Jump to content


Photo

Fixing Fonts


  • Please log in to reply
No replies to this topic

#1 Helen Brown

Helen Brown

    Mithril

  • Admin
  • 8,490 posts
  • Gender:Female
  • Location:heart in Israel
  • Accordance Version:11.x

Posted 10 July 2007 - 07:07 AM

There are two font issues with our fonts in Mac OS X, which are sometimes confused. The first is when they do not display correctly within Accordance, and the second, detailed far below, is when certain characters get substituted in Word or other OS X programs.

--------------------

Font Display in Accordance

The first step is to make sure that you have the latest version of Accordance and the latest fonts, which isbest accomplished by downloading the latest installer.

If the fonts still do not appear correctly, try turning off the smoothing in Accordance Preferences/Appearance. If they now display correctly, you have a problem with FontBook. This is not an adequate fix, just a diagnostic step, you will not be happy without font smoothing.

1. First try the FontFixer utility for your version of Accordance, found on the same download page. It does the same cleanup as the new installers, but installs only the Truetype files.
2. If this fails try these instructions for removing duplicates from FontBook:
In Font Book:

Open Font Book by clicking on any font.
Look at the font name, if there is a black dot beside the name, select the Font and choose Resolve Duplicates from the Edit menu.
If this does not correct the problem when restarting Accordance, go back to Font Book
Choose Preview>Show Font Info
Open each font triangle and select each item within it, and either Disable (Edit menu) or Remove (File menu) each item EXCEPT the ones you want to keep, which are those in the .famTrueType in Library/Fonts. Look at them all first, and you will see where each copy is.

3. If you still have problems:

If your fonts are garbled, or if there are fonts that won’t empty from the Trash even after you restart your Mac, try deleting the Mac OS X font caches.
You can do this manually by finding and removing these files:

• In /System/Library/Caches:
• fontTablesAnnex
(fontTablesAnnex contains the character encodings/mappings for all of the fonts on your system. Information in this file can lead to garbled text.)
• com.apple.ATS.System.fcache
• com.apple.ATSServer.FODB_System
• In /Library/Caches:
• com.apple.ATS
• In your home directory’s Library/Preferences folder:
• com.apple.ATS.plist

Or use a FontCache utility like this one:
http://www.jamapi.com/pr/fn/
I have NOT tested it myself.

5. Here is an even more complicated fix routine suggested on our Forum:

I had a similar problem after installing some modules with older installs. Even though the 5.7 or later installs work to install modules, I find that in some cases they leave some OS 9 fonts on the disk. Mac OS X is really smart and locates the OS 9 or other fonts and puts them in its font subsystem, "just in case".

Here's some steps to try. You'll need to do them in order. This is how I solved my problem.

1) Remove all the Accordance fonts from FontBook
Helena
Yehudit
Peshitta
Rosetta
Sylvanus
MSS

2) Search and remove all Accordance fonts from the file system. If you see any that are "bitmap" or "postscript" fonts delete them too. They will usually only be in <some long directory path>/font[s]
Accord* (Obviously only delete "font" "fon" "FFIL" "TTF" files)
Helen*
Yehud*
Peshitta
Rosett*
Sylvan*
MSS*

--- Make sure of this. I have had a case where the font subsystem was using an OS 9 version of the font, even though I had deleted from Font Book. Font Book does not always delete the font file.

3) After you are sure that all Accordance Fonts are gone: reboot

4) Run Font Book and make sure they are gone. Run your word processor (Mellel, NeoOffice or Word) and make sure they don't show in the font list.

5) Run Disk Utility and verify/fix permissions on your disk--- I had a couple program fail install because of this.

6) Reinstall 7.3 (The Accordance program only-- I assume that the modules are all installed and you're only running the 7.3 install; if you run an older install to install modules, you'll need to go to step 1).

7) Reboot (I know, feels like Windows again...)

8) Check Font Book for any duplicates-- any there? If so, you'll need to call Tech Support.

9) Try Accordance does it work? No, try the following...

10) What locale are you using? It may not matter for most of the Accordance modules, but maybe for a few. I don't know, but you could set it to "US"


--------------------

Font Character Substitution in Other Programs

This is a known problem with programs that do Quartz smoothing substituting some of our characters. The bad characters that Apple substitutes for some of the cantillation marks in Hebrew (and accents in Greek) occur only in the newer programs that use Quartz smoothing such as Text Edit and Word for Mac 2004, not in AppleWorks for example. There is nothing that we can do about it, short of changing the font layout which would void all our current modules, as well as users' documents using our fonts. Please read the Accordance Fonts.pdf for a summary of the issues, and also the PDF User's Guide, and the Help files on exporting text.

The most common problem is with the rough breathing over alpha and omega in Greek. It shows up only in two places on the E, and only with rare cantillation marks in Yehudit which is avoided by stripping the marks. Anytime people are talking about problems with these fonts in TextEdit, Word, KeyNote, PowerPoint, etc., etc. this is usually what it is.

Greek:
Version 7.2 and up of Accordance does the following recommended substitutions in Greek automatically when exporting Helena via the clipboard or drag-and-drop:
replace the apple (shift-option-k) with shift-j (replaces the rough breathing over the alpha and omega) (Matt 1:21 etc.)
replace fl (shift-option-6) with option-8 (replaces the the grave accent and rough breathing mark before capital E) (Eph 4:4, 2 Pet 3:8).
replace fi (shift-option-5) with option-- (not found in our texts)
replace € (shift-option-2) with option-= (not found in our texts)

Hebrew, Gen 6:4,19:
You can either remove or manually replace these characters with approximations in Yehudit:
replace fl (shift-option-6) with nothing
replace fi (shift-option-5) with shift-h
replace € (shift-option-2) with shift-option-c and space

or replace them with the correct Unicode character (for Unicode compliant software)
replace fl (shift-option-6) with U+05A0 (telisha gedola)‏‏֠
replace fi (shift-option-5) with U+059E (gershayyim)‏֞
replace € (shift-option-2) with U+05AE (tsinnor)‏֮

If you convert the text to Unicode you avoid the character substitution. However, Word for Mac does not support the Hebrew properly. Text Edit, Mellel and Nisus do. Accordance does not use Unicode but will convert the text on export depending on the settings in Preferences/Greek & Hebrew. You can also try converting to one of the other fonts we offer, if you have those fonts.

Although Word 2004 on Mac does not handle Hebrew well (it does on Windows), you can paste Hebrew Unicode into Word by:
Selecting a Unicode font such as Cardo or Lucida Grande, first
Then selecting Paste Special from the Edit menu, and Unformatted Text from the submenu (not Styled Text).
Helen Brown
OakTree Software




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users