Jump to content


Photo

Selecting text


  • Please log in to reply
1 reply to this topic

#1 Joel Nelson

Joel Nelson

    Member

  • Members
  • Pip
  • 2 posts

Posted 06 September 2012 - 03:13 PM

There continues to be a problem with selecting text in Bible text search results.

9.x and earlier behavior:
Enter text search, e.g. Judges 7:1-25
Press command+A to highlight all
Edit -> Copy As in order to get the appropriate format for use

Since 10, continuing into 10.0.2
Enter text search, e.g. Judges 7:1-25
Press command+A to highlight all

Much more than just the intended search area gets highlighted

Manually highlight Judges 7:1-25 by click and drag

Once the window starts scrolling, the area that appears to be selected changes. For example, though verse 1 might still copy, once I start scrolling down verse 1 no longer appears to be selected.

Loss of command+A to highlight just the search result text also seems like a large loss in functionality.

#2 Joel Brown

Joel Brown

    Administrator

  • Admin
  • 2,494 posts
  • Gender:Male
  • Location:Houston, TX
  • Accordance Version:10.x

Posted 06 September 2012 - 03:38 PM

This is a nature of the Auto Context feature in Accordance 10. Most users like the context to automatically adjust to their search, so if they search for Judges 7:1, it shows that verse in the context of the entire text. But, if you don't want to show it in the entire text, take the context slider (left of the 'Verse x of x' text) and move it from A down to zero. That'll limit the display to just your verses, so when you Command-A, it'll only select those verses.

If you never want Accordance to automatically adjust the context for you, you can turn it off in Preferences -> Search Tabs -> Add automatic context.
Joel Brown

By day: Consultant for Oaktree
By night: Freelance Trombonist and Private Instructor




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users