Jump to content


Photo

Accordance 10 has gone haywire


  • Please log in to reply
43 replies to this topic

#21 Randy Cue

Randy Cue

    Gold

  • Active Members
  • PipPipPipPip
  • 262 posts
  • Gender:Male
  • Location:Plano, Illinois
  • Interests:Teaching adult Sunday School, baseball
  • Accordance Version:10.x

Posted 23 August 2012 - 01:12 PM

I came back from the walk, Accordance crashed processing the request (?too many tools) and I'm back to the corrupted library... :(


Amy, did you try to open them one tool at a time? That's what I did and it worked for me. You then have to go back and delete module that are in the wrong tool folder.

Soli Deo Gloria,
Randy

#22 Helen Brown

Helen Brown

    Mithril

  • Admin
  • 8,267 posts
  • Gender:Female
  • Location:heart in Israel
  • Accordance Version:10.x

Posted 24 August 2012 - 05:21 AM

I suggested to Amy that she restore her user/Library/Preferences/Accordance Preferences from a backup (Timemachine) and apparently this worked for her. If you don't have a backup you can simply delete the entire Preferences folder, and Accordance will restore it (without your individual settings of course).
Helen Brown
OakTree Software

#23 Amy

Amy

    Silver

  • Active Members
  • PipPipPip
  • 158 posts
  • Gender:Female
  • Accordance Version:10.x

Posted 26 August 2012 - 09:51 AM

Randy: I have quite a number of Tool modules and it was rather tedious to manually add them one by one. I tried to open all at one go, and Accordance crashed - I think for the same reason, trying to open too many modules at one go. So I took the Preference Folder route...

Helen: I restored the preferences folder from a backup, and the library is not corrupt anymore. I have lost my Syntax from add parallel and I don't know if this was related to the corrupted library. After reading your post I deleted the preferences folder altogether, and Accordance did make a new Preferences folder, but still no go, no Syntax. Would be grateful if you would let me know, when you have some idea how it might be fixed. :)

#24 Helen Brown

Helen Brown

    Mithril

  • Admin
  • 8,267 posts
  • Gender:Female
  • Location:heart in Israel
  • Accordance Version:10.x

Posted 26 August 2012 - 10:09 AM

Joel will have to suggest how to tell Accordance it's not installed so it will add it again.
Helen Brown
OakTree Software

#25 Joel Brown

Joel Brown

    Administrator

  • Admin
  • 2,810 posts
  • Gender:Male
  • Location:Houston, TX
  • Accordance Version:10.x

Posted 27 August 2012 - 12:57 PM

You need to be sure to remove the Syntax preference files from both ~/Library/Preferences/Accordance Preferences/ and ~/Library/Application Support/Accordance/Accordance Preferences to remove it. You *may* also need to remove the General preference file from both, but I'm not sure if thats necessary as well. Try removing just the Syntax files first.
Joel Brown

By day: Consultant for Oaktree
By night: Freelance Trombonist and Private Instructor

#26 twbeining

twbeining

    Bronze

  • Active Members
  • PipPip
  • 74 posts
  • Gender:Male
  • Location:Snow & Ice Central Pennsylvania
  • Interests:Bible Study, iMac, MacBook Pro, & iPad Mini
  • Accordance Version:10.x

Posted 03 October 2012 - 02:04 PM

Hi All,

I think we need to revisit this topic.

This happened to me again today and I think I know why it did it now.

The first time this happened to me I stated that I thought it might have been my fault. That is not the case this time around and I doubt it was the first time. It is a bug of some kind in the Library Pane. Yesterday I was rearranging and alphbetizing Texts and Tools in the Library Pane. Last night I shut my iMac down to move it (rearranging my office space in my home). I plugged it back in this morning and fired it up. Started Accordance and it told me one of my Reference books was not available. I had a bad feeling about that as that is what it did the first time this happened. Needless to say it had happened again. Moved my books around the same way it did the first time. The first time this happened I had rearranged and alphebtized the same as this time. I changed no other settings so the problem is definately in the Library Pane. I followed Helen's directions above and got it fixed again. Right now I am afraid if I rearrange (prioritize) and alphebtize my tools it may do this again.

I certainly hope you guys can duplicate this error and get this fixed.

Blessings,
Tim

Edited by twbeining, 03 October 2012 - 02:32 PM.


#27 Helen Brown

Helen Brown

    Mithril

  • Admin
  • 8,267 posts
  • Gender:Female
  • Location:heart in Israel
  • Accordance Version:10.x

Posted 03 October 2012 - 02:09 PM

We looked hard in the code of the Library and did fix a couple of errors for 10.0.4 but we are not sure we got this fixed as it is not reliably reproducible. Please post any reports of it happening with 10.0.4.

The easiest way to fix it is simply to remove tools in the Library that are in the wrong place, and use the Add Modules at the bottom to add them back.

So sorry for the hassles.
Helen Brown
OakTree Software

#28 Tony Lawrence

Tony Lawrence

    Gold

  • Active Members
  • PipPipPipPip
  • 240 posts
  • Gender:Male
  • Location:McMinnville, TN
  • Interests:Hosting Bible Land Tours, Expository Preaching, My granddaughter
  • Accordance Version:10.x

Posted 03 October 2012 - 02:34 PM

I know its been a long day, but did you mean 10.0.2 instead of 10.0.4? That's the latest available according to mine.
Tony Lawrence
biblelandphotos.org

#29 twbeining

twbeining

    Bronze

  • Active Members
  • PipPip
  • 74 posts
  • Gender:Male
  • Location:Snow & Ice Central Pennsylvania
  • Interests:Bible Study, iMac, MacBook Pro, & iPad Mini
  • Accordance Version:10.x

Posted 03 October 2012 - 02:35 PM

Thanks Helen!

I hope you got it in 10.0.4. When will that update be out?

Blessings,
Tim

#30 twbeining

twbeining

    Bronze

  • Active Members
  • PipPip
  • 74 posts
  • Gender:Male
  • Location:Snow & Ice Central Pennsylvania
  • Interests:Bible Study, iMac, MacBook Pro, & iPad Mini
  • Accordance Version:10.x

Posted 03 October 2012 - 02:42 PM

Tony,

That is an interesting thought. If she meant 10.0.2 then the problem is not fixed as I am running 10.0.2. If not and she meant 10.0.4 then I look forward to the next update.

Blessings,
Tim

Edited by twbeining, 03 October 2012 - 03:40 PM.


#31 Michael J. Bolesta

Michael J. Bolesta

    Platinum

  • Active Members
  • PipPipPipPipPip
  • 692 posts
  • Gender:Male
  • Location:Addison TX
  • Interests:scripture study, preaching, teaching
  • Accordance Version:10.x

Posted 03 October 2012 - 02:51 PM

Helen had a post (that I cannot find) indicating that 10.0.3 was awaiting app store approval and that they were working on 10.0.4
Michael

#32 Tony Lawrence

Tony Lawrence

    Gold

  • Active Members
  • PipPipPipPip
  • 240 posts
  • Gender:Male
  • Location:McMinnville, TN
  • Interests:Hosting Bible Land Tours, Expository Preaching, My granddaughter
  • Accordance Version:10.x

Posted 03 October 2012 - 03:01 PM

The installer download page list 10.0.4. http://www.accordanc...nce-Installers/
Tony Lawrence
biblelandphotos.org

#33 twbeining

twbeining

    Bronze

  • Active Members
  • PipPip
  • 74 posts
  • Gender:Male
  • Location:Snow & Ice Central Pennsylvania
  • Interests:Bible Study, iMac, MacBook Pro, & iPad Mini
  • Accordance Version:10.x

Posted 03 October 2012 - 03:27 PM

Tony,

By the look of the information on the download page in your link, I would think 10.0.4 update will be out sometime today.

Blessings,
Tim

Edited by twbeining, 03 October 2012 - 03:34 PM.


#34 Joel Brown

Joel Brown

    Administrator

  • Admin
  • 2,810 posts
  • Gender:Male
  • Location:Houston, TX
  • Accordance Version:10.x

Posted 03 October 2012 - 04:12 PM

10.0.4 is now available via In-App update.
Joel Brown

By day: Consultant for Oaktree
By night: Freelance Trombonist and Private Instructor

#35 twbeining

twbeining

    Bronze

  • Active Members
  • PipPip
  • 74 posts
  • Gender:Male
  • Location:Snow & Ice Central Pennsylvania
  • Interests:Bible Study, iMac, MacBook Pro, & iPad Mini
  • Accordance Version:10.x

Posted 03 October 2012 - 04:17 PM

Thanks Joel,

I hope this fixes it. If not I will do my best to keep track of what I do that causes the problem.

Blessings,
Tim

#36 twbeining

twbeining

    Bronze

  • Active Members
  • PipPip
  • 74 posts
  • Gender:Male
  • Location:Snow & Ice Central Pennsylvania
  • Interests:Bible Study, iMac, MacBook Pro, & iPad Mini
  • Accordance Version:10.x

Posted 05 October 2012 - 04:40 PM

Hi All,

This has now happened a third time. I updated to 10.0.4 yesterday and that did not fix the problem. I do now know exactly what I did to cause it and I hope this will help the gang at Accordance to fix it.

I decided just a little while ago to try to alphabetize my Reference Tools in the Library Pane again after updating to 10.0.4. I did the same thing I did the other two times. I clicked on Reference Tools to give it focus, then I right clicked to get the menu and selected Alphabetize. When I did I saw the tools section in the Library move into alphabetical order and I got that bad feeling again. All the books had moved again.

Needless to say I once again followed Helen's directions to fix the problem.

I am thinking that trying to alphabetize at the Reference Tools folder level in the Library Pane is not a good thing to do and that is what caused the problem. Alphabetizing inside the folder works just fine and did not seem to cause a problem. Moving books up and down in the folder to prioritize caused no problem either.

Hope this helps you folks at Accordance track down and fix this problem.

All of you at Accordance are the best! Thanks for an excellent program!

Blessings,
Tim

Edited by twbeining, 05 October 2012 - 04:41 PM.


#37 Joel Brown

Joel Brown

    Administrator

  • Admin
  • 2,810 posts
  • Gender:Male
  • Location:Houston, TX
  • Accordance Version:10.x

Posted 06 October 2012 - 09:39 AM

Thank you, and thank you again, Tim for finally diagnosing the issue! I had some theories about alphabetization, but didn't realize people were selecting 'Reference Tools' itself to Alphabetize, not one of the inner modules. Thanks to your report, I've finally been able to track down and fix the bug. We'll probably be posting 10.0.5 a bit ahead of schedule to get this bug fix out ASAP. Thanks again.
Joel Brown

By day: Consultant for Oaktree
By night: Freelance Trombonist and Private Instructor

#38 twbeining

twbeining

    Bronze

  • Active Members
  • PipPip
  • 74 posts
  • Gender:Male
  • Location:Snow & Ice Central Pennsylvania
  • Interests:Bible Study, iMac, MacBook Pro, & iPad Mini
  • Accordance Version:10.x

Posted 07 October 2012 - 06:20 PM

Joel,

I'm just glad this was a good enough description to help you figure this one out. I am pretty new to Mac and Accordance. My only hope was that I could remember what I did and be able to explain it well enough for you to understand.

Thank you Joel and everyone else at Accordance for all you do!

Blessings,
Tim

#39 millca

millca

    Member

  • Active Members
  • Pip
  • 27 posts
  • Gender:Female
  • Location:Seattle, WA
  • Accordance Version:10.x

Posted 17 October 2012 - 07:03 PM

Any further word on when the 10.0.5 update will be arriving. I've bumped into this same bug numerous times today and I finally went online to see if anyone else was having the same issue with their Library pane and Tools not showing up correctly (after trying out the alphabetize feature). I'm eagerly awaiting the 10.0.5 update which will hopefully truly squash this bug. :)
Christi Milligan
Accordance 10.x

#40 Helen Brown

Helen Brown

    Mithril

  • Admin
  • 8,267 posts
  • Gender:Female
  • Location:heart in Israel
  • Accordance Version:10.x

Posted 18 October 2012 - 07:05 AM

We have just posted the release candidate and you are welcome to download it here. I am not sure that it will fix a corrupted Library but it should prevent a further corruption. You can remove any modules from the Library that are showing up in the wrong section, and then use Easy Install to reinstall them. Please let us know how it goes.
Helen Brown
OakTree Software




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users