Jump to content


Photo

Auto Insert Doesn't work with Pages '08 on Leopard


  • Please log in to reply
9 replies to this topic

#1 Levi Durfey

Levi Durfey

    Bronze

  • Active Members
  • PipPip
  • 90 posts
  • Gender:Not Telling
  • Accordance Version:Non-user

Posted 29 December 2007 - 03:57 PM

Hi...

I am having a problem with the Accordance Widget's auto-insert feature. It works if I am pasting into Textedit, but with Pages '08 I only get an error sound. I am using Leopard 10.5.1, Accordance 7.4.2 with Widget 1.6. I have deleted the widget, and the widget preferences, reinstalled 7.4.2., restarted the computer, and Cmd-R'ed it a couple times.

I just upgraded from 10.4.11, on which everything worked fine.

Is there another widget update in the works? Or is there more that I could do?

Thanks, Pastor Levi

#2 Joel Brown

Joel Brown

    Administrator

  • Admin
  • 2,486 posts
  • Gender:Male
  • Location:Houston, TX
  • Accordance Version:10.x

Posted 30 December 2007 - 01:55 AM

I am not entirely sure what is causing this problem, as it works fine for Pages '08 with me. Are you running on an Intel computer? Also, does this work with a blank, new Pages document? Finally, try resetting Access for Assistive Devices. Its found at the bottom of the screen in System Preferences -> Universal Access. Let me know how that goes.
Joel Brown

By day: Consultant for Oaktree
By night: Freelance Trombonist and Private Instructor

#3 Levi Durfey

Levi Durfey

    Bronze

  • Active Members
  • PipPip
  • 90 posts
  • Gender:Not Telling
  • Accordance Version:Non-user

Posted 31 December 2007 - 07:34 AM

Yes, I am running an Intel computer. In fact, I put Accordance on my home computer to try it, and the same thing happens. I did try both your suggestions, to no avail. I can also auto-insert into mail and bean as well as textedit--it seems limited to pages (and numbers and keynote). I do get an error sound when I attempt auto-insert, it's that soft "bump" sound.

EDIT--Problem solved--I hope. I deleted the iwork preferences from ~/library/preferences. That did the trick for all three iwork apps. The upgrade to leopard must have corrupted the preferences somehow.

Thanks for your help.

Edited by Helen Brown, 31 December 2007 - 08:22 AM.


#4 Levi Durfey

Levi Durfey

    Bronze

  • Active Members
  • PipPip
  • 90 posts
  • Gender:Not Telling
  • Accordance Version:Non-user

Posted 03 January 2008 - 09:01 AM

Well, the problem isn't solved. It keeps coming back, sometimes even worse, as the auto-insert will refuse to paste into anything, including textedit. I go through the round of deleting widget preferences, reinstalling the widget, etc., and it will insert into textedit, but not pages. I delete the pages preference file and it will insert into pages. Restart the computer, and I am back to square one...no auto insert at all.

Please help, auto insert was as natural to me as typing.

Pastor Levi

#5 Helen Brown

Helen Brown

    Mithril

  • Admin
  • 7,979 posts
  • Gender:Female
  • Location:heart in Israel
  • Accordance Version:10.x

Posted 03 January 2008 - 02:54 PM

This sounds more and more weird. It does not sound as if it is a problem with the widget itself. Please run your Disk Utility and check and clean up permissions on your drive. If that does not help, maybe you need more sophisticated disk tools.
Helen Brown
OakTree Software

#6 Levi Durfey

Levi Durfey

    Bronze

  • Active Members
  • PipPip
  • 90 posts
  • Gender:Not Telling
  • Accordance Version:Non-user

Posted 04 January 2008 - 08:33 AM

I did a couple things: I used Onyx to delete the caches. I repaired disk permissions. Things seem to be working fine for the moment.
Pastor Levi

#7 Levi Durfey

Levi Durfey

    Bronze

  • Active Members
  • PipPip
  • 90 posts
  • Gender:Not Telling
  • Accordance Version:Non-user

Posted 04 January 2008 - 05:33 PM

I think I located the problem (at least the part where it wouldn't auto-insert into Pages 08). In my iWork apps I like to change the keyboard shortcuts for "paste" and "paste and match style." I use "paste and match style" frequently, so I assigned it to Command-V. To do so, I used the following terminal commands:

defaults write com.apple.iWork.Pages NSUserKeyEquivalents '{"Paste"="@~V"; "Paste and Match Style"="@V";}'
defaults write com.apple.iWork.Keynote NSUserKeyEquivalents '{"Paste"="@~V"; "Paste and Match Style"="@V";}'
defaults write com.apple.iWork.Numbers NSUserKeyEquivalents '{"Paste"="@~V"; "Paste and Match Style"="@V";}'

After deleting the iwork preference files the last time Auto-Insert broke, I carefully changed the preferences until I found the one that made Auto-Insert not work, which were the above changes.

The thing is, I used the same changes under 10.4.11 (and Accordance 7.4.2 with widget 1.6) and everything worked fine. Now on 10.5.1 it breaks auto-insert.

For now, I'll guess I won't change the keyboard shortcuts, but I thought you'd like to know the cause (and you can test it for yourself, perhaps).

Pastor Levi

Edited by Levi Durfey, 04 January 2008 - 05:36 PM.


#8 Joel Brown

Joel Brown

    Administrator

  • Admin
  • 2,486 posts
  • Gender:Male
  • Location:Houston, TX
  • Accordance Version:10.x

Posted 04 January 2008 - 07:31 PM

Thanks for the heads-up. You definitely found the cause of the problem. The way the auto-paste works, is it first copies it to a temporary clipboard, then moves to your app, and actually physically types Command-V. I had to change the functionality a little bit on the recent releases, as as you noticed, on Leopard the keyboard shortcuts for Paste and Match Style changed around to Command-Shift-Option-V. Basically, the way the script works is if you have Leopard, it does that new command (as it seemed to be pretty universal), while Tiger retains the old command. Even so, it *should* still be working with your changed key-commands. My guess is that writing those non-standard preferences gives the widget a hiccup when trying it. Stay tuned, though, I'm working on an update that should address that issue (among others, namely pasting in unicode-a-phobic MS Word...)
Joel Brown

By day: Consultant for Oaktree
By night: Freelance Trombonist and Private Instructor

#9 Joel Brown

Joel Brown

    Administrator

  • Admin
  • 2,486 posts
  • Gender:Male
  • Location:Houston, TX
  • Accordance Version:10.x

Posted 08 January 2008 - 10:07 PM

An update is in testing now that should solve your issues, enabling you to redo your key commands if you like. The pasting is now menu item dependent, not key combo dependent, so as long as you don't rename Paste to "Insert into my document" you should be fine! Stay posted soon for a release, assuming testing goes well. (for those who can't paste into Word 2004, this fixes that too... I think)
Joel Brown

By day: Consultant for Oaktree
By night: Freelance Trombonist and Private Instructor

#10 Joel Brown

Joel Brown

    Administrator

  • Admin
  • 2,486 posts
  • Gender:Male
  • Location:Houston, TX
  • Accordance Version:10.x

Posted 16 January 2008 - 12:48 PM

An update is in testing now that should solve your issues, enabling you to redo your key commands if you like. The pasting is now menu item dependent, not key combo dependent, so as long as you don't rename Paste to "Insert into my document" you should be fine! Stay posted soon for a release, assuming testing goes well. (for those who can't paste into Word 2004, this fixes that too... I think)


The updated widget is now available here.
Joel Brown

By day: Consultant for Oaktree
By night: Freelance Trombonist and Private Instructor




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users