Jump to content


Photo

Copy and Paste bug


  • Please log in to reply
13 replies to this topic

#1 Mortensen

Mortensen

    Member

  • Members
  • Pip
  • 8 posts
  • Accordance Version:9.x

Posted 13 July 2013 - 04:11 AM

Since the update to 10.2 yesterday, I can no longer copy the Bible text from Japanese nor Scandinavian characters such as  ø, ð, á, í, ó, ý, into word or mellel. Those characters become scrambled. However, somehow it works if I copy the text first to my accrdance note, and then to word or mellel. I hope this bug can be fixed.

Keep up the good work.

Mortensen

 

 

 

 



#2 justin4jesus

justin4jesus

    Member

  • Active Members
  • Pip
  • 39 posts
  • Gender:Male
  • Accordance Version:10.x

Posted 19 July 2013 - 08:13 AM

I am having the same problem copying Greek text and pasting into a text document. The formatting is shatttered and charachters are inserted. This is a critical need for me as it's a part of my daily work pasting the text from Accordace!



#3 Julie Falling

Julie Falling

    Platinum

  • Active Members
  • PipPipPipPipPip
  • 1,362 posts
  • Gender:Female
  • Location:Tennessee
  • Interests:Numerous!
  • Accordance Version:11.x

Posted 19 July 2013 - 09:43 AM

Hey — I just gave this a try.  I copied (⌘C) a few verses of GNT28-T and pasted (⌘P) into Text Edit.  It copied perfectly.  Something else is going on here.
 
Accordance 10.2
OS 10.8.4
2013 MacBook Air i7

Edited by Julie Falling, 19 July 2013 - 09:44 AM.

Julia Falling

 

Accordance 11

MacBook Air Yosemite

mid-2013 1.7 GHz Intel Core i7 (2 cores)

8 GB RAM; 512 G SSD

 

Mac mini Yosemite Acc 11

late-2012 2.3GHz Intel Core i7 (4 cores)

16 GB RAM; 1.12  TB Fusion Drive

 

iPad Air 1 iOS 8.1

64 GB

 

 

 

 


#4 Joel Brown

Joel Brown

    Administrator

  • Admin
  • 2,995 posts
  • Gender:Male
  • Location:Houston, TX
  • Accordance Version:11.x

Posted 19 July 2013 - 03:04 PM

I'm not able to reproduce this, either.  How are you doing the Copy?  And could you post your Preferences -> Export settings?


Joel Brown

By day: Consultant for Oaktree
By night: Freelance Trombonist and Private Instructor

#5 justin4jesus

justin4jesus

    Member

  • Active Members
  • Pip
  • 39 posts
  • Gender:Male
  • Accordance Version:10.x

Posted 25 July 2013 - 07:31 AM

I am unable to post the screenshots of my export preferences and the pasted text with errors. I keep getting a message that the format is unsupported in this forum, regardless of the file format I use.

How can I post my screenshots?



#6 justin4jesus

justin4jesus

    Member

  • Active Members
  • Pip
  • 39 posts
  • Gender:Male
  • Accordance Version:10.x

Posted 25 July 2013 - 08:10 AM

Here is a link to the export preferences and a link to the pasted output with those settings changed:

Export settings:

http://i1220.photobu...25at52446AM.png

 

Pasted text:

http://i1220.photobu...25at54524AM.png



#7 Mike Garrity

Mike Garrity

    Gold

  • Accordance
  • 321 posts
  • Gender:Male
  • Location:Florida
  • Accordance Version:10.x

Posted 25 July 2013 - 03:19 PM

Justin,

 

Sorry for your troubles!

 

I think I recreated the problems with pasting text using non Unicode Helena into OpenOffice 4.0.0, Is this new to 10.2? (I don't think we changed anything about non Unicode exporting) 

 

Here is my recreation in Open Office:

OpenOffice%20Paste.png

 

Mike


Edited by Mike Garrity, 25 July 2013 - 03:21 PM.


#8 Mortensen

Mortensen

    Member

  • Members
  • Pip
  • 8 posts
  • Accordance Version:9.x

Posted 31 July 2013 - 04:17 AM

Thanks for the replies. Since the new Update (10.2.1) this problem no longer occurs for me. Wonderful

Hallur



#9 Chris Regas

Chris Regas

    Member

  • Active Members
  • Pip
  • 40 posts
  • Gender:Male
  • Accordance Version:10.x

Posted 02 August 2013 - 12:13 PM

I am having the following problems with copy and pasting...see attached jpeg.

 

I cannot copy and paste Helena without paragraph markers for the Greek "p" - unless I change the DEFAULT font under export to Times New Roman, but I prefer to use Arial.

 

I cannot copy and paste the SBL Greek font into Word without it showing up as Helena.

Attached Files


Edited by Chris Regas, 02 August 2013 - 12:44 PM.

Chris[B][I][FONT=Arial][COLOR=blue]

#10 Ken Simpson

Ken Simpson

    Platinum

  • Accordance
  • 1,729 posts
  • Gender:Male
  • Location:Sydney, Australia
  • Interests:Astronomy
    Archaeology
    Physics
    Hebrew and Greek
    Papyrology
    Orthopædic Surgery
    Yosemite 10.10.1
  • Accordance Version:11.x

Posted 02 August 2013 - 05:44 PM

Hi Chris,

copying and pasting unicode (the best thing to do) without a font set up in the preferences will paste in the current font in Word (or LibreOffice etc). Have you tried setting SBL Greek as your export font? That should produce your desired result without the extra step.

 

Attached File  Preferences.png   147.5KB   29 downloads


Regards
Ken
Lead Australian Accordance Demonstrator

Administrator, Accordance Exchange

Assistant Minister, Summer Hill Church


#11 jwolters

jwolters

    Member

  • Members
  • Pip
  • 7 posts
  • Accordance Version:10.x

Posted 11 September 2013 - 02:30 PM

I am also having this problem. Certain Greek characters don't transfer properly when pasted into MS Word.



#12 Helen Brown

Helen Brown

    Mithril

  • Admin
  • 8,431 posts
  • Gender:Female
  • Location:heart in Israel
  • Accordance Version:11.x

Posted 11 September 2013 - 11:16 PM

Chris: You should update to 10.2.4.

 

I do not think that your Unicode export is working in all the cases in your image above. Please send me an email or a PM and arrange to screenshare.


Helen Brown
OakTree Software

#13 justin4jesus

justin4jesus

    Member

  • Active Members
  • Pip
  • 39 posts
  • Gender:Male
  • Accordance Version:10.x

Posted 19 September 2013 - 07:44 AM

Copy and paste still broken after updates to 10.2.4.

The work around I've been using is to paste into OSX Textedit first, then carry over to my editor of choice. For some reason that works. I was able to paste directly into Open Office until the 10.2 update.

Something is broken within Accordance at this point but a workaround is easy, albeit a nuisance.



#14 jwolters

jwolters

    Member

  • Members
  • Pip
  • 7 posts
  • Accordance Version:10.x

Posted 07 November 2013 - 09:54 PM

I am still having the same problem when not using a unicode font such as Yehudit or Helena.  I have also been having problems with importing Hebrew with Times New Roman where whole Hebrew words get placed in reverse order or sometimes all the letters are in reverse order.

 

2Kings 14:2 b;RN_oRcVrîyM w◊jDmEv vDnÎh hDyDh bVmDlVkwø w◊oRcVrîyM wÎtEvAo vDnÎh mDlAKJ b;Iyrw…vDlDÊM w◊vEM aIm;wø y◊hwøoAd;îyN ]y◊hwøoAd;∂N[ mIN_y◊rw…vDlDÊM:






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users