Jump to content


Photo

Copy and Paste broken after update to 10.2


  • Please log in to reply
10 replies to this topic

#1 justin4jesus

justin4jesus

    Member

  • Active Members
  • Pip
  • 39 posts
  • Gender:Male
  • Accordance Version:10.x

Posted 19 July 2013 - 08:19 AM

Intel MacBook 10.8.4 just updated Accordance to 10.2

 

I can no longer paste copied Greek text from Accordance, the formatting is shattered and extra charachters are inserted. This is something I use daily, pasting Greek text into an editor and building my notes and study.

 



#2 Ken Simpson

Ken Simpson

    Platinum

  • Accordance
  • 1,830 posts
  • Gender:Male
  • Location:Sydney, Australia
  • Interests:Astronomy
    Archaeology
    Physics
    Hebrew and Greek
    Papyrology
    Orthopædic Surgery
    Yosemite 10.10.1
  • Accordance Version:11.x

Posted 19 July 2013 - 06:32 PM

Hi Justin, can you please post a screenshot of what happens? It's working fine for me using copy as citation and pasting into Mellel.

 

What are you pasting into? Are you sure that "export all characters as Unicode" is still turned on in your Export preferences?

 

Thanks


Regards
Ken
Lead Australian Accordance Demonstrator

Administrator, Accordance Exchange

Assistant Minister, Summer Hill Church


#3 justin4jesus

justin4jesus

    Member

  • Active Members
  • Pip
  • 39 posts
  • Gender:Male
  • Accordance Version:10.x

Posted 25 July 2013 - 07:33 AM

I am unable to post a screenshot as I keep getting an error that the file format in unsupported in this forum regardless of which format I use. What am I missing to be able to post a screenshot?



#4 justin4jesus

justin4jesus

    Member

  • Active Members
  • Pip
  • 39 posts
  • Gender:Male
  • Accordance Version:10.x

Posted 25 July 2013 - 07:41 AM

Checking "export all charachters as unicode" changes the font dramaticlly to a sanserif Greek but still damages the formating by inserting charachters and, odly enough, paragraph markers within words.



#5 justin4jesus

justin4jesus

    Member

  • Active Members
  • Pip
  • 39 posts
  • Gender:Male
  • Accordance Version:10.x

Posted 25 July 2013 - 08:11 AM

Here is a link to the export preferences and a link to the pasted output with those settings changed:

Export settings:

http://i1220.photobu...25at52446AM.png

 

Pasted text:

http://i1220.photobu...25at54524AM.png



#6 B Tan

B Tan

    Member

  • Active Members
  • Pip
  • 46 posts
  • Gender:Female
  • Accordance Version:10.x

Posted 27 July 2013 - 11:29 AM

I also have a Copy and Paste problem after upgrading to 10.2. Very inconvenient since I have stacks of exegesis homework lined up.

 

What happens for me with the NA27 as well as GNT is that when I copy (whether just Cmd + C or Ctrl-Cmd + C) text with an circumflex, the accent gets pasted as a square root sign, no matter how I fiddle with fonts.

 

With the BHS/HMT, my anything with a Qamets gets pasted as the letter plus a schwa.

 

I can type out the words, but it defeats the purpose of Copy and Paste in the first place. Plus, somehow I can never get the same font as the rest of the text in Word. But that's probably a Word issue.



#7 Ken Simpson

Ken Simpson

    Platinum

  • Accordance
  • 1,830 posts
  • Gender:Male
  • Location:Sydney, Australia
  • Interests:Astronomy
    Archaeology
    Physics
    Hebrew and Greek
    Papyrology
    Orthopædic Surgery
    Yosemite 10.10.1
  • Accordance Version:11.x

Posted 27 July 2013 - 04:48 PM

Hi,

I think there are some pesky bugs in copy and paste, seem to be new to me. For example, when I paste (after a copy as citation from the GNT28-T) the UC delta's disappear.

 

However, B Tan, try specifying your Unicode font in preferences. When I specify Times, it seems to copy and paste better...


Regards
Ken
Lead Australian Accordance Demonstrator

Administrator, Accordance Exchange

Assistant Minister, Summer Hill Church


#8 Chris Regas

Chris Regas

    Member

  • Active Members
  • Pip
  • 40 posts
  • Gender:Male
  • Accordance Version:10.x

Posted 03 August 2013 - 09:20 AM

I agree it works with Times New Roman as the designated font, which is fine if I am writing a paper. But other times I want to use Arial for a teaching lesson and it does not work with Arial. Of course I don't have to use the SBL Greek font for my own lessons. In any case it is inconvenient to have to switch back and forth.
Chris[B][I][FONT=Arial][COLOR=blue]

#9 dgillis

dgillis

    Bronze

  • Accordance
  • 79 posts
  • Gender:Male
  • Location:Fort Worth, TX
  • Accordance Version:10.x

Posted 10 September 2013 - 12:28 AM

Having the same problems with the inserting of the paragraph sign in the middle of Greek words or the square root sign where there is a circumflex. With or without Unicode selected still gives problems. With or without Helena selected as the font, still gives problems. Did not have this problem in earlier versions of 10.

 

Upon further testing ...

In MsWord for Mac, when I special paste Greek text as "styled text" it does better as long as I don't use Helena, which I find strange. I had unicode selected. With Unicode deselected, I have problems when doing a special paste into word in Greek. I get the square root sign again for the circumflex when I deselected Unicode and pasted as styled text.

 

Hebrew never did paste well except as a single word at a time. Logos has problems with Hebrew pasting and MS word for Mac as well from my testing.



#10 justin4jesus

justin4jesus

    Member

  • Active Members
  • Pip
  • 39 posts
  • Gender:Male
  • Accordance Version:10.x

Posted 19 September 2013 - 07:43 AM

Copy and paste still broken after updates to 10.2.4.

The work around I've been using is to paste into OSX Textedit first, then carry over to my editor of choice. For some reason that works. I was able to paste directly into Open Office until the 10.2 update.

Something is broken within Accordance at this point but a workaround is easy, albeit a nuisance.



#11 Slammer

Slammer

    Member

  • Members
  • Pip
  • 5 posts
  • Accordance Version:8.x

Posted 27 November 2013 - 12:47 AM

I posted in another section but will do it here tool.  In 10.3.2 when I copy bible text to import into PowerPoint for Mac slideshow, the first word of any paragraph is missing.  No problem before this.  Don't know if it is a Maverick problem or an Accordance problem...but it has been pretty embarrassing on Sunday mornings...






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users