Jump to content


Photo

Text order of MT jumbled in saved RTF searches


  • Please log in to reply
9 replies to this topic

#1 Priscilla Turner

Priscilla Turner

    Member

  • Members
  • Pip
  • 4 posts

Posted 19 September 2006 - 01:34 AM

‎Is. 7:14‏ לָכֵן יִתֵּן אֲדֹנָי הוּא לָכֶם אוֹת הִנֵּה הָ‎‏עַלְמָה ‎‏הָרָה וְיֹלֶדֶת בֵּן וְקָרָאת שְׁמוֹ עִמָּנוּ אֵל

is the way citations now lay themselves out when I save an MT search and open it up in TextEditor, Word for Windows etc. This never happened in older versions of the programme. There must be some solution, apart from picking up and moving bits of the text.

I rely on being able to do a search in the Mac and incorporate it into a Word for Windows document. Help Help! I have a paper to finish in not many days.


Ever-loving,

Prisca

#2 Ron Webber

Ron Webber

    Bronze

  • Active Members
  • PipPip
  • 88 posts
  • Gender:Male
  • Location:Independence, Missouri
  • Accordance Version:10.x

Posted 19 September 2006 - 07:59 AM

Hello Priscilla,

Open Preferences... under the Accordance menu. When the dialog box opens, select the Greek and Hebrew preferences from the list on the left. Check to see that the last item "Reverse Direction of Hebrew Characters" checkbox is selected. My guess is, everything will be okay when you select this.

Best regards,

Ron Webber

#3 Helen Brown

Helen Brown

    Mithril

  • Admin
  • 8,428 posts
  • Gender:Female
  • Location:heart in Israel
  • Accordance Version:11.x

Posted 19 September 2006 - 09:10 AM

Priscilla:

You are correctly exporting the text as Unicode so the text direction does not need to be set in Accordance. It does need to be set in Word, and there are illustrated directions for doing so in the Emulator manual, page 24.

This is our own manual for Basilisk with Accordance, and it is vitally important for every emulator user, especially new ones.
Helen Brown
OakTree Software

#4 Priscilla Turner

Priscilla Turner

    Member

  • Members
  • Pip
  • 4 posts

Posted 19 September 2006 - 06:42 PM

Priscilla:

You are correctly exporting the text as Unicode so the text direction does not need to be set in Accordance. It does need to be set in Word, and there are illustrated directions for doing so in the Emulator manual, page 24.

This is our own manual for Basilisk with Accordance, and it is vitally important for every emulator user, especially new ones.


Thankyou, Helen, but the problem originates in the Mac, and shows up in TextEdit. I would send you my .RTF file if this forum would let me. No settings in TextEdit, e.g. lengthening the line, wrapping or not wrapping, do the trick.

#5 Priscilla Turner

Priscilla Turner

    Member

  • Members
  • Pip
  • 4 posts

Posted 19 September 2006 - 06:48 PM

Hello Priscilla,

Open Preferences... under the Accordance menu. When the dialog box opens, select the Greek and Hebrew preferences from the list on the left. Check to see that the last item "Reverse Direction of Hebrew Characters" checkbox is selected. My guess is, everything will be okay when you select this.

Best regards,

Ron Webber


Thankyou, Ron, but my settings were AOK. This has something to do with the English reference, and a switch in order, not of lexemes, but of units.

#6 Helen Brown

Helen Brown

    Mithril

  • Admin
  • 8,428 posts
  • Gender:Female
  • Location:heart in Israel
  • Accordance Version:11.x

Posted 19 September 2006 - 09:03 PM

Thankyou, Helen, but the problem originates in the Mac, and shows up in TextEdit. I would send you my .RTF file if this forum would let me. No settings in TextEdit, e.g. lengthening the line, wrapping or not wrapping, do the trick.

Text Edit also lets you set the text direction to right to left, but it's hard to find: select the text, then Format/Text/writing Direction/Right-to-left.

Is. 7:14‏ לָכֵן יִתֵּן אֲדֹנָי הוּא לָכֶם אוֹת הִנֵּה הָעַלְמָה הָרָה וְיֹלֶדֶת בֵּן וְקָרָאת שְׁמוֹ עִמָּנוּ אֵל׃

True, when pasted here, the text direction is lost because this program does not offer that option, but it was correct in Text Edit and it will be correct in Word for Windows:
Attached File  isaiah.jpg   14.95KB   43 downloads

It does work whether you copy and paste or save as RTF. Word for Mac does not support Hebrew Unicode well, but Mellel and Nisus Express do.
Helen Brown
OakTree Software

#7 Priscilla Turner

Priscilla Turner

    Member

  • Members
  • Pip
  • 4 posts

Posted 19 September 2006 - 09:48 PM

I must have an older TextEdit (1.2), because I looked for that command earlier, but didn't find it.

Believe me, I see chaos in TextEdit. I have got somewhere by setting Accordance to put the references above the citations, and to leave a line between each one. An .rtf file like this, if made right-to-left in Word, and saved, not as .rtf but as a Word file, does turn out all right.

I must be really stupid, but your Attached File  isaiah.jpg   14.95KB   43 downloads conveys nothing to me, nor can I attach anything of my own here.

#8 Helen Brown

Helen Brown

    Mithril

  • Admin
  • 8,428 posts
  • Gender:Female
  • Location:heart in Israel
  • Accordance Version:11.x

Posted 19 September 2006 - 10:50 PM

I have TextEdit 1.4, and agree that earlier I had hunted in vain for this command, so maybe it's not there in yours. I highly recommend using Mellel which is a nice word procesor, excellent for Hebrew, outputs for Word or in RTF as well as many other options, is downloadable and inexpensive and has good tech support.

You add file attachments like images below the edit box on this Forum, above the Post Icons. I don't think it looks different in different browsers, but if you are accessing the Forum on Windows, I do not know how it works. My image was meant to show how the text looks in Text Edit, with the reference correctly at the beginning of the line.
Helen Brown
OakTree Software

#9 DavidKrishef

DavidKrishef

    Bronze

  • Active Members
  • PipPip
  • 51 posts
  • Gender:Male
  • Location:Grand Rapids, MI
  • Interests:Hebrew, Tanakh, Bible
  • Accordance Version:10.x

Posted 20 September 2006 - 09:52 AM

I have TextEdit 1.4, and agree that earlier I had hunted in vain for this command, so maybe it's not there in yours. I highly recommend using Mellel which is a nice word procesor, excellent for Hebrew, outputs for Word or in RTF as well as many other options, is downloadable and inexpensive and has good tech support.


Helen;

You might also recommend Nisus. It's main advantage over Mellel is that it is .rtf native, while Mellel requires exporting to .rft. When exchanging documents with Word users, not having to translate the file is one less step, which in my book is a good thing. I think Nisus has other advantages, but for the purposes of this discussion the native .rft file format is major.
David Krishef
Congregation Ahavas Israel
Grand Rapids, MI

#10 Ron Webber

Ron Webber

    Bronze

  • Active Members
  • PipPip
  • 88 posts
  • Gender:Male
  • Location:Independence, Missouri
  • Accordance Version:10.x

Posted 20 September 2006 - 12:00 PM

I am with Helen on this one. Mellel 2.1.1 handles unicode Hebrew text from Accordance flawlessly (make certain unicode export is selected in Accordance preferences); all fonts display beautifully on-screen and in print. Mellel is also highly customizable, rock-solid dependable, and very inexpensive.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users