Jump to content


Photo

Can't Copy Hebrew Text Into Page '13

#hebrew #pages

  • Please log in to reply
4 replies to this topic

#1 Charles Smith

Charles Smith

    Member

  • Members
  • Pip
  • 4 posts
  • Accordance Version:8.x

Posted 05 November 2013 - 03:00 PM

I am using OS X Mavericks, Accordance 10, and Pages '13.  I have updated all three to the latest software.  I have attempted to use the font fixer from the Accordance website.  When I try to copy and paste Hebrew text from Accordance into Pages I just get garbled characters.  Strangely enough, I can copy Hebrew into Keynote and Numbers.  I can even copy the text back out of Keynote or Numbers and paste, successfully, into a Pages document as long as there is no other English text in the document.  I spent like 90 minutes on the phone with Apple technical support and they finally said that Accordance 10 is not Mavericks compliant.  I don't think that is the issue.

 

Has anyone else experienced this?  Any possible work arounds?  Many thanks.

 

Charles+



#2 R. Mansfield

R. Mansfield

    Platinum

  • Active Members
  • PipPipPipPipPip
  • 1,048 posts
  • Gender:Male
  • Location:Kentucky
  • Accordance Version:10.x

Posted 05 November 2013 - 03:29 PM

Charles, this is interesting. First, with the export setting set to unicode, I can paste to Pages fine. However, with unicode unchecked, I ought to be able to paste into Pages and have the text in the Accordance native Yehudit font. I just tried with Genesis 1:1, using a document that already had text in it, and I got the same gibberish that I assume you got. When I selected the text, and tried to change the font to Yehudit, it did not work because Yehudit is not listed in Pages! My font list goes from Wingdings 3 to Zapfino. And yet, I can see the Greek font Helena from Accordance in the list. 

 

I had the same issue as you in that I can paste the text into Keynote without issue--although I noted that Yehudit is not in the font list there either. 

 

Interestingly, Word still has Yehudit in its font list. Of course, using Word with Hebrew can be a bit trickier as I assume you know.

 

It seems to be odd behavior in the new iWork apps more than an Accordance issue, but I don't know for certain. You can export your Hebrew by simply setting your export to Unicode. This should work just fine for you.

 

 

Rick


___
Rick Mansfield

RMansfield@mac.com
http://thislamp.com
twitter.com/thislamp
facebook.com/rmansfield

#3 Helen Brown

Helen Brown

    Mithril

  • Admin
  • 8,104 posts
  • Gender:Female
  • Location:heart in Israel
  • Accordance Version:10.x

Posted 05 November 2013 - 03:38 PM

I believe that the new Pages does handle Unicode right-to-left text better than before. Our own fonts are no longer installed in the Fonts folder, they are bundles with our app.


Helen Brown
OakTree Software

#4 R. Mansfield

R. Mansfield

    Platinum

  • Active Members
  • PipPipPipPipPip
  • 1,048 posts
  • Gender:Male
  • Location:Kentucky
  • Accordance Version:10.x

Posted 05 November 2013 - 06:06 PM

Helen, if the Accordance fonts are no longer in the Fonts folder, will that affect documents in which I've used them in the past? I've got scores of documents using both Helena and Yehudit because I've always thought they looked nicer than any other biblical language fonts available. 


___
Rick Mansfield

RMansfield@mac.com
http://thislamp.com
twitter.com/thislamp
facebook.com/rmansfield

#5 Charles Smith

Charles Smith

    Member

  • Members
  • Pip
  • 4 posts
  • Accordance Version:8.x

Posted 05 November 2013 - 07:15 PM

Thank you all for your responses.  Switching the Accordance preference to export all as unicode works.  

 

I actually used the font fixer and even reinstalled both Helena and Yehudit and still no dice in Pages.

 

I have just opened up an older document and the happy answer for me is that the text seems to hold.  If this remains the case across all of my documents, though I prefer Helena and Yehudit, unicode is not so bad.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users