Jump to content


Photo

BUG 10.3.1 - Scroll Bar's Scroll Box Not In Sync with Content


  • Please log in to reply
4 replies to this topic

#1 Matt Fredenburg

Matt Fredenburg

    Gold

  • Active Members
  • PipPipPipPip
  • 312 posts
  • Gender:Male
  • Accordance Version:10.x

Posted 05 November 2013 - 06:44 PM

I Ctrl-clicked and held on the word 'God' in Genesis 1:4 of the ESV and the following information displayed:

Attached File  Instant Details 00.png   42.56KB   0 downloads

 

 

I then clicked on the scroll box and dragged the scroll box to the bottom of the scroll area. As can be seen there's still more information to be displayed:

Attached File  Instant Details 01.png   44.84KB   0 downloads

 

 

I then clicked on the lower scroll arrow (pointed to by the red arrow) a single time, and as can be seen, the scroll box jumped to the upper half of the scroll area:

Attached File  Instant Details 02.png   46.87KB   0 downloads

 

 

This leads to a question: it appears that in almost every single scrollable window within Accordance for Windows, that the scroll box does not represent the size of the content, i.e., it's always a small rectangular box. Has this been reported as a bug elsewhere, or should I file a separate bug?

 

Matt


Specs:
  • Windows 7 SP1 x64
  • Accordance 10.3.4.2
  • Quad Xeon 2.83 GHz x2
  • 16 GB RAM
  • Nvidia 580 GTX 2GB VRAM

#2 Daniel Semler

Daniel Semler

    Platinum

  • Active Members
  • PipPipPipPipPip
  • 1,590 posts
  • Gender:Male
  • Accordance Version:11.x

Posted 05 November 2013 - 06:55 PM

HI Matt,

 

  I reported this issue in beta : http://www.accordanc...showtopic=10298.

  Doesn't explicitly point out all the cases affected though.

 

Thx

D


Accordance Configurations :
 
Mac : 2009 27" iMac                 Windows : HP 4540s laptop
      Intel Core Duo                          Intel i5 Ivy Bridge
      12GB RAM                                8GB RAM
      Accordance 11.0.1                       Accordance 11.0.1
      OSX 10.9 (Mavericks)                    Win 7 Professional x64 SP1


#3 Matt Fredenburg

Matt Fredenburg

    Gold

  • Active Members
  • PipPipPipPip
  • 312 posts
  • Gender:Male
  • Accordance Version:10.x

Posted 09 November 2013 - 11:30 PM

This bug still exists in 10.3.2 and seems to be worse in that now, when I drag the scroll box down, it doesn't scroll at all, but just blinks rapidly. In order to get the next resource to display, I must not drag the scroll box at all, and instead must click on the scroll arrows.

 

Matt


Specs:
  • Windows 7 SP1 x64
  • Accordance 10.3.4.2
  • Quad Xeon 2.83 GHz x2
  • 16 GB RAM
  • Nvidia 580 GTX 2GB VRAM

#4 Daniel Semler

Daniel Semler

    Platinum

  • Active Members
  • PipPipPipPipPip
  • 1,590 posts
  • Gender:Male
  • Accordance Version:11.x

Posted 09 November 2013 - 11:45 PM

Really odd - I can't repro. this. My scroll bar box while incorrectly sized as noted earlier, does respond to drag properly although it does flash in way that most normal scroll bar boxes do not. It looks like the scroll bar redraw is fighting with the window content redraw.

 


Edited by Daniel Semler, 09 November 2013 - 11:54 PM.

Accordance Configurations :
 
Mac : 2009 27" iMac                 Windows : HP 4540s laptop
      Intel Core Duo                          Intel i5 Ivy Bridge
      12GB RAM                                8GB RAM
      Accordance 11.0.1                       Accordance 11.0.1
      OSX 10.9 (Mavericks)                    Win 7 Professional x64 SP1


#5 Matt Fredenburg

Matt Fredenburg

    Gold

  • Active Members
  • PipPipPipPip
  • 312 posts
  • Gender:Male
  • Accordance Version:10.x

Posted 04 December 2013 - 08:02 PM

Partially fixed in 10.3.3. The issue of the scroll box being completely disproportionate to the amount of content still exists. Also, when dragging the scroll box down (or up), the content blinks rapidly. What has been fixed is that at least when the scroll box is clicked and dragged, the content now moves.

 

Matt


Specs:
  • Windows 7 SP1 x64
  • Accordance 10.3.4.2
  • Quad Xeon 2.83 GHz x2
  • 16 GB RAM
  • Nvidia 580 GTX 2GB VRAM




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users