Jump to content


User Tool Searching - Problems with Large File

  • Please log in to reply
2 replies to this topic

#1 Steve King

Steve King


  • Active Members
  • PipPipPipPip
  • 392 posts
  • Gender:Male
  • Location:Hoddesdon, Hertfordshire, UK
  • Accordance Version:10.x

Posted 25 November 2013 - 06:12 AM

As this is a user tool I am not expecting you to debug it but just to confirm my suspicion. I have created a user tool for Gill's Exposition and it is a rather large file and I assume the size is causing the following issue.


If you search it does not display hits after a certain point (midway through Hebrews) even when there are definitely other hits.


If I search for title "Hebrews" it gets up to Hebrews 6 then starts highlighting other words.

Attached File  Screen Shot 2013-11-25 at 10.46.56.png   819.96KB   0 downloads


If I search for title "James" it tells me there are 7 exact hits but finds nothing and does not highlight the titles in James.


In searching for "darkness" in contents - again after Hebrews 6 it does not get the searching correct.


Using the search for "Hebrews" in titles as an example. if I cycle through the hits when you reach the last one it either cycles back to the beginning of the tool or it crashes with the following error on the console:


25/11/2013 10:54:58.474 com.apple.launchd.peruser.501[199]: ([0x0-0x503503].com.OakTree.Accordance[32552]) Exited with code: 217


This is just to make you aware rather than anything else - I don't suppose you thought anyone would be silly enough to create such a large user tool. I intend to split it into OT and NT and that will hopefully solve the issue.



#2 Julie Falling

Julie Falling


  • Active Members
  • PipPipPipPipPip
  • 1,266 posts
  • Gender:Female
  • Location:Tennessee
  • Interests:Numerous!
  • Accordance Version:10.x

Posted 25 November 2013 - 08:18 AM

Steve –  I was silly enough to try it.  We had the MacArthur Study Bible on my husband's PC (when he had one - switched back to Mac right before he retired).  Anyway, I copied the Notes in batches, converted to HTML, and tried to combine it all into one huge tool.  No go.  I ran into all kinds of problems.  I broke it down into many smaller files, and that worked.  It's been many years since I my attempt, so I don't remember exactly in what order I did things, but I do know that the large files don't work.  So I do have the MacArthur Study Bible in Accordance.  Charts were hard to format and the result is less than professional.  If you've done anything with User Tools you know that what you see in the edit window is not necessarily what you get in your tool.  I've found the same thing to be true in User Notes.  I'm still hoping the Accordance folks will get to MacArthur Study Bible soon.  His multi-volume commentary is not yet complete.

Julia Falling



MacBook Air Yosemite

mid-2013 1.7 GHz Intel Core i7 (2 cores)

8 GB RAM; 512 G SSD


Mac mini Yosemite

late-2012 2.3GHz Intel Core i7 (4 cores)

16 GB RAM; 1.12  TB Fusion Drive


iPad Air 1 iOS 8.1

64 GB





#3 Steve King

Steve King


  • Active Members
  • PipPipPipPip
  • 392 posts
  • Gender:Male
  • Location:Hoddesdon, Hertfordshire, UK
  • Accordance Version:10.x

Posted 25 November 2013 - 09:14 AM

Fortunately there are no charts in Gill. The format is pretty good but I find it is best if you can load it in one go. I have attempted smaller files and merging them but the formatting then goes out in places.


I think splitting it into OT and NT will do the trick. It would be nice if improvements were made to the import process which is partly why I raised the issue. Hopefully any future upgrades to user tools may incorporate better functionality.

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users