Jump to content


Photo

Pasting Hebrew text from Accordance into Nota Bene


  • Please log in to reply
3 replies to this topic

#1 luoar

luoar

    Silver

  • Active Members
  • PipPipPip
  • 133 posts
  • Gender:Not Telling
  • Accordance Version:10.x

Posted 05 January 2014 - 05:51 AM

Whenever I try to copy Hebrew text into Nota Bene the text automatically reverts to the right of the page together with any English text I have typed. This behaviour does not occur if I paste from another program. See screenshot. 



#2 luoar

luoar

    Silver

  • Active Members
  • PipPipPip
  • 133 posts
  • Gender:Not Telling
  • Accordance Version:10.x

Posted 18 January 2014 - 09:55 AM

Since I received no reply to this I thought I would post a video to more clearly explain the problem. Accordance has limited options for pasting Hebrew text. In my Word Processor it aligns the text to the right. Though Hebrew aligns from right to left no one who types in English would ever type from right to left. There is no way to change this in the Accordance options. 

 



#3 Rick Bennett

Rick Bennett

    Platinum

  • Accordance
  • 1,876 posts
  • Gender:Male
  • Location:Tampa Bay, FL
  • Interests: gadgets, coffee, running and cycling, Rays baseball
  • Accordance Version:10.x

Posted 20 January 2014 - 08:54 AM

Accordance doesn't necessarily control how the text is rendered except indicating that it is RTL text. In other Word processors this only controls how the string of text is rendered, not the entire line in the word processor. I've heard of Nota Bene, but never used it personally.

 

Here are a couple things I would try:

Try any paste options, such as 'paste and match style' or 'paste as plain text' (wording may differ)

Try typing in English before and after the insertion point of the Hebrew text, e.g. "This is the text of Is 6.1  , where it states…". Paste the Hebrew into the blank area.

Try looking in Nota Bene for an option to insert a directional marker or non-breaking space after the insertion point of the Hebrew text. This would change the direction back to LTR after the Hebrew text.


  • luoar likes this

Rick Bennett
Director of Content Development
iOS Working Group


#4 luoar

luoar

    Silver

  • Active Members
  • PipPipPip
  • 133 posts
  • Gender:Not Telling
  • Accordance Version:10.x

Posted 20 January 2014 - 01:43 PM

Thank you for your comments Rick. I tried all of your suggestions but none of these worked. What did work for me (and I only discovered this solution today) was to copy in Accordance as a citation. I also tweaked some of the Preference settings so that the reference is not copied, and I adjusted the size of the font. Now, if I click copy as citation the text will paste without aligning the Hebrew to the right. It is a good workaround, but since I do a lot of copying and pasting, it would be better to be able to set this as my default copy and paste.

 

Thank you again.

 

Raoul


Edited by luoar, 20 January 2014 - 01:47 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users