Jump to content


Photo

New Workspace causes library to be added to the main workspace window


  • Please log in to reply
5 replies to this topic

#1 Daniel Semler

Daniel Semler

    Platinum

  • Active Members
  • PipPipPipPipPip
  • 1,714 posts
  • Gender:Male
  • Accordance Version:11.x

Posted 20 January 2014 - 02:46 AM

Hi ya,

 

  If I have a workspace open with or without the library open (in a zone not popover, if open), and I click File->New Workspace the new workspace window comes up and the main window gets a library pane added to it. If I again open a New Workspace another library pane is added. The new workspace that comes up does not have a library. Perhaps its library is being incorrectly placed. The reason I say this is that if use the new second workspace and do File -> New Workspace from there instead of from the original one then the library is added to the newly create ws not to the one I requested it from.

 

  This is 10.3.4.1 on win 7 x64 and I have the add library to new workspaces pref set.

 

Thx
D
 


Accordance Configurations :
 
Mac : 2009 27" iMac                 Windows : HP 4540s laptop
      Intel Core Duo                          Intel i5 Ivy Bridge
      12GB RAM                                8GB RAM
      Accordance 11.0.1                       Accordance 11.0.1
      OSX 10.9 (Mavericks)                    Win 7 Professional x64 SP1


#2 David_Bailey

David_Bailey

    Bronze

  • Active Members
  • PipPip
  • 99 posts
  • Gender:Male
  • Accordance Version:10.x

Posted 20 January 2014 - 10:32 PM

Daniel,

 

I can't seem to duplicate your situation.  I have tried on a single monitor setup as well as a dual monitor setup.  Each time I open a new workspace, that workspace will have a library view (when "Add Library to new workspaces" box is checked in Preferences>Workspaces>Tabs and Zones section).

 

David



#3 Daniel Semler

Daniel Semler

    Platinum

  • Active Members
  • PipPipPipPipPip
  • 1,714 posts
  • Gender:Male
  • Accordance Version:11.x

Posted 20 January 2014 - 11:05 PM

Hi David,

 

  Thanx for trying. I am seeing this on a two monitor setup when the main workspace is on the secondary monitor. What happens then is that the new ws is opened on the main monitor - the laptop screen in my case, and the library is added to the workspace on the attached secondary screen. If I try this with the main ws on the main screen it does not repro.

 

thx
D


Accordance Configurations :
 
Mac : 2009 27" iMac                 Windows : HP 4540s laptop
      Intel Core Duo                          Intel i5 Ivy Bridge
      12GB RAM                                8GB RAM
      Accordance 11.0.1                       Accordance 11.0.1
      OSX 10.9 (Mavericks)                    Win 7 Professional x64 SP1


#4 David_Bailey

David_Bailey

    Bronze

  • Active Members
  • PipPip
  • 99 posts
  • Gender:Male
  • Accordance Version:10.x

Posted 21 January 2014 - 10:17 AM

Hi David,

 

  Thanx for trying. I am seeing this on a two monitor setup when the main workspace is on the secondary monitor. What happens then is that the new ws is opened on the main monitor - the laptop screen in my case, and the library is added to the workspace on the attached secondary screen. If I try this with the main ws on the main screen it does not repro.

 

thx
D

 

With Accordance on my secondary display (number 1 in the screenshot below), I open a new workspace.  That workspace opens on my main display (number 2), and the Library is attached to it.  I still can't reproduce your situation.  Maybe try unstalling and re-installing your graphic driver, using the latest available for your laptop?

 

David

Attached Files



#5 Daniel Semler

Daniel Semler

    Platinum

  • Active Members
  • PipPipPipPipPip
  • 1,714 posts
  • Gender:Male
  • Accordance Version:11.x

Posted 21 January 2014 - 10:52 AM

Hi David,

 

  I don't think its a driver issue but your suggestion caused me to consider something else. I use this reg hack http://sinewalker.wo...registry-hacks/ to get decent window focus behaviour in windows - by decent I mean like on Linux. One of my greatest irritations with OSX is the lack of this support. Anyhow, this has never caused any problems before and I've been using this since XP. But if I turn this hack off the New Workspace behaviour I describe goes away. As the New Workspace issue is minor and can be worked around I'll continue using the reg hack and live with it. My guess is that there is a window selection issue in the application of the library to the workspace and that my mouse focus is interfering with that in some way. Not an especially serious bug but would be nice to have it fixed of course. But then I'm technically doing a not really supported thing.

 

  Anyhow thanx for the help getting to the bottom of it.

  That said I should check for a video driver update anyway - an interaction there is still possible I guess.

 

Thx

D


Accordance Configurations :
 
Mac : 2009 27" iMac                 Windows : HP 4540s laptop
      Intel Core Duo                          Intel i5 Ivy Bridge
      12GB RAM                                8GB RAM
      Accordance 11.0.1                       Accordance 11.0.1
      OSX 10.9 (Mavericks)                    Win 7 Professional x64 SP1


#6 David_Bailey

David_Bailey

    Bronze

  • Active Members
  • PipPip
  • 99 posts
  • Gender:Male
  • Accordance Version:10.x

Posted 21 January 2014 - 11:15 AM

Daniel,

 

Glad you found the source that's causing the issue.

 

David






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users