Jump to content


Photo

Customize display for Analysis tab is unresponsive


  • Please log in to reply
6 replies to this topic

#1 Daniel Semler

Daniel Semler

    Platinum

  • Active Members
  • PipPipPipPipPip
  • 1,324 posts
  • Gender:Male
  • Accordance Version:10.x

Posted 02 March 2014 - 10:12 PM

Hi ya,

 

  This happens on 10.4.0pr2 on Win 7 SP1.

 

  Run a search and then pop up an (Word count) Analysis tab. No buttons in the dialog respond, nor can you click check boxes or move items in the table of parts to display. You then have to crash out Acc. to regain control. My example search in case it matters was "[RANGE MATT] <AND> [COUNT -20]" against the GNT28-T.

 

Tx

D


Accordance Configurations :
 
Mac : 2009 27" iMac                 Windows : HP 4540s laptop
      Intel Core Duo                          Intel i5 Ivy Bridge
      12GB RAM                                8GB RAM
      Accordance 10.4.3.2                     Accordance 10.4.3.2 and Aleph 10.4.3.2
      OSX 10.9 (Mavericks)                    Win 7 Professional x64 SP1

#2 Helen Brown

Helen Brown

    Mithril

  • Admin
  • 8,209 posts
  • Gender:Female
  • Location:heart in Israel
  • Accordance Version:10.x

Posted 03 March 2014 - 04:35 AM

Are you sure this is reproducible? I tried exactly your search and both the Analysis tab itself and the Set Analysis Display worked fine. 10.4.0pr2 on Win 7.


Helen Brown
OakTree Software

#3 Daniel Semler

Daniel Semler

    Platinum

  • Active Members
  • PipPipPipPipPip
  • 1,324 posts
  • Gender:Male
  • Accordance Version:10.x

Posted 03 March 2014 - 09:30 AM

Hi Helen,

 

  I missed one thing required to repro. it. It needs to be done in a workspace window that is not the primary one.

  I've just tried it again now and if you use the primary w/s window it works fine. If you use a secondary ws it behaves as I described above.

 

  Oh and just to clarify one point is 10.4.0rc2 not pr, in case that makes a difference.

thx

D


Edited by Daniel Semler, 03 March 2014 - 09:31 AM.

Accordance Configurations :
 
Mac : 2009 27" iMac                 Windows : HP 4540s laptop
      Intel Core Duo                          Intel i5 Ivy Bridge
      12GB RAM                                8GB RAM
      Accordance 10.4.3.2                     Accordance 10.4.3.2 and Aleph 10.4.3.2
      OSX 10.9 (Mavericks)                    Win 7 Professional x64 SP1

#4 Helen Brown

Helen Brown

    Mithril

  • Admin
  • 8,209 posts
  • Gender:Female
  • Location:heart in Israel
  • Accordance Version:10.x

Posted 03 March 2014 - 09:34 AM

Yes, I am using rc2, but still cannot reproduce even in a second workspace.


Helen Brown
OakTree Software

#5 Daniel Semler

Daniel Semler

    Platinum

  • Active Members
  • PipPipPipPipPip
  • 1,324 posts
  • Gender:Male
  • Accordance Version:10.x

Posted 03 March 2014 - 10:04 AM

OK found the problem. Hmmmm....

This is the second interaction between Acc and the windows registry hack to allow focus follows mouse that I've found.

If I go back to click to focus it works fine.

 

I'll have to try some tweaks to it. I believe the problem may be with the setting for the ActiveWndTrackTimeout. But I'll do more testing.

Will post back if I can get a value that works.

 

Thanx for your help.

 

Thx

D


Edited by Daniel Semler, 03 March 2014 - 10:05 AM.

Accordance Configurations :
 
Mac : 2009 27" iMac                 Windows : HP 4540s laptop
      Intel Core Duo                          Intel i5 Ivy Bridge
      12GB RAM                                8GB RAM
      Accordance 10.4.3.2                     Accordance 10.4.3.2 and Aleph 10.4.3.2
      OSX 10.9 (Mavericks)                    Win 7 Professional x64 SP1

#6 Matt Fredenburg

Matt Fredenburg

    Gold

  • Active Members
  • PipPipPipPip
  • 310 posts
  • Gender:Male
  • Accordance Version:10.x

Posted 03 March 2014 - 12:42 PM

Hi Daniel,

  Is this a bug in Accordance for Windows or some inherent flaw on your system which is causing other software on your system in addition to Accordance to become unresponsive and need to be forcibly terminated? I've written many pieces of software over the years which exhibited behavior I could not duplicate on a non-customer system but which were bugs nonetheless!

 

Thanks,

 

Matt

 


Specs:
  • Windows 7 SP1 x64
  • Accordance 10.3.4.2
  • Quad Xeon 2.83 GHz x2
  • 16 GB RAM
  • Nvidia 580 GTX 2GB VRAM

#7 Daniel Semler

Daniel Semler

    Platinum

  • Active Members
  • PipPipPipPipPip
  • 1,324 posts
  • Gender:Male
  • Accordance Version:10.x

Posted 03 March 2014 - 01:25 PM

Hi Matt,

 

  True enough. Having found the problem in the large doesn't yet decide whether its a bug or not and if a bug where it's located.

  I have found two artifacts in the Acc GUI which are sensitive to the use of focus-follows-mouse via the registry modifications that I've been using. My guess is that the issue lies in the Windows GUI libs and that these are not tested in non-default registry configurations. But that's just a guess. If you are interested in trying to repro. the problems I've seen with this hack in place you could refer to this web page for the hack : http://sinewalker.wo...registry-hacks/ and then this forum post and the previous one concerning the library : http://www.accordanc...howtopic=11836.

 

If you do try it I'd be very interested in what you find. I have not noticed issues with any other software with this registry hack.

 

thx

D


Accordance Configurations :
 
Mac : 2009 27" iMac                 Windows : HP 4540s laptop
      Intel Core Duo                          Intel i5 Ivy Bridge
      12GB RAM                                8GB RAM
      Accordance 10.4.3.2                     Accordance 10.4.3.2 and Aleph 10.4.3.2
      OSX 10.9 (Mavericks)                    Win 7 Professional x64 SP1




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users