Jump to content


Photo

3D control palette behaviour


  • Please log in to reply
6 replies to this topic

#1 Daniel Semler

Daniel Semler

    Platinum

  • Active Members
  • PipPipPipPipPip
  • 1,714 posts
  • Gender:Male
  • Accordance Version:11.x

Posted 29 March 2014 - 08:20 PM

Hi ya,

 

  As you will have noticed I've just acquired the Atlas and so as I play with it I will plague you all with questions :)

 

  This is 10.4.1. Mac.

 

  In this case the 3D Control palette turn and move joysticks don't appear to be behaving as documented. I can click on them but I cannot drag them any specific direction. They go to just one direction as soon as I click on them - that is in both cases about SE (or 4:30 by the clock model). If I hold the shift key the go to E (3pm) only. So I do not have much control. I find the mouse controls on the 3D map are fine and seem to be pretty much like what I'd expect in terms of function based on other 3D stuff I've used. But the control palette looks broken. Of course I could be missing something too ....

 

  Also I notice that if I have a 3D window up and the control palette is visible, then I click to another desktop - say for Firefox - then come back, the 3D window is still in the for but the control palette is gone. If I click on the 3D window it does not restore it. But if I bring a different Acc window to the front and then bring the 3D window to the front then the control palette shows up with it.

 

Thx

D


Accordance Configurations :
 
Mac : 2009 27" iMac                 Windows : HP 4540s laptop
      Intel Core Duo                          Intel i5 Ivy Bridge
      12GB RAM                                8GB RAM
      Accordance 11.0.1                       Accordance 11.0.1
      OSX 10.9 (Mavericks)                    Win 7 Professional x64 SP1


#2 Lorinda H. M. Hoover

Lorinda H. M. Hoover

    Platinum

  • Active Members
  • PipPipPipPipPip
  • 1,371 posts
  • Gender:Female
  • Location:Iowa
  • Accordance Version:11.x
  • Platforms:Mac OS X, Windows, iOS

Posted 30 March 2014 - 07:00 AM

I'm seeing the same thing. 


Running Accordance on:
Mac 10.10 (Yosemite)
iOS 7 (iPad)
Windows Vista Home Premium


#3 Daniel Semler

Daniel Semler

    Platinum

  • Active Members
  • PipPipPipPipPip
  • 1,714 posts
  • Gender:Male
  • Accordance Version:11.x

Posted 06 April 2014 - 03:00 PM

The User Layer Palette also has the same issue I mentioned above not coming to the front when the Atlas window its associated with does. The workaround is basically the same as above, though sometimes I also need to click on the layer.

 

Thx

D


Accordance Configurations :
 
Mac : 2009 27" iMac                 Windows : HP 4540s laptop
      Intel Core Duo                          Intel i5 Ivy Bridge
      12GB RAM                                8GB RAM
      Accordance 11.0.1                       Accordance 11.0.1
      OSX 10.9 (Mavericks)                    Win 7 Professional x64 SP1


#4 JoeyD

JoeyD

    Member

  • Active Members
  • Pip
  • 29 posts
  • Gender:Male
  • Location:Roanoke, Texas
  • Interests:Bible Study, Preaching, Teaching, Baseball, Fishing, Football
  • Accordance Version:11.x

Posted 25 April 2014 - 01:25 PM

I am experiencing the same problem with the controls for the 3D map tool. As soon as I click on a control to move or rotate the map slice, the control slams in the lower right direction and the map begins to move, regardless of the direction I am specifying.

 

This post is almost 30 days old. Is there any feedback from support?

 

Thanks,

 

Joey



#5 Joel Brown

Joel Brown

    Administrator

  • Admin
  • 3,048 posts
  • Gender:Male
  • Location:Houston, TX
  • Accordance Version:11.x
  • Platforms:Mac OS X, Windows

Posted 25 April 2014 - 01:44 PM

Sorry for not responding more promptly - we've already found and fixed the bug for 10.4.2, which is in testing right now.  As a temporary workaround, you can click and drag on the map itself to navigate, or use option-click and drag on the map to Turn it.


  • JoeyD likes this
Joel Brown

By day: Consultant for Oaktree
By night: Freelance Trombonist and Private Instructor

#6 JoeyD

JoeyD

    Member

  • Active Members
  • Pip
  • 29 posts
  • Gender:Male
  • Location:Roanoke, Texas
  • Interests:Bible Study, Preaching, Teaching, Baseball, Fishing, Football
  • Accordance Version:11.x

Posted 25 April 2014 - 04:39 PM

Thanks Joel!



#7 Daniel Semler

Daniel Semler

    Platinum

  • Active Members
  • PipPipPipPipPip
  • 1,714 posts
  • Gender:Male
  • Accordance Version:11.x

Posted 25 April 2014 - 04:49 PM

Thanx Joel.

 

BTW, I logged another issue on this palette in the Windows 10.4.2 beta where two of the buttons (in/out) are not working properly though all the rest are fine. I don't know where your generic to platform specific code boundary is so I don't know if that issue occurs on Mac, and could not test for it on 10.4.1 due to this issue here. Anyhow that other thread is here : http://www.accordanc...showtopic=12595 in case it helps.

 

Thx

D
 


Accordance Configurations :
 
Mac : 2009 27" iMac                 Windows : HP 4540s laptop
      Intel Core Duo                          Intel i5 Ivy Bridge
      12GB RAM                                8GB RAM
      Accordance 11.0.1                       Accordance 11.0.1
      OSX 10.9 (Mavericks)                    Win 7 Professional x64 SP1





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users