Jump to content


Photo

Bug when searching in ZEB


  • Please log in to reply
3 replies to this topic

#1 Ken Simpson

Ken Simpson

    Platinum

  • Accordance
  • 1,297 posts
  • Gender:Male
  • Location:Sydney, Australia
  • Interests:Astronomy
    Archaeology
    Physics
    Hebrew and Greek
    Papyrology
    Surgeon
  • Accordance Version:10.x

Posted 12 April 2014 - 02:29 AM

Hi, I am getting a strange result when searching in ZEB

 

Open ZEB as a standalone tool,

 

change search field to captions

 

enter "donkey" (no quotes) and press return

 

I get 5 results (exact search)

 

the first thing to see is that  on the 4th hit, (navigated to by pressing the down Mk triangle) that the word donkey is not highlit as you would expect a hit to be

 

Attached File  Workspace-1.png   63.6KB   0 downloads

 

and when you press the down triangle the next time it jumps you back to the first page of the tool

 

Attached File  Workspace-2.png   162.8KB   0 downloads

 

There is a crash here in the windows version, but I will post a bug report over there as well

 

 

And, another weirdness is, that if you set the tool to search by Entry, and you search for donkey, the first hit result displayed is at p173. If you press the Mk down triangle you get a beep as if it's the last one (even though there are three hits). If you hit the Mk up triangle it jumps "backwards" to p401, and then if you press it again to p400. Seems definitely weird to me.


Edited by Ken Simpson, 12 April 2014 - 02:29 AM.

Regards
Ken
Australian Accordance Demonstrator

Administrator, Accordance Exchange

Assistant Minister, Summer Hill Church


#2 Ryan Mudge

Ryan Mudge

    Bronze

  • Accordance
  • 74 posts
  • Gender:Male
  • Accordance Version:10.x

Posted 12 April 2014 - 12:26 PM

I can confirm 'donkey' is not highlighted on the fourth hit. Also, the fifth hit does take you back to the first page of the tool. 

 

Every time I test this on the Windows version and get to the fifth hit, it causes Accordance to crash. Interestingly, it also causes my Mac version to crash as well, but only about 50% of the time. I also found that the problem is the same whether I open the ZEB as a standalone tool or not. 

 

I can also confirm the same issue as Ken when I search for 'donkey' via Entry.

 

Ryan



#3 Ken Simpson

Ken Simpson

    Platinum

  • Accordance
  • 1,297 posts
  • Gender:Male
  • Location:Sydney, Australia
  • Interests:Astronomy
    Archaeology
    Physics
    Hebrew and Greek
    Papyrology
    Surgeon
  • Accordance Version:10.x

Posted 12 April 2014 - 04:43 PM

Thanks Ryan. I was going to post about the Windows issue but you beat me to it. I too get the same crash.

But I haven't had a macos crash...phew!


Regards
Ken
Australian Accordance Demonstrator

Administrator, Accordance Exchange

Assistant Minister, Summer Hill Church


#4 Joel Brown

Joel Brown

    Administrator

  • Admin
  • 2,486 posts
  • Gender:Male
  • Location:Houston, TX
  • Accordance Version:10.x

Posted 15 April 2014 - 01:21 PM

I believe this is an error in the module that should be fixed soon.


Joel Brown

By day: Consultant for Oaktree
By night: Freelance Trombonist and Private Instructor




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users