Jump to content


Photo

Greek Copy/Pasting Problem


  • Please log in to reply
7 replies to this topic

#1 Darren Larson

Darren Larson

    Member

  • Active Members
  • Pip
  • 36 posts

Posted 11 January 2007 - 04:47 PM

I have found that whenever I am copying and pasting a Greek word that starts with an omega AND a rough accent (e.g., the oft-repeated word hos) that the accent mark is substituted with the Apple logo in Word. This does not occur when the word begins with omega, but has a smooth accent (like ophelethes in Matt. 15).

I've tried the font fixer to fix the problem but it did not fix it! I also noticed it's only since I installed 7 that this has occured (since I never noticed it before and I'm certain I've copy/pasted like this before I got 7). Anyone have any suggestions?

#2 jpkang

jpkang

    Platinum

  • Active Members
  • PipPipPipPipPip
  • 577 posts
  • Gender:Male
  • Location:Seattle, WA
  • Interests:Comparative Semitics; ancient Hebrew semantics; Hebrew syntax; history and religion of ancient Israel; history of interpretation.
  • Accordance Version:10.x

Posted 12 January 2007 - 01:49 AM

I can verify this behavior on a MacBook with Accordance 7.1 and Word 2004.

For now, you can get the correct accent by replacing the apple glyph with a capital J in Helena (see page 6 of the Accordance Fonts PDF). Word's Find and Replace can do this for you globally in a document:

1. enter the appropriate characters in the "Find what:" and "Replace with:" boxes
2. click the blue disclosure button next to the Replace All button
3. with the cursor in the Replace with: box, choose Format > Font..., and choose Helena
4. click Replace All
J. P. Kang, Ph.D. (Bible)

#3 CharlyG

CharlyG

    Member

  • Active Members
  • Pip
  • 18 posts

Posted 12 January 2007 - 05:46 PM

It's all Greek to me!!!


Are lame attempts at humor allowed?

#4 Darren Larson

Darren Larson

    Member

  • Active Members
  • Pip
  • 36 posts

Posted 13 January 2007 - 05:34 PM

I also just noticed it again when the word starts with an alpha and a rough accent (Mark 2:5).

This is just FYI in case it's a fixable issue.

PS. Thanks jpkang for the replace all idea. I was just going through and manually fixing it.

#5 Eoin

Eoin

    Member

  • Active Members
  • Pip
  • 32 posts
  • Gender:Male
  • Location:Killin, SCOTLAND
  • Accordance Version:10.x

Posted 14 January 2007 - 10:46 AM

Darren Larson wrote
"I also just noticed it again when the word starts with an alpha and a rough accent (Mark 2:5)."

I saw the same problem (OS 10.4.8, Accordance 7.1, Word 11.3.3 on Powerbook G4).

In Font Book - Helena font - Plain was "off" and Regular "on".
This was the setting Font Book used to resolve duplicates.
I switched them over so that Plain was "on" and Regular "off", this SEEMED to have cured the problem.

But I only restarted Word - that updated the font information for Word and all looked OK. Accordance was using the regular font and Word the plain - I had no trouble copying and pasting.

However when I restarted my computer this morning - both applications were using the same Helena font - Accordance didn't like the setting and the Greek font was all messed up.

It looks like a font problem - Accordance works with Helena regular - Word works with Helena Plain.

Eņin

Edited by Eoin, 15 January 2007 - 06:03 AM.

The Reverend John Lincoln
Minister
Parishes of Balquhidder linked with Killin and Ardeonaig
Scotland

My Webpage

#6 Chris

Chris

    Member

  • Active Members
  • Pip
  • 10 posts
  • Gender:Male
  • Location:Worcestershire, UK

Posted 08 February 2007 - 10:47 AM

I'm having the same problem using a Macbook, Accordance 7.1 and Mellel. I have run the font fixer and I have only one iteration of Helena in my font book

#7 Helen Brown

Helen Brown

    Mithril

  • Admin
  • 8,506 posts
  • Twitter:accordancebible
  • Gender:Female
  • Location:heart in Israel
  • Accordance Version:11.x
  • Platforms:Mac OS X, Windows, iOS

Posted 08 February 2007 - 12:49 PM

This has nothing to do with FontFixer or the FontBook. Apple is substituting the apple for our rough breathing. You can search and replace these characters (shift-option-k) with shift-j which looks almost as good. The next rev of Accordancve will make that substitution for you when you export in Helena.

Another alternative is to convert to Unicode. the Accordance Fonts PDF goes into all the options.

For the record, FontFixer only corrects errors of font display within Accordance.
Helen Brown
OakTree Software

#8 Chris

Chris

    Member

  • Active Members
  • Pip
  • 10 posts
  • Gender:Male
  • Location:Worcestershire, UK

Posted 08 February 2007 - 01:17 PM

Thanks Helen.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users