Jump to content


Photo

Running FontFixer


  • Please log in to reply
10 replies to this topic

#1 John Hilber

John Hilber

    Member

  • Active Members
  • Pip
  • 9 posts

Posted 23 January 2007 - 10:18 PM

Greetings,
This morning my Hebrew fonts turned into Latin character gibberish. I upgraded to 7.1 from 7.0.3 and then downloaded FontFixer. However, when I try to run the program, I get a request for choosing an application to open it. Thank you in advance for your help.
John

#2 Helen Brown

Helen Brown

    Mithril

  • Admin
  • 8,029 posts
  • Gender:Female
  • Location:heart in Israel
  • Accordance Version:10.x

Posted 24 January 2007 - 01:02 AM

What Mac OS are you using? FontFixer is only for OS X.

The Accordance Fonts PDF has details on which font files you should be using, and how to fix problems.
Helen Brown
OakTree Software

#3 Dave Klein

Dave Klein

    Member

  • Active Members
  • Pip
  • 4 posts

Posted 24 January 2007 - 01:49 AM

I had this exact same problem about a month or two ago. I downloaded the font fixer with Firefox and tried to open it and got the request to choose a program. I don't think it downloaded correctly though, because when I downloaded it again with Safari I didn't have any trouble.

My suggestion would be to try downloading font fixer with a different browser to see if it fixes the problem. It worked for me.

Blessings,
DJK

#4 John Hilber

John Hilber

    Member

  • Active Members
  • Pip
  • 9 posts

Posted 24 January 2007 - 12:11 PM

In answer to Helen's question, I am running OSX 10.4.8 on an Intel Mac. In response to Dave's suggestion, I did switched to Safari from Firefox and got a correct download (seeing the difference is obvious). The FontFixer program ran smoothly and indicated a successful installation. However, I still have the same problem. I will wade through the pdf., but my intuition is that the solution is not (or should not need to be) there. From Dave's comments and those of a colleague, the FontFixer should just do it.
John

#5 Helen Brown

Helen Brown

    Mithril

  • Admin
  • 8,029 posts
  • Gender:Female
  • Location:heart in Israel
  • Accordance Version:10.x

Posted 24 January 2007 - 12:16 PM

What is the font problem you are having?
Helen Brown
OakTree Software

#6 John Hilber

John Hilber

    Member

  • Active Members
  • Pip
  • 9 posts

Posted 24 January 2007 - 03:29 PM

What is the font problem you are having?


My BHS-W4 and HMT-T look sort of like this copy/paste from Accordane of Gen. 1:1:

Gen. 1:1:Xr`DaDh tEa◊w MyAmDvAh tEa MyIhlTa a∂rD;b tyIvarV;b

--except that in copying and pasting, the letters are different yet. Basically a wierd Latin character set.

John

#7 Helen Brown

Helen Brown

    Mithril

  • Admin
  • 8,029 posts
  • Gender:Female
  • Location:heart in Israel
  • Accordance Version:10.x

Posted 25 January 2007 - 02:41 AM

Then you must look at the settings in Preferences/Greek & Hebrew, and choose to export either as Unicode or as Yehudit or as a font which you do have. A lot depends on the program into which you are pasting. Accordance Fonts discusses the export of Accordance text, and so does the General Features section of Accordance Help.

This is not a font problem, it is a question of the settings. FontFixer corrects problems in the display of our fonts within Accordance.
Helen Brown
OakTree Software

#8 John Hilber

John Hilber

    Member

  • Active Members
  • Pip
  • 9 posts

Posted 25 January 2007 - 11:41 AM

Then you must look at the settings in Preferences/Greek & Hebrew, and choose to export either as Unicode or as Yehudit or as a font which you do have. A lot depends on the program into which you are pasting. Accordance Fonts discusses the export of Accordance text, and so does the General Features section of Accordance Help.

This is not a font problem, it is a question of the settings. FontFixer corrects problems in the display of our fonts within Accordance.


I'm sorry, Helen, that my last reply was not very clear. The cut from Accordance pasted into the Forum window was only to give an example of what my Hebrew looks like in Accordance at all times. I haven't had time yet this week to read the .pdf on fonts. Perhaps this will illumine something.
All good cheer,
John

#9 John Hilber

John Hilber

    Member

  • Active Members
  • Pip
  • 9 posts

Posted 25 January 2007 - 12:19 PM

Helen,
After my last reply to clarify that my problem is with the font display within Accordance, not exported fonts, I opened FontBook to look at Yehudit. I'm not sure what it is supposed to look like, but Yehudit Plain has Latin characters identical to the ones appearing in my Accordance workspace. Odd thing is that Yehudit seems fine in Mellel, my word processor. Maybe these observations will mean something to you.
Cheers,
John

#10 Helen Brown

Helen Brown

    Mithril

  • Admin
  • 8,029 posts
  • Gender:Female
  • Location:heart in Israel
  • Accordance Version:10.x

Posted 25 January 2007 - 12:34 PM

In FontBook make sure that it is only using the Library/Fonts/Yehudit.famTrueType. Remove any other fonts.
Helen Brown
OakTree Software

#11 Helen Brown

Helen Brown

    Mithril

  • Admin
  • 8,029 posts
  • Gender:Female
  • Location:heart in Israel
  • Accordance Version:10.x

Posted 25 January 2007 - 01:34 PM

I just spoke to John, and found that his FontBook was accessing Geneva in place of Yehudit Plain. He could see this when he set the Preview menu to Show info. This happens randomly to people, the only solution is to go through each style of the troublesome font and to disable or remove any that are incorrect, leaving only one of each style. Since the problem is individual, no two are alike, it is hard to write specific instructions that apply to everyone, but they are in the Accordance Fonts PDF.

Please note that I have now posted the updated FontFixer that should have been uploaded on Dec 1st. Many apologies for the hassles caused to several users.
Helen Brown
OakTree Software




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users