Jump to content


Photo

importing: Rev 12:18 and version mismatch


  • Please log in to reply
8 replies to this topic

#1 countach

countach

    Silver

  • Active Members
  • PipPipPip
  • 133 posts
  • Gender:Male

Posted 10 June 2007 - 09:07 AM

Some bibles have a rev 12:18. Accordance can't import such a verse. It's really 13:1, but some bibles like it the other way. Is it a bug?

Also, I tried importing a bible that is apparently in the correct format, but starting from around Dt, all the verses were out of sync right through to the end of the bible. Dt 1:1 in my imported bible is really Dt 1:25. What should be Jn 1:1 is listed as Lk 24:20.

#2 Helen Brown

Helen Brown

    Mithril

  • Admin
  • 7,981 posts
  • Gender:Female
  • Location:heart in Israel
  • Accordance Version:10.x

Posted 10 June 2007 - 01:09 PM

Please see the Help files for User Bibles, and the other posts on the forum in the last month. You have to conform all the verse references to the KJV. You can merge verses and put your actual reference in parentheses, but the reference at the beginning of each line must be one that is found in the KJV.

For our official modules we go to great lengths to account for differences in versification. User Bibles can accept missing verses except at the beginning of the chapter, but not extra verses.
Helen Brown
OakTree Software

#3 countach

countach

    Silver

  • Active Members
  • PipPipPip
  • 133 posts
  • Gender:Male

Posted 10 June 2007 - 07:55 PM

I think I see the problem. If the verse is zero length, everything falls apart from then on. So if we have this:

Num 1:21
Num 1:22 Simeon 59,300
Num 1:23
Num 1:24 Gad 45,650
Num 1:25
Num 1:26 Judah 74,600
Num 1:27

...the numbering is all thrown out. I think this is a bug.

Also it would be nice if the documentation stated what "some apocryphal books" are allowed import. I'm hoping it is going to be all of the possible ones, but "some" doesn't sound hopeful.

#4 countach

countach

    Silver

  • Active Members
  • PipPipPip
  • 133 posts
  • Gender:Male

Posted 10 June 2007 - 08:01 PM

Also it would be nice if it was documented how to remove an imported version. I can't see how to do it.

#5 countach

countach

    Silver

  • Active Members
  • PipPipPip
  • 133 posts
  • Gender:Male

Posted 10 June 2007 - 08:20 PM

I tried importing a different text, but on this one Accordance crashed. (Info below). I tried it twice, same result.


------------

Date/Time: 2007-06-11 11:17:58.365 +1000
OS Version: 10.4.9 (Build 8P2137)
Report Version: 4

Command: Accord 7.2
Path: /Accordance Folder/Accordance.app/Contents/MacOS/Accord 7.2
Parent: WindowServer [62]
Rosetta: Yes

Version: 7.2.1 (7.2.1)

PID: 548
Thread: Unknown

#6 Helen Brown

Helen Brown

    Mithril

  • Admin
  • 7,981 posts
  • Gender:Female
  • Location:heart in Israel
  • Accordance Version:10.x

Posted 10 June 2007 - 09:18 PM

Please do not post crash reports on the Forum. They are usually of no help to us, and of no interest to others. You need to check the file itself to see if there are anomalies in the text or verse references. If you cannot find the problem, you may send the file to me (off list).

We have corrected some import bugs for the next release, and will check into the zero length verses. Anyway, please write to me directly with your import problems.
Helen Brown
OakTree Software

#7 Helen Brown

Helen Brown

    Mithril

  • Admin
  • 7,981 posts
  • Gender:Female
  • Location:heart in Israel
  • Accordance Version:10.x

Posted 10 June 2007 - 09:22 PM

Also it would be nice if it was documented how to remove an imported version. I can't see how to do it.


You can remove any modules in the Arrange Modules window (Edit menu).
Helen Brown
OakTree Software

#8 Helen Brown

Helen Brown

    Mithril

  • Admin
  • 7,981 posts
  • Gender:Female
  • Location:heart in Israel
  • Accordance Version:10.x

Posted 10 June 2007 - 09:27 PM

Also it would be nice if the documentation stated what "some apocryphal books" are allowed import. I'm hoping it is going to be all of the possible ones, but "some" doesn't sound hopeful.


We didn't test the Apocrypha, but we think most books that are in the RSV Apocrypha will work except for the additions to Esther and Daniel, and Sirach and Tobit. There are so many versification issues in these books that we cannot support them in User Bibles.
Helen Brown
OakTree Software

#9 countach

countach

    Silver

  • Active Members
  • PipPipPip
  • 133 posts
  • Gender:Male

Posted 11 June 2007 - 02:15 AM

There are so many versification issues in these books that we cannot support them in User Bibles.


Well, it would be nice if you supported them one day, by having a user configurable versification mapping like Bibleworks. Lots of stuff related to the apocrypha does not have anything like KJV mapping.

With the crashing, I did some more testing, and it seems to work when restarting Accordance, and then it stops working after the first time. This means the import procedure is probably corrupting memory or something like that.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users