Jump to content


Photo

Junk fonts in Anchor


  • Please log in to reply
10 replies to this topic

#1 countach

countach

    Silver

  • Active Members
  • PipPipPip
  • 134 posts
  • Gender:Male

Posted 19 June 2007 - 07:50 AM

I'm seeing junk fonts in Anchor. I tried reinstalling the latest Accordance program, installing the latest "Font Fixer" and reinstalling Anchor. From some previous postings here I looked in Font Book under Rosetta. I can't see anything obviously untoward about Rosetta, but I don't really know what I'm looking for.

Running OSX 10.4.9

Attached Files



#2 Lorinda H. M. Hoover

Lorinda H. M. Hoover

    Platinum

  • Active Members
  • PipPipPipPipPip
  • 1,291 posts
  • Gender:Female
  • Location:Iowa
  • Accordance Version:11.x

Posted 19 June 2007 - 08:28 AM

Well, the dots to the right of Rosetta mean that there are duplicates. This is probably the issue. You might want to run Font Fixer again (if you haven't done so since you reinstalled Anchor).

The other way to go is to fix it "by hand" in Font Book. In your screen shot, you have "computer" selected in the upper left box. You need to select "All Fonts" in that box. Then go to Rosetta and click the flippy triangle so you can see Bold, Bold, Italic, etc. You should see two or more entries for each Rosetta "sub-fonts" (e.g. two or more Bold). Make sure the pane all the way to the right is set for "show font info" (it is in our screen shot) and check the location of each duplicate font. You want to Disable any fonts that are not in Library/Fonts/. Most frequently for me, my duplicates show up in Users/Lorinda/Library/Fonts, and I have to disable them. (To disable a font, select it, then under the Edit menu choose "Disable")

Lorinda
Running Accordance on:
Mac 10.9 (Mavericks)
iOS 7 (iPad)
Windows Vista Home Premium

#3 countach

countach

    Silver

  • Active Members
  • PipPipPip
  • 134 posts
  • Gender:Male

Posted 19 June 2007 - 09:18 AM

I'm a bit confused I'm afraid. I re-ran font-fixer, but that didn't help.

In Font Book under "all fonts" it just lists bold, italic, bolditalic, plain. It says "Duplicate: yes", but I don't know what I'm supposed to disable. I don't see two of Bold for example.

Under User, or under Users/<name>/Library/Fonts there isn't any Rosetta files.

Attached Files



#4 Robb Brunansky

Robb Brunansky

    Platinum

  • Active Members
  • PipPipPipPipPip
  • 715 posts
  • Gender:Male
  • Location:Glendale, AZ
  • Accordance Version:11.x

Posted 19 June 2007 - 09:25 AM

Another option for fixing it manually is to choose "Resolve Duplicates" from the menu options in font book with Rosetta selected. I think it's under Edit, but I can't check right now since I am on a windoze machine...
Soli Deo Gloria,
Robb Brunansky

#5 countach

countach

    Silver

  • Active Members
  • PipPipPip
  • 134 posts
  • Gender:Male

Posted 19 June 2007 - 10:05 AM

I clicked on every Rosetta entry, selected Resolve Duplicates, but it didn't affect anything.

#6 Helen Brown

Helen Brown

    Mithril

  • Admin
  • 8,428 posts
  • Gender:Female
  • Location:heart in Israel
  • Accordance Version:11.x

Posted 19 June 2007 - 10:26 AM

Your snapshot of Anchor is really weird. This does not look like a typical issue where FontBook has accessed old fonts. Either it has accessed a totally different font, or somehow the Anchor settings got corrupted.

First make sure that in FontBook your Rosetta appears exactly like Robb's. That is, the Location line reads Library/fonts/Rosetta.famTrueType for every style. If it has a different font there, delete Rosetta from FontBook and reinstall Accordance 7.2.1.

If FontBook is truly accessing only the correct font, try removing Anchor from Arrange Modules, click Update, and then add it back again.

If all this fails, please call for tech support. You can ask for me.
Helen Brown
OakTree Software

#7 countach

countach

    Silver

  • Active Members
  • PipPipPip
  • 134 posts
  • Gender:Male

Posted 19 June 2007 - 11:02 AM

I removed the Rosetta font from /Library/Fonts altogether to see what happens. Naturally, it no longer shows up in Font Book. Removed Anchor from arrange modules, updated then added it again. It looks exactly the same. I did a search in Finder for any files on my system containing the word Rosetta, and the only one is the Font in my Trash can. Ran it again: looks the same.

Reran font fixer 7.1. Didn't help. Reinstalled Accordance 7.2.1, didn't help. Reran Font Book after reinstalling, and it looks identical to the above screen shots.

It also seems to affect ISBE (pic attached), so I presume it isn't something specific to Anchor.

See if you can think of anything else to try before I resort to an international phone call. (Might be a good idea if you published a Skype user id for support).

Attached Files



#8 RPat

RPat

    Bronze

  • Active Members
  • PipPip
  • 69 posts

Posted 19 June 2007 - 11:53 AM

Hi:

I had a similar problem after installing some modules with older installs. Even though the 5.7 or later installs work to install modules, I find that in some cases they leave some OS 9 fonts on the disk. Mac OS X is really smart and locates the OS 9 or other fonts and puts them in its font subsystem, "just in case".

Here's some steps to try. You'll need to do them in order. This is how I solved my problem.

1) Remove all the Accordance fonts from FontBook
Helena
Yehudit
Peshitta
Rosetta
Sylvanus
MSS

2) Search and remove all Accordance fonts from the file system. If you see any that are "bitmap" or "postscript" fonts delete them too. They will usually only be in <some long directory path>/font[s]
Accord* (Obviously only delete "font" "fon" "FFIL" "TTF" files)
Helen*
Yehud*
Peshitta
Rosett*
Sylvan*
MSS*

--- Make sure of this. I have had a case where the font subsystem was using an OS 9 version of the font, even though I had deleted from Font Book. Font Book does not always delete the font file.

3) After you are sure that all Accordance Fonts are gone: reboot

4) Run Font Book and make sure they are gone. Run your word processor (Mellel, NeoOffice or Word) and make sure they don't show in the font list.

5) Run Disk Utility and verify/fix permissions on your disk--- I had a couple program fail install because of this.

6) Reinstall 7.2.1 (The Accordance program only-- I assume that the modules are all installed and you're only running the 7.2.1 install; if you run an older install to install modules, you'll need to go to step 1).

7) Reboot (I know, feels like Windows again...)

8) Check Font Book for any duplicates-- any there? If so, you'll need to call Tech Support.

9) Try ABD does it work? No, try the following...

10) What locale are you using? It may not matter for most of the Accordance modules, but maybe for a few. I don't know, but you could set it to "US"

11) Try Anchor now. Any problems? You'll need to call Tech Support

Hope this helps.

Rich

Edited by RPat, 19 June 2007 - 11:57 AM.


#9 Helen Brown

Helen Brown

    Mithril

  • Admin
  • 8,428 posts
  • Gender:Female
  • Location:heart in Israel
  • Accordance Version:11.x

Posted 19 June 2007 - 02:28 PM

I am happy to furnish my Skype name on request, but not to post it on the Forum. I already sent it to countach.
Helen Brown
OakTree Software

#10 countach

countach

    Silver

  • Active Members
  • PipPipPip
  • 134 posts
  • Gender:Male

Posted 20 June 2007 - 03:12 AM

Thanks Rich, removing and reinstalling all fixed it! Thanks Helen, looks like I won't need to call you.

#11 RPat

RPat

    Bronze

  • Active Members
  • PipPip
  • 69 posts

Posted 20 June 2007 - 11:32 AM

Hi Countach:

Glad I could help! Have a great rest of you week.

Kindest regards,

Rich




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users