Jump to content


Photo

6.6 Slow with Quartz


  • Please log in to reply
11 replies to this topic

#1 ajohnson

ajohnson

    Member

  • Members
  • Pip
  • 14 posts

Posted 30 June 2005 - 06:02 AM

After upgrading to 6.6 from 6.5 I'm experiencing some major slowdowns when I have the Quartz font smoothing turned on. It happens mainly when I switch between tabs in a workspace. It takes up to 10 seconds to switch from one tab to another, where it was instantaneous in 6.5. This delay doesn't happen with Quartz turned off. I've tried reinstalling 6.6 several times, but it's still the same. I'm running 10.4.1 on a 1.25GHz G4 with 1GB of RAM. Any suggestions?

Thanks!

#2 jpkang

jpkang

    Platinum

  • Active Members
  • PipPipPipPipPip
  • 577 posts
  • Gender:Male
  • Location:Seattle, WA
  • Interests:Comparative Semitics; ancient Hebrew semantics; Hebrew syntax; history and religion of ancient Israel; history of interpretation.
  • Accordance Version:10.x

Posted 30 June 2005 - 03:59 PM

Just curious--are you simultaneously running any other smoothing utilities like Silk?

You could also try opening up Console in /Applications/Utilities and see if there are any diagnostic messages that might indicate some kind of conflict (though, admittedly, this can often be a frustrating exercise in decryption).
J. P. Kang, Ph.D. (Bible)

#3 ajohnson

ajohnson

    Member

  • Members
  • Pip
  • 14 posts

Posted 30 June 2005 - 05:39 PM

I'm not using any other smoothing utilities. The font I'm using on my bible texts is Lucida Grande and for my notes and reference tools it's Geneva. Scrolling through synchronized texts is also delayed. As soon as I turn the font smoothing off in the Preferences everything is back to its speedy old self.

#4 jpkang

jpkang

    Platinum

  • Active Members
  • PipPipPipPipPip
  • 577 posts
  • Gender:Male
  • Location:Seattle, WA
  • Interests:Comparative Semitics; ancient Hebrew semantics; Hebrew syntax; history and religion of ancient Israel; history of interpretation.
  • Accordance Version:10.x

Posted 30 June 2005 - 08:32 PM

Perhaps try repairing permissions (Disk Utility in /Applications/Utilities/) and run the 6.6 updater again?
J. P. Kang, Ph.D. (Bible)

#5 jpkang

jpkang

    Platinum

  • Active Members
  • PipPipPipPipPip
  • 577 posts
  • Gender:Male
  • Location:Seattle, WA
  • Interests:Comparative Semitics; ancient Hebrew semantics; Hebrew syntax; history and religion of ancient Israel; history of interpretation.
  • Accordance Version:10.x

Posted 30 June 2005 - 09:49 PM

Well, well... I take back some of what I said earlier. I think I'm seeing very similar behavior on my PowerBook running 10.4.1 (lots of the spinning pizza). According to the system activity monitor, Accordance 6.6 will take 40%+ of the processor when I'm simply scrolling (sluggishly) through text. I should add that I do have a dozen tabs open, so that might be part of it, but I think this is a genuine issue. I also think it started happening after I had a details window open (now closed), and that it also seems to set in after a while--quitting and restarting Accordance with all my tabs restored (and smoothing on), things are snappy again. Are you experiencing this gradual onset of the symptoms, as well?
J. P. Kang, Ph.D. (Bible)

#6 ajohnson

ajohnson

    Member

  • Members
  • Pip
  • 14 posts

Posted 02 July 2005 - 05:20 PM

My symptoms seem to happen immediately, not gradually. I have a workspace that I save and open everytime I use Accordance, and it has between 5-12 tabs at any given time. Here's the funny thing. When I was running version 6.5 I used Adobe Myriad as my display font for all my bible texts. Using this font (or any other Postscript font) caused the fonts to smooth on screen and it looked very nice and "Quartz-like." If I used a TrueType font, such as Geneva for example, the smoothing would be gone and I'd get the typical rough look. Well, now in version 6.6 Myriad (or any other Postscript font for that matter) no longer looks smooth, unless of course I turn on the Quartz smoothing option in the Preferences. So I decided since the Postscript fonts weren't giving me any smoothing advantages in 6.6 that I'd just use Lucida Grande instead since it's a System font and is quite readable on screen.

So for now I think I'll just keep the font smoothing turned off so that the program continues to perform quickly. Or I might just reinstall Accordance 6.5 so that I can get the Postscript font smoothing back without sacrificing any speed.

Perhaps this is something the Accordance team could look into. Maybe it's an easy tweak for an update?

Thanks jpkang for continuing to test this with me!

#7 Helen Brown

Helen Brown

    Mithril

  • Admin
  • 8,219 posts
  • Gender:Female
  • Location:heart in Israel
  • Accordance Version:10.x

Posted 02 July 2005 - 06:41 PM

We are currently "down under" with little time for extermination of bugs. Several people have reported the slowing. We think it disappears if you turn off font smoothing. We also think it may be related to Spotlight. Perhaps you can try turning this off for the Accordance folder to see if that makes a difference.
Helen Brown
OakTree Software

#8 ajohnson

ajohnson

    Member

  • Members
  • Pip
  • 14 posts

Posted 03 July 2005 - 08:20 AM

Thanks for the response Helen. I turned Spotlight off for the Accordance folder and still get the same slowdowns. For now I'll just keep the font smoothing turned off.

Much success to you all in Australia!

#9 jpkang

jpkang

    Platinum

  • Active Members
  • PipPipPipPipPip
  • 577 posts
  • Gender:Male
  • Location:Seattle, WA
  • Interests:Comparative Semitics; ancient Hebrew semantics; Hebrew syntax; history and religion of ancient Israel; history of interpretation.
  • Accordance Version:10.x

Posted 05 July 2005 - 02:07 PM

You're certainly welcome; I hope a clear culprit emerges so it can be squashed!
J. P. Kang, Ph.D. (Bible)

#10 hughwalton

hughwalton

    Member

  • Members
  • Pip
  • 2 posts

Posted 13 July 2005 - 02:39 PM

I also am experiencing a slow down in version 6.6 especially going from tab to tab. I am running Mac OS X 10.3.9 on a 1.8GHz iMac G5 with 1GB DDR SDRAM.
I went back to version 6.5 and regained good performance. And, in 6.5, it does not matter if font smoothing is on or off... it is quick either way.
I prefer to have the quick operation rather than whatever benefits 6.6 gives me and the slow performance.

#11 nickpage

nickpage

    Member

  • Active Members
  • Pip
  • 13 posts
  • Location:Eynsham, England

Posted 23 July 2005 - 07:38 AM

I too have this problem. Not only in opening tabs, but typing in the User's Notes was intolerably slow. Fine when the font smoothing is turned off.
Nick Page

#12 Helen Brown

Helen Brown

    Mithril

  • Admin
  • 8,219 posts
  • Gender:Female
  • Location:heart in Israel
  • Accordance Version:10.x

Posted 23 July 2005 - 07:54 AM

Please see my post under Tiger Slowdown and give me some feedback.

Thanks
Helen Brown
OakTree Software




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users