Jump to content


Photo

User Tool Bugs


  • Please log in to reply
2 replies to this topic

#1 BrianBowman

BrianBowman

    Member

  • Active Members
  • Pip
  • 39 posts
  • Gender:Male
  • Location:Apex, NC
  • Interests:The Mysteries of Christ, Holy Scripture, Patristic and Catholic Theology, Guitar, Classical Pilates, Software Engineering, Craftsman Architecture
  • Accordance Version:8.x

Posted 01 July 2005 - 09:31 PM

Hi,

I'm a visually imparied individual who has spent 20+ years developing very complex systems software professionally, therefore I have some real appreciation for just how good (and complicated) Accordance "internals" are. I simply *love* the User Tool feature in Accordance (especially with the HTML importing) because it allows me to develop Bible and Historical Theological Study content where the font size can easily be increased. However, I have experienced a number of the same bugs in the User Tool facility for the past 3 years. These started back in Accordance 5 and some seem to still exist in 6.6 with some new ones in 6.6 as well.

Here are the User Tool bugs I've seen since Accordance 5:

1) Interposed sections (i.e. those marked by 'T', '1', '2,' etc. Heading designations) magically disappear after doing additional editing on surrounding sections. I've verified that the text is actually removed from the tool by viewing the "before and after" with BBEdit.

2) Markup such as BOLD, Center, etc. simply disappears after performing editing operations on neighboring text.

3) Text blocks (i.e. paragraphs) that were left-justified magically become centered or right-justified (oddly with the first line of the paragraph still left-justified) after performing editing operations on neighboring major sections (i.e. those marked by 'T', '1', '2,' etc. Heading designations).

Here is the User Tool bug I've seen in Accordance 6.6:

1) The markup result for text with Bold and/or Italics is not visible in the Editor. Only the plain text is present.


While, I really, really appreciate the availabilty of the Accordance User Tool, I've spent nearly 100 hours over the past couple of years dealing with these idiosyncratic behaviors and bugs. I feel pretty confidient that in this amound of time, I could have identified and fixed the software bugs in the User Tool :) .


Brian Bowman

#2 David Lang

David Lang

    Platinum

  • Accordance
  • 755 posts
  • Gender:Male
  • Location:Mount Dora, FL
  • Interests:Accordance development, writing, spending time with my wife and five kids
  • Accordance Version:9.x

Posted 01 July 2005 - 10:12 PM

Here are the User Tool bugs I've seen since Accordance 5:

1)  Interposed sections (i.e. those marked by 'T', '1', '2,' etc. Heading designations) magically disappear after doing additional editing on surrounding sections.  I've verified that the text is actually removed from the tool by viewing the "before and after" with BBEdit.

2) Markup such as BOLD, Center, etc. simply disappears after performing editing operations on neighboring text.

3) Text blocks (i.e. paragraphs) that were left-justified magically become centered or right-justified (oddly with the first line of the paragraph still left-justified) after performing editing operations on neighboring major sections (i.e. those marked by 'T', '1', '2,' etc. Heading designations).

Here is the User Tool bug I've seen in Accordance 6.6:

1)  The markup result for text with Bold and/or Italics is not visible in the Editor.  Only the plain text is present.


Brian,

I too have occasionally run into some of these odd behaviors in the Edit window, and we'll certainly do our best to iron them out.

With respect to the problem of bold and italicized text not being visible in the Edit window in 6.6, this is not a bug so much as an oversight on our part. The Edit window defaults to using the Geneva font, but because the Geneva font does not have italic and boldface versions, and because Quartz looks for those fonts when trying to display italic and bold text, the bold and italicized text is appearing as plain text. It's a quirky thing, but it could easily be fixed by changing the default font for the Edit window to Lucida Grande instead of Geneva. We just didn't think of that when we released 6.6.

Until we fix that oversight, the best way around it is to turn off the font smoothing in the Preferences whenever you're editing text in the User Tools Edit window.

Hope this helps.
Sincerely,
David Lang
Accordance Developer
http://www.accordancebible.com

Author:
Feet to Follow, Eyes to See
http://feettofollow.wordpress.com

Macs in the Ministry
http://www.macsinministrybook.com

Leader of the "Lang Gang"
http://www.langgangland.com
http://twitter.com/DavidAllenLang

#3 BrianBowman

BrianBowman

    Member

  • Active Members
  • Pip
  • 39 posts
  • Gender:Male
  • Location:Apex, NC
  • Interests:The Mysteries of Christ, Holy Scripture, Patristic and Catholic Theology, Guitar, Classical Pilates, Software Engineering, Craftsman Architecture
  • Accordance Version:8.x

Posted 02 July 2005 - 09:12 AM

Thanks David,

Please email me if I can be of any further assistance in debugging the User Tool Editor. Back in the 80's I worked on a trace facility for the editor in an "industrial strength" commercial software product. Does Accordance have the capability to log/trace editor events? If this were avialable, I could precisely record the manual actions I take when editing User Tools and correlate them with logged events in an attempt to identify problems. I'm less concerned with the markup issues, but the loss of content is very frustrating. Of course, I do make incremental backups, so "all is not lost"
:(

Brian Bowman




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users