Jump to content


Photo

Italics not "Sticking" in User Tools


  • Please log in to reply
7 replies to this topic

#1 Lorinda H. M. Hoover

Lorinda H. M. Hoover

    Platinum

  • Active Members
  • PipPipPipPipPip
  • 1,090 posts
  • Gender:Female
  • Location:Iowa
  • Accordance Version:10.x

Posted 10 June 2008 - 03:44 PM

I'm running 8.0.1 (Universal) on an iBook G4 (Tiger).

Since upgrading, italicized words and phrases in my user tools won't "stick" in the edit window. I can make some italics, but it will shortly revert to what appears to be plain text. The "regular" User Tools veiw does not appear to be affected.

I presume this is related to the fact that Helvetica does not really have an italic version (as mentioned in this post). But I did not have this problem in Accordance version 7.

I can get the italics to "return" in a specific spot if I select the text and reset the font to Helvetica in the text pallette. Occasionally this doesn't work and I have to shift the font to Helena and then back to Helvetica. Note that this only affects the selected text.

I have text smoothing turned on; if I turn it off, the italics all reappear, but the resulting text is ugly and hard to read.

Lorinda

Running Accordance on:

Mac 10.9 (Mavericks)

iOS 7 (iPad)

Windows Vista Home Premium


#2 Lorinda H. M. Hoover

Lorinda H. M. Hoover

    Platinum

  • Active Members
  • PipPipPipPipPip
  • 1,090 posts
  • Gender:Female
  • Location:Iowa
  • Accordance Version:10.x

Posted 10 June 2008 - 03:50 PM

Update: When I first open an edit window for a User Tool, no italics are visible in the edit window, although they still exist in the User Tool tab of my work space.

Running Accordance on:

Mac 10.9 (Mavericks)

iOS 7 (iPad)

Windows Vista Home Premium


#3 Lorinda H. M. Hoover

Lorinda H. M. Hoover

    Platinum

  • Active Members
  • PipPipPipPipPip
  • 1,090 posts
  • Gender:Female
  • Location:Iowa
  • Accordance Version:10.x

Posted 21 June 2008 - 11:02 AM

The 8.0.2 update appears to have corrected the dissappearing Italics problem, but not there is a new one.

In the Edit User Tools window, in italicized text (and only italicized text), the following substitutions take place in the display:
the smart right double quote character turns into a j
the smart left double quote character turns into an S
the smart apostrophe/smart right single quote turns into an ħ (it looks like an h with a bar across it)
the smart left single quote turns into an Ћ (it looks like an h with a line across the top of the bar)
If I click in the affected line of text and a) start typing or b) select it, the characters revert to the correct punctuation. It stays correct until I scroll the user tool to "hide" that line. When I return to that line of text, the punctuation has been replaced again.

I have text smoothing and smart quotes turned on. If I turn text smoothing off, the text is correct, but very hard to read. If I turn off smart quotes, punctuation typed after that point does not change. Punctuation type while smart quotes was on is still affected, presumably since it has been saved as the smart quote characters.

The saved User Tool displays correctly, regardess of the settings, with the exception that turning off graphics smoothing results in text that is hard on the eyes. (How picky we have become! The text without smoothing is reminiscent of my early Mac days) The problems I am describing only happen in the User Tool Edit window.

Lorinda

Running Accordance on:

Mac 10.9 (Mavericks)

iOS 7 (iPad)

Windows Vista Home Premium


#4 Lorinda H. M. Hoover

Lorinda H. M. Hoover

    Platinum

  • Active Members
  • PipPipPipPipPip
  • 1,090 posts
  • Gender:Female
  • Location:Iowa
  • Accordance Version:10.x

Posted 21 June 2008 - 01:47 PM

I just discovered another transformation: fi becomes a rectangular box.

Running Accordance on:

Mac 10.9 (Mavericks)

iOS 7 (iPad)

Windows Vista Home Premium


#5 Justin Burt

Justin Burt

    Silver

  • Active Members
  • PipPipPip
  • 167 posts
  • Gender:Male
  • Location:Indonesia
  • Interests:Chess, Backpacking, and Traveling.

Posted 21 June 2008 - 02:47 PM

Lorinda,

I have found that when I am having trouble working with the User Tools, I update before I scroll down. I have had problems similar to what you are describing in previous versions of Accordance, and updating before I scrolled down worked most of the time. I have been working in User Tools the whole week and have similar texts to what you are describing, but it all seems to be in working order. I say to that to say, it doesn't SEEM to be a bug.
Justin Burt

#6 Mike Garrity

Mike Garrity

    Gold

  • Accordance
  • 288 posts
  • Gender:Male
  • Location:Florida
  • Accordance Version:10.x

Posted 21 June 2008 - 06:07 PM

Hey Lorinda,

I was able to reproduce the problem with scrolling in the Edit Window. I believe this is an Edit Window display problem and I don't think it effects the User Tool you are editing.

I have not looked for the problem yet, but I wanted to tell you one workaround to force a redraw in the Edit Window. You can simply click in the grow box (in the lower right corner of the Edit Window) to force a redraw.

I am sorry for the inconvenience.

Mike

#7 Lorinda H. M. Hoover

Lorinda H. M. Hoover

    Platinum

  • Active Members
  • PipPipPipPipPip
  • 1,090 posts
  • Gender:Female
  • Location:Iowa
  • Accordance Version:10.x

Posted 21 June 2008 - 08:03 PM

Thanks, Mike.

You are correct that it does not affect the User Tool, just the display in the Edit window.

Thanks for the workaround.

Since it's just a display issue it is an annoyance but not a major problem. I can wait patiently for a fix.

Lorinda

Running Accordance on:

Mac 10.9 (Mavericks)

iOS 7 (iPad)

Windows Vista Home Premium


#8 Lorinda H. M. Hoover

Lorinda H. M. Hoover

    Platinum

  • Active Members
  • PipPipPipPipPip
  • 1,090 posts
  • Gender:Female
  • Location:Iowa
  • Accordance Version:10.x

Posted 23 June 2008 - 02:39 PM

Just another follow up, to add a little more info:

-I can also clear the display by clicking anywhere in the edit window and hitting Command-A (select all).

-Today it is happening with huge chunks of my text in the edit window, not just the italicized phrases. When it happens, everything shifts to gibberish when I scroll, or, even occasionally when I paste in some text. But a quick Select All fixes the display issue.

Having found the Command-A trick, it's just a minor annoyance at this point.

Lorinda

Running Accordance on:

Mac 10.9 (Mavericks)

iOS 7 (iPad)

Windows Vista Home Premium





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users