Jump to content


Photo

Superscript


  • Please log in to reply
17 replies to this topic

#1 Kevin Murray

Kevin Murray

    Member

  • Active Members
  • Pip
  • 8 posts
  • Accordance Version:8.x

Posted 03 November 2008 - 05:00 PM

Hi everyone. When I prepare sermons I like to cut and paste the passage into a word processor and then write all over the pages and make notes etc.

I don't like verse numbers getting in the way so I manually superscript them and take them down to 9 point as well [they are a necessary evil].

Is there a way to do this automatically in Accordance so I don't have to manually do the superscript? ie. I'd like to be able to export or cut and paste the text 'ready to go' into my word processor.

Thanks

Kevin

#2 Joe Weaks

Joe Weaks

    Platinum

  • Active Members
  • PipPipPipPipPip
  • 1,043 posts
  • Gender:Male
  • Location:Raytown, MO (outside KC)
  • Interests:I like things that are Orange, and possibly Blue.
  • Accordance Version:8.x

Posted 03 November 2008 - 06:13 PM

Kevin,
I may not be understanding your question, since my suggestions are pretty simple.
When you have a text open, select from the menu "Display/Set Text Display..." or press ⌘t. This brings up the text display dialog, where you can set many properties to the references in the text, including superscript. Do that, and if you want to, click the button to make those changes the default display option for every new window of that module.
Then, satisfied with the look, you can copy and paste text or you can save a window of text as an .rtf file that will be read with styling intact in your word processor.
Do offer more clarification if this is not what you're looking for.
Cheers,
Joe

Edited by Joe Weaks, 03 November 2008 - 06:14 PM.

Joe Weaks
The Macintosh Biblioblog

Sometimes I'm so helpful even I can't stand it.

#3 Kevin Murray

Kevin Murray

    Member

  • Active Members
  • Pip
  • 8 posts
  • Accordance Version:8.x

Posted 03 November 2008 - 06:39 PM

Thanks Joe. I tried that repeatedly last night with no success.

I want to be able to read the line and have the verse reference [with no book or chapter ref] in 9 point above the line as a superscript.

Whenever I try this in the Text Setting Pref box I can get a preview in the "References" Style sample for italics, bold, underline but no preview for superscript.

Can't seem to work out how to attach a sample.

Thanks
Kevin

Edited by Kevin Murray, 03 November 2008 - 06:39 PM.


#4 Helen Brown

Helen Brown

    Mithril

  • Admin
  • 8,104 posts
  • Gender:Female
  • Location:heart in Israel
  • Accordance Version:10.x

Posted 03 November 2008 - 06:58 PM

I used Set Text Display to set the text like this:
Attached File  superscript.jpg   57.62KB   53 downloadsAttached File  settings.jpg   46.25KB   33 downloads
But you can also go to Preferences: Citation and set a different format for the export of the text as a citation (Copy Special in the Edit menu) so that you can view it one way in Accordance and past it differently into Word.
Helen Brown
OakTree Software

#5 Kevin Murray

Kevin Murray

    Member

  • Active Members
  • Pip
  • 8 posts
  • Accordance Version:8.x

Posted 03 November 2008 - 07:05 PM

Thanks Helen. I've tried that as well but it doesn't do what I want. I prefer to have the verse number not on the line but just above the line i.e. slightly out of the way. Can Accordance do this or am I being too picky?

By the way I'm from Australia enjoyed your Carlton seminar.

Thanks.

Kevin

#6 Helen Brown

Helen Brown

    Mithril

  • Admin
  • 8,104 posts
  • Gender:Female
  • Location:heart in Israel
  • Accordance Version:10.x

Posted 03 November 2008 - 07:33 PM

Look closely, the verse number is superscripted, except at the beginning of a paragraph.
Helen Brown
OakTree Software

#7 Kevin Murray

Kevin Murray

    Member

  • Active Members
  • Pip
  • 8 posts
  • Accordance Version:8.x

Posted 03 November 2008 - 07:59 PM

Thanks Helen - but try as I might I can't reproduce what you are getting.

But even what you've produced is inconsistent even in the screenshot eg verse 2 is superscripted but verse 3 isn't and verse 5 is partial.

Kevin

#8 Helen Brown

Helen Brown

    Mithril

  • Admin
  • 8,104 posts
  • Gender:Female
  • Location:heart in Israel
  • Accordance Version:10.x

Posted 03 November 2008 - 08:41 PM

I gave you a snapshot of the settings, and I do not agree that the superscript is partial, it just does not appear on the first verse in the paragraph.

What version of Accordance are you using, and which text and version of the text?
Helen Brown
OakTree Software

#9 Joe Weaks

Joe Weaks

    Platinum

  • Active Members
  • PipPipPipPipPip
  • 1,043 posts
  • Gender:Male
  • Location:Raytown, MO (outside KC)
  • Interests:I like things that are Orange, and possibly Blue.
  • Accordance Version:8.x

Posted 03 November 2008 - 10:26 PM

Can't seem to work out how to attach a sample.

Kevin,
Try taking a screenshot of the two windows that Helen showed so we can have a look at your setup. Have a look here if you want help in how to take screenshots.

#10 Kevin Murray

Kevin Murray

    Member

  • Active Members
  • Pip
  • 8 posts
  • Accordance Version:8.x

Posted 03 November 2008 - 11:21 PM

Thanks Joe. My problem isn't how to take a screenshot [I've been using Macs for 18 years] but how to post a jpg in the forums.

I've tried 'choose file' on the reply to post page but nothing has appeared.

Thanks

Kevin

#11 Joe Weaks

Joe Weaks

    Platinum

  • Active Members
  • PipPipPipPipPip
  • 1,043 posts
  • Gender:Male
  • Location:Raytown, MO (outside KC)
  • Interests:I like things that are Orange, and possibly Blue.
  • Accordance Version:8.x

Posted 04 November 2008 - 02:01 AM

After you upload an image with the Choose File button, you then click on it and then click the Upload button, then the (0) should change to a (1) in the "Manage Current Attachments" menu just to the left of it.
Attached File  Picture_3.png   5.49KB   7 downloads
Select the drop down file and it will put into your post code like:
attachment=381:Picture_3.png
inside of brackets [ ].
I must confess that I don't see how Helen's screenshot example is not doing what you're requesting, perhaps with the exception of each reference that happens at the beginning of a paragraph.

Edited by Joe Weaks, 04 November 2008 - 02:03 AM.

Joe Weaks
The Macintosh Biblioblog

Sometimes I'm so helpful even I can't stand it.

#12 Kevin Murray

Kevin Murray

    Member

  • Active Members
  • Pip
  • 8 posts
  • Accordance Version:8.x

Posted 04 November 2008 - 02:59 AM

Thanks Joe and Helen for your patience.

I'm using Accordance 8.1 with ESV 2.1 and NIV 2.2 on a MacBook Pro.

What I'd ideally like to achieve is this from Daniel 3

Attached File  Dan_3.png   187.1KB   25 downloads


See how the verse numbers are above the baseline?

Using the settings that Helen supplied my set up looks like this

Attached File  Setup.png   62.65KB   31 downloads

and this is what I get

Attached File  Gen_1.png   39.32KB   27 downloads

But the verse numbers are still near the baseline.

Thanks for any suggestions.

Kevin

#13 Helen Brown

Helen Brown

    Mithril

  • Admin
  • 8,104 posts
  • Gender:Female
  • Location:heart in Israel
  • Accordance Version:10.x

Posted 04 November 2008 - 07:45 AM

It does not show in the sample, but I did select the superscript style for the verse references. Did you?

David pointed out to me that you probably are concerned with the appearance after copy and paste into another program. The problem here is that the clipboard does not support the superscript style. The solution is to save the text selection as an RTF file. This preserves the superscript style well (I tried it in TextEdit). Of course, it is a little more hassle than a quick copy and paste.
Helen Brown
OakTree Software

#14 Joe Weaks

Joe Weaks

    Platinum

  • Active Members
  • PipPipPipPipPip
  • 1,043 posts
  • Gender:Male
  • Location:Raytown, MO (outside KC)
  • Interests:I like things that are Orange, and possibly Blue.
  • Accordance Version:8.x

Posted 04 November 2008 - 11:55 AM

But the verse numbers are still near the baseline.

Kevin,
It is clear in the screen shot that you posted that you have not in fact set the style of the reference to Superscript, as Helen questioned. Do you see it there at the bottom of the popup menu in the Reference side entitled "Style:"

Attached File  Superscript.png   85.39KB   18 downloads

The two things that aren't ideal for you is that the reference at the beginning of each paragraph are not going to be in Superscript, and you'll have to save as an .rtf file and then open in order to preserve the Superscript formatting.
Joe Weaks
The Macintosh Biblioblog

Sometimes I'm so helpful even I can't stand it.

#15 Kevin Murray

Kevin Murray

    Member

  • Active Members
  • Pip
  • 8 posts
  • Accordance Version:8.x

Posted 04 November 2008 - 05:59 PM

Thanks Joe and Helen. I've tried everything you've suggested multiple times but the verses are still on the baseline.

I put the style in superscript and then "save text selection as rtf" and it produces the text with the verses on the baseline in Textedit.

I've got a friend who is a power Accordance user flying in from Western Australia tonight. I'll see if he can spot what I'd doing wrong.

Kevin

#16 Kevin Murray

Kevin Murray

    Member

  • Active Members
  • Pip
  • 8 posts
  • Accordance Version:8.x

Posted 05 November 2008 - 07:17 AM

Success! Working with a friend he pointed out that I was making the change in the global preferences rather than in just the individual text eg ESV text. So it worked in the individual text.

But it wouldn't work in the global preferences.

Thanks very much for your help.

#17 Helen Brown

Helen Brown

    Mithril

  • Admin
  • 8,104 posts
  • Gender:Female
  • Location:heart in Israel
  • Accordance Version:10.x

Posted 05 November 2008 - 08:59 AM

I think it does work in Preferences, but these do not affect open or saved windows, only new panes and windows.
Helen Brown
OakTree Software

#18 Joe Weaks

Joe Weaks

    Platinum

  • Active Members
  • PipPipPipPipPip
  • 1,043 posts
  • Gender:Male
  • Location:Raytown, MO (outside KC)
  • Interests:I like things that are Orange, and possibly Blue.
  • Accordance Version:8.x

Posted 05 November 2008 - 02:23 PM

Success! Working with a friend he pointed out that I was making the change in the global preferences rather than in just the individual text eg ESV text. So it worked in the individual text.

Kevin,
Glad you got it working.
Now, if only you could've followed the instruction of the very first reply to your question:

I may not be understanding your question, since my suggestions are pretty simple.
When you have a text open, select from the menu "Display/Set Text Display..." or press ⌘t.

:P




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users