Jump to content


Photo

Copying Hebrew


  • Please log in to reply
13 replies to this topic

#1 M.Chris.Schwartz

M.Chris.Schwartz

    Member

  • Active Members
  • Pip
  • 12 posts
  • Accordance Version:8.x

Posted 23 September 2009 - 02:10 PM

I am trying to copy Hebrew into a pages document. Each time I do it, it reverse the lines. The first line is on the bottom. Is there a way to remedy this?

#2 Helen Brown

Helen Brown

    Mithril

  • Admin
  • 8,506 posts
  • Twitter:accordancebible
  • Gender:Female
  • Location:heart in Israel
  • Accordance Version:11.x
  • Platforms:Mac OS X, Windows, iOS

Posted 23 September 2009 - 02:22 PM

I think you are keeping the text in Yehudit, which is fine for your own use. You must make the text pane in Accordance narrower than that of Pages so that the text does not wrap. The lines you export must fit in pages without wrapping or dividing, since Yehudit is not a true right-to-left font.

The alternative is to set Preferences: Greek & Hebrew to export to Unicode, but Pages is not very good at righ-to-left unicode either, better than Word, but not nearly as good as Mellel or Nisus.
Helen Brown
OakTree Software

#3 jpkang

jpkang

    Platinum

  • Active Members
  • PipPipPipPipPip
  • 577 posts
  • Gender:Male
  • Location:Seattle, WA
  • Interests:Comparative Semitics; ancient Hebrew semantics; Hebrew syntax; history and religion of ancient Israel; history of interpretation.
  • Accordance Version:10.x

Posted 23 September 2009 - 03:52 PM

I would only add to Helen's reply that Pages will do better with Unicode Hebrew that has vowels and cantillation stripped from it (a checkbox in the Greek & Hebrew preferences). I also personally like the SBL Unicode fonts.
J. P. Kang, Ph.D. (Bible)

#4 J A Miller

J A Miller

    Member

  • Active Members
  • Pip
  • 17 posts
  • Gender:Male
  • Accordance Version:8.x

Posted 21 October 2009 - 10:37 AM

I would only add to Helen's reply that Pages will do better with Unicode Hebrew that has vowels and cantillation stripped from it (a checkbox in the Greek & Hebrew preferences). I also personally like the SBL Unicode fonts.


I wondered if you could help. I have been trying to figure out how to copy into Scrivener with the unicode SBL fonts. I have set the preferences in Accordance to export to Unicode, but when I copy and paste into Scrivener, the Lucida Grande font is being pasted into the document with Greek and Hebrew letters. I then have to highlight and select the SBL font from the font menu in Scrivener to get the font type I desire. Am I missing a step or setup option in Accordance?

Edit: Scrivener is built on OS X's text edit program, so I don't know if that is a limitation, but I have the same problem pasting into Mellel as well.

Edited by J A Miller, 21 October 2009 - 10:54 AM.


#5 Helen Brown

Helen Brown

    Mithril

  • Admin
  • 8,506 posts
  • Twitter:accordancebible
  • Gender:Female
  • Location:heart in Israel
  • Accordance Version:11.x
  • Platforms:Mac OS X, Windows, iOS

Posted 21 October 2009 - 11:34 AM

You cannot select the font in Accordance, but can you try pasting as plain text after setting the font in Scrivener?
Helen Brown
OakTree Software

#6 J A Miller

J A Miller

    Member

  • Active Members
  • Pip
  • 17 posts
  • Gender:Male
  • Accordance Version:8.x

Posted 21 October 2009 - 12:26 PM

You cannot select the font in Accordance, but can you try pasting as plain text after setting the font in Scrivener?


I am sorry, but I am not sure I am following you. I only have the option to "Paste" in Scrivener. E.g., sometimes I want to copy a root form from a Hebrew or Greek dictionary or highlight Hebrew or Greek text from the Hebrew or Greek testaments, so I highlight the word, right-click - copy, then in Scrivener or Mellel I right-click - paste. The results are the same for both Scrivener and Mellel: I get the text in Hebrew or Greek characters but the font is Lucida Grande. I then have to highlight the Hebrew or Greek and select the SBL Hebrew or SBL Greek font. Is there a different way to do the same thing?

#7 Helen Brown

Helen Brown

    Mithril

  • Admin
  • 8,506 posts
  • Twitter:accordancebible
  • Gender:Female
  • Location:heart in Israel
  • Accordance Version:11.x
  • Platforms:Mac OS X, Windows, iOS

Posted 21 October 2009 - 12:57 PM

In MS Word there is an option to paste as plain text, and many programs support shift-option-command-V to do the same thing. This then ignores the style information in the clipboard and continues the current font and style at the insertion point in the document.
  • Rick Paquette likes this
Helen Brown
OakTree Software

#8 J A Miller

J A Miller

    Member

  • Active Members
  • Pip
  • 17 posts
  • Gender:Male
  • Accordance Version:8.x

Posted 21 October 2009 - 02:26 PM

Thank you for the response, Helen. I have learned something new today. I found out that if I switch to the SBL font in Mellel and Scrivener and then do a plain paste the text will be pasted in the SBL font.

I will use this option as a workaround for now, in the hope that a future version of Accordance will allow the user to choose which font to export for various languages (English, Greek, Hebrew). This is something I miss from my work in BibleWorks which does include this functionality.

#9 Rick Bennett

Rick Bennett

    Platinum

  • Accordance
  • 1,879 posts
  • Gender:Male
  • Location:Tampa Bay, FL
  • Interests: gadgets, coffee, running and cycling, Rays baseball
  • Accordance Version:10.x

Posted 21 October 2009 - 03:19 PM

Note that you can also create a Character Style in Mellel just for Hebrew. Once this is done, either select a portion of text and double-click the style (see shot below) or double-click it before pasting. This should save you some time in changing the font, and size every time you want to copy/paste Hebrew.

Attached File  Screen shot 2009-10-21 at 4.16.32 PM.png   116.36KB   49 downloads

Rick Bennett
Director of Content Development
iOS Working Group


#10 J A Miller

J A Miller

    Member

  • Active Members
  • Pip
  • 17 posts
  • Gender:Male
  • Accordance Version:8.x

Posted 26 October 2009 - 11:56 AM

Note that you can also create a Character Style in Mellel just for Hebrew. Once this is done, either select a portion of text and double-click the style (see shot below) or double-click it before pasting. This should save you some time in changing the font, and size every time you want to copy/paste Hebrew.

Attached File  Screen shot 2009-10-21 at 4.16.32 PM.png   116.36KB   49 downloads


Thanks for the tip.

#11 Kevin Soars

Kevin Soars

    Silver

  • Active Members
  • PipPipPip
  • 129 posts
  • Location:Vienna, Austria & UK

Posted 26 October 2009 - 02:59 PM

Rick,

I would like to add my thanks too.

Kevin.
Kevin.

#12 YingLam

YingLam

    Bronze

  • Active Members
  • PipPip
  • 85 posts
  • Gender:Male
  • Location:Hong Kong
  • Accordance Version:8.x

Posted 24 November 2009 - 08:07 AM

Hi,

Sorry for asking this here. This thread has been very useful to me. But I bumped into a minor problem that when I changed the font to SBL Hebrew in Mellel, there appeared an arrow pointing towards the left above some of my Hebrew characters. I don't have this problem when I changed the font to Yehudit. But as Helen has said, this is not a true right to left font.

How come?

YingLam

#13 Helen Brown

Helen Brown

    Mithril

  • Admin
  • 8,506 posts
  • Twitter:accordancebible
  • Gender:Female
  • Location:heart in Israel
  • Accordance Version:11.x
  • Platforms:Mac OS X, Windows, iOS

Posted 24 November 2009 - 10:18 AM

These are direction change indicators, and only appear in certain fonts. Try Cardo, for example. There is a post on this topic, but I cannot take time to locate it now.
Helen Brown
OakTree Software

#14 YingLam

YingLam

    Bronze

  • Active Members
  • PipPip
  • 85 posts
  • Gender:Male
  • Location:Hong Kong
  • Accordance Version:8.x

Posted 27 November 2009 - 01:00 AM

Helen,


Many thanks.

YingLam




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users