Jump to content


Photo

Handling Corrupt Accordance Fonts


  • Please log in to reply
1 reply to this topic

#1 Doug Gray

Doug Gray

    Member

  • Members
  • Pip
  • 1 posts

Posted 22 November 2005 - 09:40 AM

I have had a great experience with Accordance in Tiger thanks to the updates.

However, every time I booted MS Word 2004, it would optimize the font menu and complain that "The Rosetta font is corrupt and should be disabled or removed." In fact, every Accordance font was listed. When I checked on things in FontBook, and followed the directions Helen has offered in fonts.pdf and a number of other places in these forums, the problem still persisted.

Rummaging around in some newsgroups, the suggestion was made to clear the font cache. Using FontFinagler, I did just that...and voila! The problem is gone!

The only potential fly in the ointment is that when you clear the font cache, it "forgets" what fonts are enabled and which are disabled. I judged that hassle was worth the effort.

Doug

#2 Mick Matousek

Mick Matousek

    Silver

  • Active Members
  • PipPipPip
  • 173 posts
  • Gender:Male
  • Accordance Version:10.x

Posted 10 December 2005 - 12:13 PM

Looks likes you are right on target Doug. Note a MacInTouch user report:


MacInTouch
Saturday, December 10, 2005 11:26 EST
Notes and Tips

Craig Jones shared a tip about one of the frequent font problems that plagues Mac OS X:

Here is another of those hard-won tips. As with many others (check, for instance, Google Groups with "Tiger font cache office"), Office 2004 one day decided that a lot of my fonts were corrupt. Using Office bordered on insane.
Nothing else thought they were (not Font Book, not FontDoctor). Tried MS's rather lame support board suggestion; I could launch Office if I hacked down to a few basic fonts, but then other codes would be in trouble. Moved all my user fonts, MS Office's fonts. Flushed Office's font cache, cleared caches from FontDoctor.
All the more frustrating because my laptop - nearly identical in most regards - was fine. Finally found that if I logged in as a different user, Office worked OK (in fact, some users have moved all their files to a new account once they find this "solution" - painful).
So you would think it was a file in my home directory. Wrong! The culprit was Apple's system level font cache, which caches fonts by user. Deleting /Library/Caches/com.apple.ATS/(uid)/, where (uid) is my user id (just check with get info if you don't know your id - yours is the one you own) solved the problem.
I suspect this will also rid me of some other mysterious crashes. Turns out FontFinagler will attack this cache (Cocktail will not, by default, as I tried that too).



http://homepage.mac....6/fontfinagler/

Edited by Helen Brown, 02 August 2007 - 05:50 AM.
removed quote





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users