Jump to content


Photo

User Notes Bug in 9


  • Please log in to reply
12 replies to this topic

#1 Steve Lo Vullo

Steve Lo Vullo

    Silver

  • Active Members
  • PipPipPip
  • 188 posts
  • Gender:Male
  • Location:Madison, WI
  • Accordance Version:9.x

Posted 18 September 2010 - 06:02 PM

I've just run into a problem with User Notes in version 9. I have GNT-T open with a User Notes file open in a parallel pane. If my cursor accidentally moves over an Old Testament Scripture link in the User Notes, a message immediately pops up saying, for example, "The book 'Ruth' cannot be found." This is understandable, since the search text is the GNT-T. But what happens next is that, without doing anything, the search criterion automatically switches to "Words," and the GNT-T is searched for every word, resulting in the whole text being highlighted red. Every time this happens I must click back on "Verses" and hit enter. This can get very annoying after awhile.
Steve Lo Vullo

#2 Sean R.

Sean R.

    Gold

  • Active Members
  • PipPipPipPip
  • 289 posts
  • Gender:Male
  • Location:Russellville, TN
  • Accordance Version:10.x

Posted 18 September 2010 - 07:36 PM

Here's a minor bug with the edit window:

When I open the edit window to continue editing a user tool, or user note, the text in the window is very rough looking as if text smoothing has been turned off in the preference pane. As soon as I scroll in the edit window, the text smooths. However, when I make text into a link or add a title marker, the selected text (or that line when adding title markers) loses its smoothing. Also, whenever I select text, it loses its smoothing.
Sean Reed

#3 Ken Han

Ken Han

    Platinum

  • Active Members
  • PipPipPipPipPip
  • 604 posts
  • Gender:Male
  • Location:San Diego, CA
  • Accordance Version:10.x

Posted 18 September 2010 - 08:31 PM

Something else:

When I Command-U from inside a biblical text, e.g. ESV Prov 1:3, then user note edit window pops up, text looks great, and editing goes smoothly. But when I Command-U from inside the user note window, then the editing window which opens has strange behavior, unable to display some characters, the cursor is misplaced, and etc. Does anyone else experience this?

#4 Joel Brown

Joel Brown

    Administrator

  • Admin
  • 2,812 posts
  • Gender:Male
  • Location:Houston, TX
  • Accordance Version:10.x

Posted 19 September 2010 - 05:40 PM

I can reproduce Steve Lo Vullo's error.

However, both Sean and ken: I cannot reproduce this error. We've seen other instances of a lack of anti-aliasing, but regardless of how I try to edit my user notes, I cannot get it to occur. Perhaps more detailed instructions are necessary? Or perhaps you can just send me your user notes file (joel@accordancebible.com) to see if it is file-specific.
Joel Brown

By day: Consultant for Oaktree
By night: Freelance Trombonist and Private Instructor

#5 Sean R.

Sean R.

    Gold

  • Active Members
  • PipPipPipPip
  • 289 posts
  • Gender:Male
  • Location:Russellville, TN
  • Accordance Version:10.x

Posted 20 September 2010 - 12:31 PM

I can reproduce Steve Lo Vullo's error.

However, both Sean and ken: I cannot reproduce this error. We've seen other instances of a lack of anti-aliasing, but regardless of how I try to edit my user notes, I cannot get it to occur. Perhaps more detailed instructions are necessary? Or perhaps you can just send me your user notes file (joel@accordancebible.com) to see if it is file-specific.


Here is what is happening: When I select text in an edit window (either for user notes or user tools) using shift and the arrow keys, the text changes into the choppy looking, non-smoothed type of text displayed in TextEdit when the file is plain text. If I select the text in the edit window using the shift key and the mouse, the text stays smooth. Does this help?
Sean Reed

#6 Sean R.

Sean R.

    Gold

  • Active Members
  • PipPipPipPip
  • 289 posts
  • Gender:Male
  • Location:Russellville, TN
  • Accordance Version:10.x

Posted 20 September 2010 - 12:34 PM

The same thing happens when I'm selecting a search argument in the search entry box when the text is either a Hebrew or Greek text set to word search; both the Greek or Hebrew text and the English font search commands lose the smoothing if I select it using the shift key plus the arrow keys. If I select it with the shift key plus the mouse, it doesn't change. This does not happen, however, in the search box when I have an English translation open.
Sean Reed

#7 Joel Brown

Joel Brown

    Administrator

  • Admin
  • 2,812 posts
  • Gender:Male
  • Location:Houston, TX
  • Accordance Version:10.x

Posted 20 September 2010 - 12:56 PM

Excellent, thanks! I can reproduce this, and we'll fix it.
Joel Brown

By day: Consultant for Oaktree
By night: Freelance Trombonist and Private Instructor

#8 Sean R.

Sean R.

    Gold

  • Active Members
  • PipPipPipPip
  • 289 posts
  • Gender:Male
  • Location:Russellville, TN
  • Accordance Version:10.x

Posted 20 September 2010 - 02:05 PM

Excellent, thanks! I can reproduce this, and we'll fix it.


Joel,

I just installed Accordance 9.0.1 and this problem has changed somewhat. Now, when I highlight the text using the shift key plus the arrow keys, the text maintains its smoothness until I deselect it; it then becomes jagged. This occurs in both the search entry box and the edit window.
Sean Reed

#9 Joel Brown

Joel Brown

    Administrator

  • Admin
  • 2,812 posts
  • Gender:Male
  • Location:Houston, TX
  • Accordance Version:10.x

Posted 20 September 2010 - 02:30 PM

How are you deselecting? Via the arrow keys again?
Joel Brown

By day: Consultant for Oaktree
By night: Freelance Trombonist and Private Instructor

#10 Sean R.

Sean R.

    Gold

  • Active Members
  • PipPipPipPip
  • 289 posts
  • Gender:Male
  • Location:Russellville, TN
  • Accordance Version:10.x

Posted 20 September 2010 - 03:33 PM

How are you deselecting? Via the arrow keys again?


Yes, by the arrow keys. When I deselect by clicking, the text is unaffected.
Sean Reed

#11 Joel Brown

Joel Brown

    Administrator

  • Admin
  • 2,812 posts
  • Gender:Male
  • Location:Houston, TX
  • Accordance Version:10.x

Posted 20 September 2010 - 03:34 PM

Thanks for the reports. This should be fixed in the next release.
Joel Brown

By day: Consultant for Oaktree
By night: Freelance Trombonist and Private Instructor

#12 Sean R.

Sean R.

    Gold

  • Active Members
  • PipPipPipPip
  • 289 posts
  • Gender:Male
  • Location:Russellville, TN
  • Accordance Version:10.x

Posted 20 September 2010 - 03:46 PM

By the way, I just noticed this same issue showing up in the edit window a different way. When I begin typing in a User Tool, the edit window automatically opens to allow an edit of that tool. When I do this currently, the edit window opens with most of the text being jagged.

Hope it helps.
Sean Reed

#13 Sean R.

Sean R.

    Gold

  • Active Members
  • PipPipPipPip
  • 289 posts
  • Gender:Male
  • Location:Russellville, TN
  • Accordance Version:10.x

Posted 22 October 2010 - 11:16 AM

This anti-aliasing bug seems to have been fixed… mostly. It still occurs, however, under certain circumstances in the edit window. When I use shift+arrow keys (or shift+option+arrow keys) to select text in the edit window, I don't experience any problems. If I use shift+command+arrow key to select an entire line of text, the anti-aliasing is lost.
Sean Reed




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users