Jump to content


Photo

Copying from BHS


  • Please log in to reply
12 replies to this topic

#1 ryangeer

ryangeer

    Silver

  • Active Members
  • PipPipPip
  • 115 posts
  • Gender:Male
  • Accordance Version:11.x

Posted 27 September 2010 - 06:57 PM

In A9, when I copy and paste from the BHS - there appear to be fixed carriage returns so that instead of

XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX

I get

XXXXXXXXXXXXXXX
XXXXXXXXXXXXXXXX
XXXXXXXXXXXXXXXX
XXXXXXXXXXXXXXXX
XXXXXXX

Anyone else?

Edited by ryangeer, 27 September 2010 - 06:57 PM.


#2 R. Mansfield

R. Mansfield

    Platinum

  • Accordance
  • 1,200 posts
  • Gender:Male
  • Location:Kentucky
  • Accordance Version:11.x

Posted 27 September 2010 - 07:38 PM

I just pasted into Mellel and that didn't happen. What program are you pasting into?

Rick Mansfield

Technology Evangelist

Accordance Bible Software

 

 

Gear for running Accordance:

OS X

2012 15" MacBook Pro (retina) - 2.7 Ghz Core i7, 16 GB RAM, 750 GB SSD, Yosemite

Windows

2014 15.6" Acer R7-572 - 1.6 Ghz Core i5, 8 GB RAM, 256 GB mSATA, 1 TB HDD, Windows 8.1

2013 8" Dell Venue 8 Pro - 1.33 Ghz Atom, 2 GB RAM, 64 GB eMMC, Windows 8.1

iOS

2014 iPhone 6 Plus, 128 GB, Verizon

2013 iPad Air, 128 GB, Verizon

 


#3 jpkang

jpkang

    Platinum

  • Active Members
  • PipPipPipPipPip
  • 577 posts
  • Gender:Male
  • Location:Seattle, WA
  • Interests:Comparative Semitics; ancient Hebrew semantics; Hebrew syntax; history and religion of ancient Israel; history of interpretation.
  • Accordance Version:10.x

Posted 27 September 2010 - 08:14 PM

Just to verify: do you have Unicode export checked in the preferences?
J. P. Kang, Ph.D. (Bible)

#4 ryangeer

ryangeer

    Silver

  • Active Members
  • PipPipPip
  • 115 posts
  • Gender:Male
  • Accordance Version:11.x

Posted 27 September 2010 - 09:45 PM

Just to verify: do you have Unicode export checked in the preferences?


I don't have unicode checked - I never did before either. If I do check that box - it really bollixes the font...

I'm pasting into Pages and never had this problem before. By the way - I own Mellel as well and it does the same thing as Pages.

Attached Files


Edited by ryangeer, 27 September 2010 - 09:50 PM.


#5 Dick Roberts

Dick Roberts

    Bronze

  • Active Members
  • PipPip
  • 65 posts
  • Gender:Male
  • Location:Vida, Oregon
  • Accordance Version:10.x

Posted 27 September 2010 - 10:39 PM

I too am having the same issue with pasting BHS into both Pages and Mellel
Dick Roberts

#6 Mark Allison

Mark Allison

    Gold

  • Accordance
  • 217 posts
  • Gender:Male
  • Location:Flowery Branch, GA
  • Accordance Version:4.x

Posted 28 September 2010 - 05:25 AM

I think J.P. has hit the nail on the head. I can duplicate this behavior when exporting as Yehudit. Normal behavior returns when exporting as unicode. This happens in Word and Mellel.

#7 ryangeer

ryangeer

    Silver

  • Active Members
  • PipPipPip
  • 115 posts
  • Gender:Male
  • Accordance Version:11.x

Posted 28 September 2010 - 07:17 AM

I think J.P. has hit the nail on the head. I can duplicate this behavior when exporting as Yehudit. Normal behavior returns when exporting as unicode. This happens in Word and Mellel.

I too was able to duplicate that behavior... However, the point I am making is that it did not behave this way prior to v.9. Exporting as unicode is unnacceptable for at least two reasons (1) the font is hideous (imo) and (2) the references are in the wrong place...

Edited by ryangeer, 28 September 2010 - 07:29 AM.


#8 Dick Roberts

Dick Roberts

    Bronze

  • Active Members
  • PipPip
  • 65 posts
  • Gender:Male
  • Location:Vida, Oregon
  • Accordance Version:10.x

Posted 28 September 2010 - 08:59 AM

I have unicode checked and the bhs copy is still not pasting correctly into either Mellel or Pages
Dick Roberts

#9 Robert Holmstedt

Robert Holmstedt

    Platinum

  • Accordance
  • 537 posts
  • Gender:Male
  • Accordance Version:10.x

Posted 28 September 2010 - 09:21 AM

I too was able to duplicate that behavior... However, the point I am making is that it did not behave this way prior to v.9. Exporting as unicode is unnacceptable for at least two reasons (1) the font is hideous (imo) and (2) the references are in the wrong place...


FYI -- when pasting unicode from Accordance it's important to remember to change the text direction in Mellel (or NeoOffice, or whatever) to Right-to-Left. Then the verse references are right where they're supposed to be -- at the right-edge beginning of the line.
Also, while unicode Hebrew fonts look very nice in Mellel, the only (biblical) font that looks decent and deals with vowels well in NeoOffice is New Peninim MT. (I've not worked with Pages at all.)
Associate Professor, Ancient Hebrew and Northwest Semitic Languages
Dept. of Near and Middle Eastern Civilizations
The University of Toronto
blog: ancienthebrewgrammar.wordpress.com

#10 ryangeer

ryangeer

    Silver

  • Active Members
  • PipPipPip
  • 115 posts
  • Gender:Male
  • Accordance Version:11.x

Posted 28 September 2010 - 09:44 AM

FYI -- when pasting unicode from Accordance it's important to remember to change the text direction in Mellel (or NeoOffice, or whatever) to Right-to-Left. Then the verse references are right where they're supposed to be -- at the right-edge beginning of the line.
Also, while unicode Hebrew fonts look very nice in Mellel, the only (biblical) font that looks decent and deals with vowels well in NeoOffice is New Peninim MT. (I've not worked with Pages at all.)


Actually when I paste unicode the references appear at the left margin, while with unicode unchecked they remain properly in place at the right edge... Regardless - none of this discussion addresses my issue. Why is A9 behaving this way and is there anything that can be done to correct?

#11 Helen Brown

Helen Brown

    Mithril

  • Admin
  • 8,506 posts
  • Twitter:accordancebible
  • Gender:Female
  • Location:heart in Israel
  • Accordance Version:11.x
  • Platforms:Mac OS X, Windows, iOS

Posted 28 September 2010 - 10:04 AM

We will look into it just as soon as we can get more urgent bugs out of the way.
Helen Brown
OakTree Software

#12 Robert Holmstedt

Robert Holmstedt

    Platinum

  • Accordance
  • 537 posts
  • Gender:Male
  • Accordance Version:10.x

Posted 28 September 2010 - 12:04 PM

Actually when I paste unicode the references appear at the left margin, while with unicode unchecked they remain properly in place at the right edge... Regardless - none of this discussion addresses my issue. Why is A9 behaving this way and is there anything that can be done to correct?


W.r.t. to the unicode, you're missing my point. If you paste Hebrew unicode, you *must* change the text direction of the pasted material within your word processor.

In the first screenshot below, the unicode is pasted in Mellel without changing the text direction (the > symbol in the tool bar, to the immediate right of the full justify button).
In the second screenshot, the text direction is changed to <, which is correct for Semitic R-L languages and you can see the references are right where they belong.

Attached File  Screen shot 2010-09-28 at 12.02.02 PM.png   83.6KB   22 downloads
Attached File  Screen shot 2010-09-28 at 12.02.09 PM.png   83.15KB   23 downloads
Associate Professor, Ancient Hebrew and Northwest Semitic Languages
Dept. of Near and Middle Eastern Civilizations
The University of Toronto
blog: ancienthebrewgrammar.wordpress.com

#13 ryangeer

ryangeer

    Silver

  • Active Members
  • PipPipPip
  • 115 posts
  • Gender:Male
  • Accordance Version:11.x

Posted 28 September 2010 - 09:00 PM

We will look into it just as soon as we can get more urgent bugs out of the way.


Thanks, Helen - I realize this isn't a pressing issue. However, it is going to be a bit of a pain as I do my weekly teaching and sermon prep...




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users