Jump to content


Photo

Copy/Pasting Hebrew Font in Microsoft Word


  • Please log in to reply
10 replies to this topic

#1 Alex H

Alex H

    Member

  • Members
  • Pip
  • 2 posts
  • Accordance Version:8.x

Posted 19 October 2010 - 01:48 PM

Hi,

Before I updated the Accordance software to 9.0.4, I was able to copy and paste the Hebrew font (Yehudit) onto Microsoft Word (Mac 2008) with relative ease.

Now the fonts are coming off weird, having barely any semblance to the actual Hebrew text.

Currently, I'm highlighting the text, clicking "Print", then going to "Print Preview" and copying the text from that page to Microsoft Word.

I was wondering if there is a solution so that I can go back to copying and pasting Yehudit directly to Microsoft Word (Mac 2008) without the Hebrew text being misaligned and different? Thank you!

#2 Ron Webber

Ron Webber

    Bronze

  • Active Members
  • PipPip
  • 88 posts
  • Gender:Male
  • Location:Independence, Missouri
  • Accordance Version:10.x

Posted 19 October 2010 - 02:41 PM

Are your preference settings for copying the font set correctly? Choose Preferences... and the Greek & Hebrew settings. Then make certain that you have NOT checked the box to Export All Characters in Unicode Format. Then make sure that the Hebrew Format settings are set to export the Yehudit font.

Best regards,

Ron

#3 calebernst

calebernst

    Member

  • Members
  • Pip
  • 2 posts
  • Gender:Male
  • Accordance Version:9.x

Posted 19 October 2010 - 02:52 PM

I am having the exact same problem as Alex. I had 9.0.4 and I could copy and paste in microsoft word no problem. I just made the update to 9.0.5 and yehudit will not copy over into word. I also have Office 2008 for mac. I've made sure that the preferences in Accordance are correct (they're the same as before), but this still did not help.

#4 R. Mansfield

R. Mansfield

    Platinum

  • Active Members
  • PipPipPipPipPip
  • 1,029 posts
  • Gender:Male
  • Location:Kentucky
  • Accordance Version:10.x

Posted 19 October 2010 - 03:46 PM

I'm not having this error. Yehudit Hebrew is pasting from Accordance 9.05 to Word 2008 just fine for me.

Is this something that running Font Fixer might help?
___
Rick Mansfield

RMansfield@mac.com
http://thislamp.com
twitter.com/thislamp
facebook.com/rmansfield

#5 Alex H

Alex H

    Member

  • Members
  • Pip
  • 2 posts
  • Accordance Version:8.x

Posted 19 October 2010 - 04:01 PM

@ Ron- It works. Thank you so much for your help! I can now write my Hebrew paper in peace. :D

#6 calebernst

calebernst

    Member

  • Members
  • Pip
  • 2 posts
  • Gender:Male
  • Accordance Version:9.x

Posted 19 October 2010 - 04:38 PM

Got it working. Solved with a simple restart (slaps head with hand).

#7 Ron Webber

Ron Webber

    Bronze

  • Active Members
  • PipPip
  • 88 posts
  • Gender:Male
  • Location:Independence, Missouri
  • Accordance Version:10.x

Posted 19 October 2010 - 05:18 PM

Glad things are working well for you now. Really, the best option for working with Hebrew and Greek is to choose the preference to Export to Unicode. However current versions of MS WORD (or even the new release of MS WORD 2011) do not support right-to-left languages. If you use Mellel as your word processor, the typographic spacing is superior and incorporation of right-to-left languages like Hebrew is unexcelled.

Best regards,

Ron

#8 Lawson Stone

Lawson Stone

    Member

  • Active Members
  • Pip
  • 32 posts
  • Gender:Male
  • Location:Asbury Theological Seminary
  • Interests:Old Testament and everything related to it; drystone masonry, classic firearms, jazz guitar, old west history and lore, straight razor shaving and collecting, great tea
  • Accordance Version:9.x

Posted 01 November 2010 - 05:34 PM

I can't paste Hebrew into Word or Pages in non-unicode, non-RTL format. Several lines will be fine, and suddenly a section of a line will be in reverse order, then it will switch back. It's really disconcerting when I'm trying to set up text with indenting from the left margin to illustrate the clause syntax.

Geeze that sounded so geeky, but then, that's what we do, isn't it!
***************************************************************************
"Behavior that's admired is the path to power among people everywhere."
--Anonymous Poet of "Beowulf"
***************************************************************************
Lawson G. Stone, Professor of Old Testament
Asbury Theological Seminary
Stonesfence-my website

#9 Battlesman

Battlesman

    Member

  • Active Members
  • Pip
  • 47 posts
  • Gender:Male
  • Location:Carlisle, PA
  • Accordance Version:10.x

Posted 10 October 2013 - 01:49 PM

I'm still having problems with this reverse pasting in Microsoft Word (2011), despite using the unicode option in Accordance 10.3.1. What am I doing wrong? 


Dustin Battles

BA, MA, MDiv


#10 Ken Simpson

Ken Simpson

    Platinum

  • Accordance
  • 1,308 posts
  • Gender:Male
  • Location:Sydney, Australia
  • Interests:Astronomy
    Archaeology
    Physics
    Hebrew and Greek
    Papyrology
    Surgeon
  • Accordance Version:10.x

Posted 10 October 2013 - 04:14 PM

HI Dustin,

you're not doing anything wrong. It's a limitation of Word on Mac. It chokes on rtl text.

 

If you are serious about doing rtl work you really need Mellel (my personal favourite) or Nisus Writer Pro. Bot of which hnad RTL perfectly. Word on Windows supports RTL, but not Word on Mac. (Who knows what Office 2014 Mac will bring...)

 

Honestly, get Mellel (and it's very cheap). It's a bit different to Word, so there's a learning curve but it is far superior for language work (and it exports in Word, PDF and RTF formats).


Edited by Ken Simpson, 10 October 2013 - 04:14 PM.

Regards
Ken
Australian Accordance Demonstrator

Administrator, Accordance Exchange

Assistant Minister, Summer Hill Church


#11 Willem

Willem

    Member

  • Members
  • Pip
  • 1 posts
  • Accordance Version:10.x

Posted 18 November 2013 - 12:58 AM

I rarely use Word, in part because I find it distracting and there are better options available. But sometimes I have to use it.

So I installed Windows 7 on Parallels, which runs, and installed Office for 2010 Windows on Parallels. So far so good. Enabled Hebrew on Windows.

 

Copy & paste worked once, to my annoyance not again, because the paste options are not displayed in Office 2010. I can only copy plain text without formatting. This appears to be a bug under Windows. The common advice is to disable "click skype for call" to retrieve the lost paste options. However, I do not have Skype installed, so this advice does not work for me. Anyone else with an idea?






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users