Jump to content


Photo

Font issue when pasting into Word


  • Please log in to reply
13 replies to this topic

#1 hesed

hesed

    Member

  • Members
  • Pip
  • 7 posts

Posted 16 May 2005 - 12:46 PM

When I copy a Greek NT passage from Accordance into Word (2004), all the rough breathing marks (I think, it could be smooth) display as Apple symbols. Is there are way to fix this? I can't find the Accordance fonts in my font list either (although I haven't looked that hard).

#2 Helen Brown

Helen Brown

    Mithril

  • Admin
  • 8,427 posts
  • Gender:Female
  • Location:heart in Israel
  • Accordance Version:11.x

Posted 16 May 2005 - 01:32 PM

When I copy a Greek NT passage from Accordance into Word (2004), all the rough breathing marks (I think, it could be smooth) display as Apple symbols.  Is there are way to fix this?

<{POST_SNAPBACK}>

This is because Quartz substitutes certain characters in both Helena and Yehudit. The export to Unicode is the best way to get around this.

Please see our Unicode page for details about using Unicode export.

I can't find the Accordance fonts in my font list either (although I haven't looked that hard).

<{POST_SNAPBACK}>

Hmmm. Are the Accordance fonts in your Hard Drive>Library>Fonts folder? Are they visible to other programs like FontBook, TextEdit?
Helen Brown
OakTree Software

#3 hesed

hesed

    Member

  • Members
  • Pip
  • 7 posts

Posted 16 May 2005 - 08:07 PM

Thanks for your response, Helen. I'll take a look at the Unicode page.

The Accordance fonts are in the Hard Drive>Library>Fonts folder, but if I double click the font it doesn't show up in Font Book.

#4 Helen Brown

Helen Brown

    Mithril

  • Admin
  • 8,427 posts
  • Gender:Female
  • Location:heart in Israel
  • Accordance Version:11.x

Posted 16 May 2005 - 08:41 PM

Then follow the tips in Tiger Tales and replace that one file with the individual fonts.

Edited by Helen Brown, 14 July 2005 - 07:50 AM.

Helen Brown
OakTree Software

#5 hesed

hesed

    Member

  • Members
  • Pip
  • 7 posts

Posted 18 May 2005 - 12:53 PM

I'm not sure what Tiger Tales is, but the link doesn't seem to be addressing this same issue. I'm not sure if Tiger is refering here to OS X 10.4, but I'm running 10.3...

#6 Helen Brown

Helen Brown

    Mithril

  • Admin
  • 8,427 posts
  • Gender:Female
  • Location:heart in Israel
  • Accordance Version:11.x

Posted 18 May 2005 - 06:41 PM

You have not told me whether the fonts are available to other programs like Text Edit, nor where they are on your hard drive.

I think you need to call the tech support line: 407-339-0266 during office hours EST, so that we can help you personally.
Helen Brown
OakTree Software

#7 preterist1

preterist1

    Member

  • Active Members
  • Pip
  • 27 posts
  • Gender:Male
  • Location:Bradford, Pennsylvania USA
  • Interests:Preterist Theology and Eschatology, Josephus, Yosippon, Enoch, Judaica, and Apostolic Fathers (esp. Barnabas)
  • Accordance Version:10.x

Posted 23 May 2005 - 10:35 AM

I had noticed the same problem with my Microsoft Word copy/pastes. Thanks for clearing this up for me. I'm glad to know that I'm not the only one who had this problem.
Edward E. Stevens, President
International Preterist Association
www.preterist.org

#8 Jaap van Rootselaar

Jaap van Rootselaar

    Member

  • Members
  • Pip
  • 2 posts

Posted 07 June 2005 - 03:23 PM

"÷ the Accordance fonts in your Hard Drive>Library>Fonts folder? Are they visible to other programs like÷ TextEdit÷" (Yes, but only in TextEdit they are, Jaap)

Dear Helen,

After installing Tiger there is a problem:
When I launch my eMac, or after a restart, my fonts Helena and Yehudit seem to be disabled.
In Accordance and AppleWorks I can't use or find them (in Appleworks I see Yehudit Bold, but it doesn't work).
In Fontbook they disapeared too, but after double clicking the both fonts in their folder they came back, and after restarting Accordance all things worked fine!
Helas, after a new restart of my eMac, again no Hebrew and Greek fonts in Accordance.
What can I do to solve this strange problem?

Greetings,
Jaap van Rootselaar

#9 Helen Brown

Helen Brown

    Mithril

  • Admin
  • 8,427 posts
  • Gender:Female
  • Location:heart in Israel
  • Accordance Version:11.x

Posted 07 June 2005 - 03:28 PM

I talked to another user today, with the same problem. Please download and run the 6.5 installer again, and see if that helps. Also, try searching your hard drive for the file "Accordance fonts" and deleting it everywhere.

I do not have a final answer yet, sorry!
Helen Brown
OakTree Software

#10 Jaap van Rootselaar

Jaap van Rootselaar

    Member

  • Members
  • Pip
  • 2 posts

Posted 08 June 2005 - 03:29 PM

But it works!
That's great!
Many thanks! :D

#11 Steve Walton

Steve Walton

    Member

  • Members
  • Pip
  • 9 posts
  • Gender:Male
  • Location:Tyndale House, Cambridge
  • Interests:Aside from NT Studies, which I teach, research and write about, volleyball.
  • Accordance Version:10.x

Posted 05 July 2005 - 10:45 AM

I've just gone over to Accordance 6.6 and Tiger, and am appreciating the Quartz fonts very much. However, with my old computer (using OS 9.1 on a PowerBook G3) I had shortcuts (in the late, lamented KeyQuencer) to copy and paste from Accordance 5.x to Word 98, putting the Greek into SuperGreek format (which is the same keyboard map as Graeca II, the font I need to use for a book I'm working on). I'm trying to set the same up in Tiger with Accordance 6.6 and Word 2004, but now using QuicKeys 3.1.

In Tiger, using Accordance 6.6 and Word 2004, I can find no way to get the text copied from Accordance to paste into Word as SuperGreek/Graeca II Greek text - it simply pastes as whichever English font I'm using (usually Palatino). Copying from Accordance 6.6 and pasting into Word 2004 with Helena works fine - any ideas on how I can get the Greek to paste as Graeca II?

#12 Helen Brown

Helen Brown

    Mithril

  • Admin
  • 8,427 posts
  • Gender:Female
  • Location:heart in Israel
  • Accordance Version:11.x

Posted 05 July 2005 - 04:48 PM

Steve:

Hi from Down Under! Not sure I understand the problem. You are exporting as SuperGreek but it pastes as English? If you convert it to Graeca is it then correct? Does it work in TextEdit? That will isolate whether this is a 6.6/Quartz problem or a Word problem.

Apparently I only have SuperGreek and Hebrew here with me, and I do not have a TrueType font at all, only bitmaps and PostScript. For me the conversion works for SimpleText and AppleWorks, but SuperGreek is not available to TextEdit which uses Quartz and requires TrueType fonts. Maybe all you need to do is make sure the Truetype fonts are in you Library>Fonts folder and recognized by Font Book.
Helen Brown
OakTree Software

#13 Steve Walton

Steve Walton

    Member

  • Members
  • Pip
  • 9 posts
  • Gender:Male
  • Location:Tyndale House, Cambridge
  • Interests:Aside from NT Studies, which I teach, research and write about, volleyball.
  • Accordance Version:10.x

Posted 06 July 2005 - 03:28 AM

Helen,

HI: I hope the trip to Australia is going well. Let me try to explain further.

Hi from Down Under! Not sure I understand the problem. You are exporting as SuperGreek but it pastes as English? If you convert it to Graeca is it then correct? Does it work in TextEdit? That will isolate whether this is a 6.6/Quartz problem or a Word problem.

I have the export Greek text setting set to SuperGreek, which has the same keyboard map as Graeca II - and Graeca II is the font that my publisher requires me to use for a book I'm working on.

Apparently I only have SuperGreek and Hebrew here with me, and I do not have a TrueType font at all, only bitmaps and PostScript. For me the conversion works for SimpleText and AppleWorks, but SuperGreek is not available to TextEdit which uses Quartz and requires TrueType fonts. Maybe all you need to do is make sure the Truetype fonts are in you Library>Fonts folder and recognized by Font Book.


It's not working with TextEdit. However, I've just now tried the operation with AppleWorks 6.2.9 and it copies the Greek text into Alexandria, another Greek font with the same keyboard map as SuperGreek. It's then easy to do a find and replace to change Alexandria into Graeca II. This was my experience when working with Word 98 previously under OS 9.1. But I cannot make Alexandria available to Word 2004, however - FontBook won't even recognise that it exists (I suspect it is quite an old font and likely a bitmap). And having removed Alexandria from any font folders, AppleWorks then pastes the Greek text in using Helena (which means it looks wrong, since I've exported the text in SuperGreek format).

Sorry this is complicated - it's all arisen from upgrading to a new computer (PowerBook G4) and thus upgrading to Word 2004. I suspect this might well be a Word issue, but if you have any wisdom to offer, I'll be pleased to have it, since I have to use Graeca II for my publisher...

Warm regards,

Steve

#14 Joe Weaks

Joe Weaks

    Platinum

  • Active Members
  • PipPipPipPipPip
  • 1,077 posts
  • Gender:Male
  • Location:Odessa, TX
  • Interests:I like things that are Orange, and possibly Blue.
  • Accordance Version:11.x

Posted 06 July 2005 - 12:18 PM

I have had several email exchanges with Steve, and here's what I think is happening.

Accordance is placing text onto the clipboard with the font "SuperGreek".
Steve doesn't have SuperGreek loaded on his computer (who DOES still have it and why and why does Accordance still assign that abandoned font?).
The application is assigning another font, but why in Word it is not assigning a close relative like Helena (which is what happens on my machine) I don't know.
The solution to this scenario really is not very good.

The only real solution is for Accordance to expand it's list of font exports (many are very similar to SuperGreek, such as Graeca II and TekniaGreek). One can't simply have a macro change the contents of the clipboard to the Greek font you want, because then references would be in the wrong font.
Joe Weaks
The Macintosh Biblioblog

Sometimes I'm so helpful even I can't stand it.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users