Jump to content


Photo

Incomplete reference links aren't being handled


  • Please log in to reply
2 replies to this topic

#1 Ed Heckman

Ed Heckman

    Bronze

  • Active Members
  • PipPip
  • 93 posts
  • Gender:Male
  • Location:Lancaster, PA
  • Accordance Version:10.x

Posted 10 May 2011 - 07:37 PM

I've discovered that Accordance for iOS isn't handling incomplete verse reference links.

For example, one of the dictionaries I was reading included these verse references:

(Acts 13:2; 20:23)*

If I tap and hold on the first reference, the instant details window opens as it should. However, tapping and holding on the second reference doesn't do anything.

(*FYI, when I tried copying the reference text from Accordance 9.3.2 it would not work. Nothing would paste into my web browser for this message. I had to type the text manually.)
Ed "What the" Heckman

#2 Scott Knapp

Scott Knapp

    Platinum

  • Accordance
  • 1,042 posts
  • Gender:Male
  • Location:Orlando, FL
  • Accordance Version:10.x

Posted 10 May 2011 - 08:58 PM

I've discovered that Accordance for iOS isn't handling incomplete verse reference links.

For example, one of the dictionaries I was reading included these verse references:

(Acts 13:2; 20:23)*

If I tap and hold on the first reference, the instant details window opens as it should. However, tapping and holding on the second reference doesn't do anything.

(*FYI, when I tried copying the reference text from Accordance 9.3.2 it would not work. Nothing would paste into my web browser for this message. I had to type the text manually.)

They should be working correctly. For instance, in Easton, the article on Aaron has several partial scripture links that all work. So I think you're seeing one of two things: either a bug in that specific link or your font size is small enough that the app is having difficulty determining that the link has been pressed. Note that for tools you do not need to perform a long press on a link. Just a simple tap will do. At small font sizes we sometimes have a problem mapping a finger touch to a specific location.

Do the same links still not work if you increase the font size and leading for the tool display?

Scott

#3 Ed Heckman

Ed Heckman

    Bronze

  • Active Members
  • PipPip
  • 93 posts
  • Gender:Male
  • Location:Lancaster, PA
  • Accordance Version:10.x

Posted 10 May 2011 - 10:58 PM

It seems I was a bit confused. And now that I think about it, I think I'm still a bit confused.

First, simply tapping on the link in the dictionary worked more reliably, probably because a light tap makes for a smaller contact area. I didn't need to change the font size or leading to make it work. (I'm using Georgia 16 with just a little bit extra leading.)

But I guess what made me think I had to tap and hold is because that action is what's required to display the instant details window in a text. So that's a little confusing.

Bottom line, it's not a bug. I just need a lighter touch. B)
Ed "What the" Heckman




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users