Jump to content


Photo

Pasting Hebrew text into Google Docs


  • Please log in to reply
11 replies to this topic

#1 Ploni

Ploni

    Bronze

  • Active Members
  • PipPip
  • 57 posts
  • Gender:Not Telling
  • Accordance Version:9.x

Posted 25 May 2011 - 02:55 AM

I have a problem pasting Hebrew text into Google Docs from Accordance. I CAN paste the text correctly into a Google Document but then cannot type in a left to right direction unless I go onto a new line. This problem does not occur with Hebrew text pasted from other applications (e.g. web based Hebrew or Logos). It is peculiar to Accordance. I have tried changing the export options in Accordance to no avail. I do have Mellel and have used that in past but my preference is now to use Google Docs. As I have said, the problem is *not* with Google Docs as I can paste Hebrew from other applications and can continue typing in a left to right direction. I would like to able to use Accordance for pasting Hebrew rather than having to switch to a different application.

#2 Mark Allison

Mark Allison

    Gold

  • Accordance
  • 217 posts
  • Gender:Male
  • Location:Flowery Branch, GA
  • Accordance Version:4.x

Posted 25 May 2011 - 08:25 AM

A hard return is being inserted after the inserted Hebrew text (at least when exporting as Unicode). If you backspace to delete the return, you can then place your cursor after the inserted Hebrew text and begin typing. Or, you can begin typing without deleting the return, then go back and delete it later. Not convenient, but it only requires a couple of extra steps.

Mark

#3 Ploni

Ploni

    Bronze

  • Active Members
  • PipPip
  • 57 posts
  • Gender:Not Telling
  • Accordance Version:9.x

Posted 25 May 2011 - 09:17 AM

In my case the problem is not a hard return for the cursor does not move to the next line and therefore there is nothing to delete. The cursor remains after the last Hebrew letter pasted. However when I try to then type in English, the English text appears to the left of the Hebrew rather than the right.


A hard return is being inserted after the inserted Hebrew text (at least when exporting as Unicode). If you backspace to delete the return, you can then place your cursor after the inserted Hebrew text and begin typing. Or, you can begin typing without deleting the return, then go back and delete it later. Not convenient, but it only requires a couple of extra steps.

Mark

Attached Files



#4 Ploni

Ploni

    Bronze

  • Active Members
  • PipPip
  • 57 posts
  • Gender:Not Telling
  • Accordance Version:9.x

Posted 26 May 2011 - 04:57 AM

I am thankful to Mark for giving me an option in Google Chrome where the behavior he describes is replicated. The situation is different for Firefox. While Mark's solution is very useful as a Google Docs user, I am open to any further suggestions which would obviate the need for multiple steps.

#5 Mark Allison

Mark Allison

    Gold

  • Accordance
  • 217 posts
  • Gender:Male
  • Location:Flowery Branch, GA
  • Accordance Version:4.x

Posted 26 May 2011 - 05:41 AM

Did you try hitting the tab key to bring the curser to the other side of the inserted text? It seemed to work for me in Safari, but I was wondering if it helped you in your situation.

Mark

#6 Ploni

Ploni

    Bronze

  • Active Members
  • PipPip
  • 57 posts
  • Gender:Not Telling
  • Accordance Version:9.x

Posted 26 May 2011 - 12:19 PM

I did try the second suggestion without success. While the cursor is placed in the correct position, hitting tab does not allow one to type correctly afterwards. Your first suggestion works well however and I am very glad to adopt it. Thank you! I am thrilled to be able to use Accordance with Google Docs.

Did you try hitting the tab key to bring the curser to the other side of the inserted text? It seemed to work for me in Safari, but I was wondering if it helped you in your situation.

Mark



#7 jpkang

jpkang

    Platinum

  • Active Members
  • PipPipPipPipPip
  • 577 posts
  • Gender:Male
  • Location:Seattle, WA
  • Interests:Comparative Semitics; ancient Hebrew semantics; Hebrew syntax; history and religion of ancient Israel; history of interpretation.
  • Accordance Version:10.x

Posted 26 May 2011 - 04:38 PM

I suspect the source of the problem is the RTL and LTR markers which Accordance exports before and after Hebrew/Aramaic/Arabic/Syriac text (and which become visible depending on which Hebrew font you use). If they were omitted/stripped, I don't think most modern Unicode-compliant editors would notice.
J. P. Kang, Ph.D. (Bible)

#8 Ploni

Ploni

    Bronze

  • Active Members
  • PipPip
  • 57 posts
  • Gender:Not Telling
  • Accordance Version:9.x

Posted 30 May 2011 - 12:56 AM

How would one go about striping these?

I suspect the source of the problem is the RTL and LTR markers which Accordance exports before and after Hebrew/Aramaic/Arabic/Syriac text (and which become visible depending on which Hebrew font you use). If they were omitted/stripped, I don't think most modern Unicode-compliant editors would notice.



#9 Helen Brown

Helen Brown

    Mithril

  • Admin
  • 8,499 posts
  • Gender:Female
  • Location:heart in Israel
  • Accordance Version:11.x

Posted 30 May 2011 - 04:45 AM

This is not currently an option in Accordance. We understood that they were helpful in mixed Unicode text, but we will look into removing them.
Helen Brown
OakTree Software

#10 SGBCjax

SGBCjax

    Member

  • Members
  • Pip
  • 5 posts
  • Gender:Male
  • Accordance Version:10.x

Posted 21 December 2011 - 04:59 PM

I am still unable to paste either Hebrew or Greek into Google docs. I use Chrome but tried it in Firefox as well. I am unable to paste for either. Any suggestions? Is this something I need to live with or is there a way around this?

#11 Joel Brown

Joel Brown

    Administrator

  • Admin
  • 3,048 posts
  • Gender:Male
  • Location:Houston, TX
  • Accordance Version:11.x
  • Platforms:Mac OS X, Windows

Posted 21 December 2011 - 06:33 PM

What is your 'Export all characters with Unicode format' setting at in your Preferences -> Greek & Hebrew?
Joel Brown

By day: Consultant for Oaktree
By night: Freelance Trombonist and Private Instructor

#12 SGBCjax

SGBCjax

    Member

  • Members
  • Pip
  • 5 posts
  • Gender:Male
  • Accordance Version:10.x

Posted 22 December 2011 - 10:29 AM

I DID NOT have any of these clicked. I have them on now & am able to paste Hebrew & Greek into G-docs. Thanks!!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users