Jump to content


Photo

Newbie help with grammatical tags and @ sign


  • Please log in to reply
9 replies to this topic

#1 Meg

Meg

    Member

  • Members
  • Pip
  • 6 posts
  • Accordance Version:9.x

Posted 01 August 2011 - 12:29 PM

I'm still learning how to do this, so I hope I'm posting in the right place. Doing a Hebrew search for ish + 3rd. fem. sing. suffix, "her man".

Under the Search menu I choose Enter Lexical Form and choose "ish"
Under the Search menu I choose Enter Tag --> Suffix, and chose 3rd person, fem, sing

Accordance automatically inserts the @ sign between the two elements.

I click the search button and get this message: ' There are no verses in the current range of the "BHS-W4 text, which fit the current search entry.'

I click OK, and after a lot of trial and error, I remove the @ and leave a SPACE between the 2 elements and the search finds what I am looking for -- 39 hits.

I've been reading the manuals and watching the videos until I am crosseyed and everything says I need the @ symbol here. What am I doing wrong? How do I know when to remove the @ sign?

Thanks,
Meg

#2 David Knoll

David Knoll

    Silver

  • Active Members
  • PipPipPip
  • 150 posts
  • Gender:Male
  • Accordance Version:10.x

Posted 01 August 2011 - 01:28 PM

I think that you don't need the @. The @ is used for attributes of the same element. Here you have two separate elements: The noun and the possesive pronoun.
I still wonder why Accordance adds the @ when you insert the suffix tag. Maybe someone else can clarify.

#3 Helen Brown

Helen Brown

    Mithril

  • Admin
  • 8,027 posts
  • Gender:Female
  • Location:heart in Israel
  • Accordance Version:10.x

Posted 01 August 2011 - 03:33 PM

Usually when people enter a word followed by a tag they do want them to apply to the same item, this is why Accordance adds the @. David is correct that you just need to delete it in the cases where you are effectively looking for a phrase.
Helen Brown
OakTree Software

#4 Joel Brown

Joel Brown

    Administrator

  • Admin
  • 2,512 posts
  • Gender:Male
  • Location:Houston, TX
  • Accordance Version:10.x

Posted 01 August 2011 - 03:42 PM

Alternatively, just type a space before choosing to enter the SUFFIX, to confirm that you want it as a phrase and not a requirement of your other word.
Joel Brown

By day: Consultant for Oaktree
By night: Freelance Trombonist and Private Instructor

#5 Meg

Meg

    Member

  • Members
  • Pip
  • 6 posts
  • Accordance Version:9.x

Posted 01 August 2011 - 04:41 PM

Thank you all -- very helpful!

#6 David Knoll

David Knoll

    Silver

  • Active Members
  • PipPipPip
  • 150 posts
  • Gender:Male
  • Accordance Version:10.x

Posted 01 August 2011 - 08:35 PM

Usually when people enter a word followed by a tag they do want them to apply to the same item, this is why Accordance adds the @.


Isn't it always false when it comes to the suffix? I mean if the suffix is tagged as a separate morpheme then how can the @ ever be relevant?

#7 Helen Brown

Helen Brown

    Mithril

  • Admin
  • 8,027 posts
  • Gender:Female
  • Location:heart in Israel
  • Accordance Version:10.x

Posted 01 August 2011 - 10:35 PM

It's not relevant to a suffix after a lemma or root, but it can be added after an inflected form, or a COUNT or HITS command. The @ can link any of these together to define a single word, even multiple terms (though these are often done more clearly in the Construct window).

Of course, Accordance could be programmed NOT to put the @ when adding [SUFFIX] after a lemma or root, but no-one has complained about it, and the developers have a very long honey-do list as it is.
Helen Brown
OakTree Software

#8 Martin Smith

Martin Smith

    Member

  • Active Members
  • Pip
  • 20 posts
  • Gender:Male
  • Location:Redondo Beach, CA
  • Accordance Version:10.x

Posted 08 May 2012 - 01:23 PM

Found this thread of last year helpful but also need to find nouns without pronominal suffixes. There is a NOT indicated at the bottom of the SUFFUX Tag dialog box. I thought that I would be able to select the NOT as a way to exclude any suffixes associated with the noun. But I find I cannot select this NOT. I suspect I'm missing something simple. Thanks for you help.

#9 Ken Simpson

Ken Simpson

    Platinum

  • Accordance
  • 1,330 posts
  • Gender:Male
  • Location:Sydney, Australia
  • Interests:Astronomy
    Archaeology
    Physics
    Hebrew and Greek
    Papyrology
    Surgeon
  • Accordance Version:10.x

Posted 08 May 2012 - 09:24 PM

I think you will find that the NOT becomes available when you select one of the options in the suffix dropdowns.

To get no pronom suffixes at all, I think you will have to shift click each one to select all the options, and then NOT the entire selection on that line.

A little tiresome, but it should work.

Can anyone else think of a better way of doing it?

Regards
Ken
Australian Accordance Demonstrator

Administrator, Accordance Exchange

Assistant Minister, Summer Hill Church


#10 Helen Brown

Helen Brown

    Mithril

  • Admin
  • 8,027 posts
  • Gender:Female
  • Location:heart in Israel
  • Accordance Version:10.x

Posted 08 May 2012 - 11:22 PM

To find nouns not followed by any suffix you would either use a string of commands and tags in the Search tab:
[NOUN] <NOT> <FOLLOWED BY> <WITHIN 1 > [SUFFIX}
which is fairly easy to construct using the drop down menus

or set it up in the Construct tab:

Attached File  Noun_not_suffix.png   14.2KB   7 downloads

which is way more elegant.

Longtime users need to remember that until 9 the Construct always assumed adjacent words, but it no longer does, so we do need to add the WITHIN connecting item.
Helen Brown
OakTree Software




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users