Jump to content


Photo

Highlighting bug in 1.4


  • Please log in to reply
9 replies to this topic

#1 Daniel Wee

Daniel Wee

    Member

  • Active Members
  • Pip
  • 39 posts
  • Accordance Version:9.x

Posted 25 December 2011 - 01:20 PM

I think I've discovered a bug with the highlighting feature in Accordance for IOS 1.4. The problem occurs when I have two bibles open in the two text panes and tracking one another. Now, when I highlight a verse in the first pane, the second pane goes blank.

In my case, the top pane was NRSV while the bottom pane was KJVA. I selected and highlighted a verse in the top pane that was also displayed in the bottom pane. That causes the problem to occur. I'm pretty sure this is not supposed to happen.

Can some confirm this bug or suggest a solution?

Daniel

#2 Daniel Wee

Daniel Wee

    Member

  • Active Members
  • Pip
  • 39 posts
  • Accordance Version:9.x

Posted 25 December 2011 - 01:52 PM

An associated problem is when you highlight a verse in the second pane instead, the text location jumps to some other position rather than remaining unchanged as it should have remained.

#3 Scott Knapp

Scott Knapp

    Platinum

  • Accordance
  • 1,142 posts
  • Gender:Male
  • Location:Orlando, FL
  • Accordance Version:10.x

Posted 26 December 2011 - 12:37 PM

Daniel:

I am unable to reproduce this issue using the two modules you listed. Was there a particular verse that you were trying to highlight in the main or parallel pane?

Scott.

#4 Daniel Wee

Daniel Wee

    Member

  • Active Members
  • Pip
  • 39 posts
  • Accordance Version:9.x

Posted 26 December 2011 - 09:28 PM

I was looking at 1Maccabees. I just tried this again with NRSV 1Macc 2:19 in the top pane and KJVA showing the same in the lower pane. I pressed and held to highlight the said verse in NRSV, then selected highlight and the yellow colour. The verse was highlighted but the lower pane went blank.

Daniel

#5 Scott Knapp

Scott Knapp

    Platinum

  • Accordance
  • 1,142 posts
  • Gender:Male
  • Location:Orlando, FL
  • Accordance Version:10.x

Posted 27 December 2011 - 02:03 PM

I was looking at 1Maccabees. I just tried this again with NRSV 1Macc 2:19 in the top pane and KJVA showing the same in the lower pane. I pressed and held to highlight the said verse in NRSV, then selected highlight and the yellow colour. The verse was highlighted but the lower pane went blank.

Daniel

I am still unable to reproduce the issue, even with your specific example. So I'm going to need some more information...

Which iOS device you have and what iOS version are you running?
What are your text display settings (verse or paragraph, font, font size, etc.)?
Does this happen in the reading mode (all verses shown) or only when you have a set of search results shown?
Are you using the default "My Mobile Highlights" file for your highlights or a set of highlights you synced over from an Accordance for Mac installation?

Scott.

#6 Daniel Wee

Daniel Wee

    Member

  • Active Members
  • Pip
  • 39 posts
  • Accordance Version:9.x

Posted 27 December 2011 - 07:26 PM

I am using an iPad2 running the latest IOS 5.0.1 (as far as iTunes will update). This is the 64GB 3G model.

My font size in "Display Settings" are all 16 (Georgia). Not sure if it matters, the background colour is "Parchment".

I have not messed with My Mobile Highlights so I would assume that it is the default. I did select sync highlights though but I cannot see that it has made any difference with either this or my Mac.

Daniel

#7 Rick Bennett

Rick Bennett

    Platinum

  • Accordance
  • 1,876 posts
  • Gender:Male
  • Location:Tampa Bay, FL
  • Interests: gadgets, coffee, running and cycling, Rays baseball
  • Accordance Version:10.x

Posted 28 December 2011 - 11:15 AM

I am able to reproduce and will coordinate with Scott on tracking down the issue.

Rick Bennett
Director of Content Development
iOS Working Group


#8 Scott Knapp

Scott Knapp

    Platinum

  • Accordance
  • 1,142 posts
  • Gender:Male
  • Location:Orlando, FL
  • Accordance Version:10.x

Posted 28 December 2011 - 03:59 PM

This issue has been fixed for the next release. A temporary workaround is to change the text display settings to "Separate Verses" or "Separate Verses With Space" since the issue only occurs if one of the paragraph modes is being used and the paragraph being interacted with is unusually long.

Scott.

#9 Daniel Wee

Daniel Wee

    Member

  • Active Members
  • Pip
  • 39 posts
  • Accordance Version:9.x

Posted 29 December 2011 - 05:04 AM

Thanks guys. Am I right that the second issue is related to the first one?

#10 Scott Knapp

Scott Knapp

    Platinum

  • Accordance
  • 1,142 posts
  • Gender:Male
  • Location:Orlando, FL
  • Accordance Version:10.x

Posted 29 December 2011 - 10:05 AM

Thanks guys. Am I right that the second issue is related to the first one?

Yes.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users