Jump to content


Photo

Shrunken text in search display window

Font display

  • Please log in to reply
14 replies to this topic

#1 Mark Nigro

Mark Nigro

    Gold

  • Active Members
  • PipPipPipPip
  • 217 posts
  • Gender:Male
  • Location:California
  • Interests:Theology, biblical and modern languages, motorcycles, classical guitar, technology
  • Accordance Version:10.x

Posted 23 January 2012 - 05:35 AM

After performing a search string with rule* <not> rulers my results displayed but there may be a bug causing the text to show in two sizes, one very small as you can see from the picture I have uploaded. I checked the verses in question by opening them in a separate window to verify that they show properly and indeed they do. I tried a second search with slightly different word choice (rule* <not> ruled) and got the same problem at the same verses in discussion. I am using 9.5.3.

Attached Files



#2 Ed Heckman

Ed Heckman

    Bronze

  • Active Members
  • PipPip
  • 93 posts
  • Gender:Male
  • Location:Lancaster, PA
  • Accordance Version:10.x

Posted 29 January 2012 - 06:12 PM

I'm seeing a similar bug. I have my default font for text display set to Times Roman 14 point. But as of version 9.5.3, it's displaying far smaller. I'm attaching a screen shot with the same text displayed in Accordance 9.5.3 and Pages, both with the same set text size and style.

Attached Files


Ed "What the" Heckman

#3 Helen Brown

Helen Brown

    Mithril

  • Admin
  • 8,267 posts
  • Gender:Female
  • Location:heart in Israel
  • Accordance Version:10.x

Posted 30 January 2012 - 12:24 AM

Ed: Please check the font size of your display. 9.5.3 added a couple of font sizes which changes all the saved settings.

Mark: I cannot reproduce your bug. If you can narrow it down for us, that would be helpful. Does it persist if you change different display settings? Is it only in the one version? I think the superscript marker in 1 Cor 7:17 is carrying over the superscript to the next mark in the next verse. Have you updated the text itself?
Helen Brown
OakTree Software

#4 Ed Heckman

Ed Heckman

    Bronze

  • Active Members
  • PipPip
  • 93 posts
  • Gender:Male
  • Location:Lancaster, PA
  • Accordance Version:10.x

Posted 30 January 2012 - 10:09 AM

The default text size setting in Preferences was still 14 points. (I've temporarily changed it to 16.) I experimented with changing it to different sizes and accepted the dialog asking if I wanted to change the open windows. The displayed font size did change, but it was still smaller than the actual selected size. Reselecting 14 point returned the text size to the one in my screen shot.

Hitting Command-T (Set Text Pane Display…) and experimenting with the sizes there produced the same results.

Additional observation: Under Preferences -> General -> Startup, I have "Default Session" selected in the popup. (Mostly for window placement and size.) Even though I have 16 point set in preferences, hitting Command-T shows that this window is still set to 14 point. If I close that workspace and open a new one, it uses the <i>new</i> default setting of 16 point.

This issue also affects the tools text size.
Ed "What the" Heckman

#5 Helen Brown

Helen Brown

    Mithril

  • Admin
  • 8,267 posts
  • Gender:Female
  • Location:heart in Israel
  • Accordance Version:10.x

Posted 30 January 2012 - 10:49 AM

Yes, you have to resave any saved sessions with the new point sizes. Sorry, I hope we won't be doing this change again.
Helen Brown
OakTree Software

#6 Timothy Jenney

Timothy Jenney

    Platinum

  • Accordance
  • 1,577 posts
  • Gender:Male
  • Location:sunny Winter Haven, FL
  • Interests:a good cup of coffee, sci-fi, playing bass, listing to jazz and the blues, camping, fishing and the great outdoors
  • Accordance Version:10.x

Posted 31 January 2012 - 09:22 AM

I have seen the same sort of text display problem in 9.5.3. Typically, it occurs between two superscript letters (indicating the existence of notes or cross-references), especially when the two are split by a verse reference. I have only seen this issue when superscripts are displayed, so users should be able to "Hide superscripts" in the text display panel (Cmd-T) in order to display the text in that is sized correctly. Meanwhile, I am sure our programmers and text developers are hard at work, tracking down this pesky little bug... ;-)
  • Mark Nigro likes this

Blessings,
"Dr. J"

Timothy P. Jenney, Ph. D.
"Lighting the Lamp" Host and Producer

 

Early 2011 17" MBP (8,3), 2.3 GHz Quad core, 16 GB RAM, Mercury 6G 480 SSD + 1.5 TB HD, OSX 10.10, Yosemite

iPhone 6 plus 64 GB iOS 8.1


#7 R. Mansfield

R. Mansfield

    Platinum

  • Accordance
  • 1,117 posts
  • Gender:Male
  • Location:Kentucky
  • Accordance Version:10.x

Posted 31 January 2012 - 11:22 AM

After performing a search string with rule* <not> rulers my results displayed but there may be a bug causing the text to show in two sizes, one very small as you can see from the picture I have uploaded. I checked the verses in question by opening them in a separate window to verify that they show properly and indeed they do. I tried a second search with slightly different word choice (rule* <not> ruled) and got the same problem at the same verses in discussion. I am using 9.5.3.


In regard to Mark's original post, when I look at one of his examples--1 Cor 7:17 in the ESVS--mine does not show the same text in superscript; however, it does display the footnote letter n, which should be in superscript, as regular text. This creates what looks like a nonsense word: nall.

See screenshot:

Attached File  Screen Shot 2012-01-31 at 10.16.25 AM.png   69.36KB   9 downloads

Edited by R. Mansfield, 31 January 2012 - 11:22 AM.

Rick Mansfield

Technology Evangelist

Accordance Bible Software

 


#8 Mark Nigro

Mark Nigro

    Gold

  • Active Members
  • PipPipPipPip
  • 217 posts
  • Gender:Male
  • Location:California
  • Interests:Theology, biblical and modern languages, motorcycles, classical guitar, technology
  • Accordance Version:10.x

Posted 31 January 2012 - 12:20 PM

Helen, I've run into it again and here are the latest screen shots with and without the problem. In response to your questions, latest versions of all modules are installed, so that is ruled out. As Dr. J pointed out and you also suggested, it is happening between the superscripts, but so far only in my ESVS. Switching to various other translations from the same search window displayed correctly, notice the NASB95. And when out of curiosity I reselected ESV from the drop down menu to see if the variation in the window would cause the text to refresh, the problem was still there. My only other insight so far is that it seems to happen after displaying a search, or going to a context window from the search results.

Attached Files



#9 Mark Nigro

Mark Nigro

    Gold

  • Active Members
  • PipPipPipPip
  • 217 posts
  • Gender:Male
  • Location:California
  • Interests:Theology, biblical and modern languages, motorcycles, classical guitar, technology
  • Accordance Version:10.x

Posted 31 January 2012 - 03:10 PM

One more update now...I was able to cause the problem in my regular study pane simply by using the contextual right-click menu to set the text display, adjusting it form 14 to 12 font. Immediately portions of at least three verses (1 Samuel 12:9, 11, 12) morphed into the superscript font. Changing the font size back and forth again did not help at all. Again, this was with the ESV and I cannot seem to produce it with the NAS95.

Edited by nigromr, 31 January 2012 - 03:10 PM.


#10 Ed Heckman

Ed Heckman

    Bronze

  • Active Members
  • PipPip
  • 93 posts
  • Gender:Male
  • Location:Lancaster, PA
  • Accordance Version:10.x

Posted 04 February 2012 - 04:52 PM

Ed: Please check the font size of your display. 9.5.3 added a couple of font sizes which changes all the saved settings.


I didn't understand what you meant by this until I looked at an older copy on my laptop. My saved settings were originally using 16 point Times Roman, and the update changed them to 14 point.

Now I understand! Thanks, Helen.
Ed "What the" Heckman

#11 Daniel Wee

Daniel Wee

    Member

  • Active Members
  • Pip
  • 39 posts
  • Accordance Version:9.x

Posted 13 February 2012 - 08:49 AM

I have a similar problem with the font in the tool displays. Sometimes the font will become smaller than what is set. If I change the font in the Preferences, it will be reset to the new size. Every now and then, the font will shrink. I cannot ascertain the conditions that trigger this as yet but if I do, I will post here.

#12 Joel Brown

Joel Brown

    Administrator

  • Admin
  • 2,810 posts
  • Gender:Male
  • Location:Houston, TX
  • Accordance Version:10.x

Posted 13 February 2012 - 03:38 PM

I'm trying to track down the bug of the font sizes, but I'm still unable to reproduce it in the ESVS in all the verses mentioned here. Mark, can you provide a screenshot of your Set Text Display for when it is occurring, to see if it is a different setting there? Or perhaps a set of steps to reproduce it, such as 'New Search Window -> Enter Verse Reference' idea.

Thanks.
Joel Brown

By day: Consultant for Oaktree
By night: Freelance Trombonist and Private Instructor

#13 Daniel Wee

Daniel Wee

    Member

  • Active Members
  • Pip
  • 39 posts
  • Accordance Version:9.x

Posted 21 February 2012 - 11:09 AM

I've noticed that with the 9.5.4 announcement, it says that every bug has been followed up on. I'm wondering if the font sizing issue has been address because it looks like I am still getting font sizes that do not match my preference settings, with 9.5.4.

Daniel

#14 Joel Brown

Joel Brown

    Administrator

  • Admin
  • 2,810 posts
  • Gender:Male
  • Location:Houston, TX
  • Accordance Version:10.x

Posted 25 February 2012 - 03:08 PM

Daniel, can you post a specific example that isn't matching? Remember how text settings are customized:

• Preferences affect the defaults for all tools, but only affect current open documents if you tell it to 'Apply' after making a change.
• Each tool window can be customized with Command-T, but this is only a temporary change. If you want it to become the new default for that tool, do 'Use as Default'

So, if you make a change in preferences, but the tool already has its own defaults, it may not update them the next time you use the tool.
Joel Brown

By day: Consultant for Oaktree
By night: Freelance Trombonist and Private Instructor

#15 Helen Brown

Helen Brown

    Mithril

  • Admin
  • 8,267 posts
  • Gender:Female
  • Location:heart in Israel
  • Accordance Version:10.x

Posted 25 February 2012 - 04:02 PM

In addition, any saved sessions or workspaces are not affected by the change in Preferences.

The only quick way to fix that is to open every one of your saved workspaces, favorites, and startup session. Then make a change to the text and tool displays in Preferences, and choose to apply to all the open windows. Then you have to resave each workspace (use Save as unless you have made another change in the workspace so that Save is activated).
Helen Brown
OakTree Software




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users