Jump to content


Photo

Issue when copying as citation

copy citation

  • Please log in to reply
9 replies to this topic

#1 Sean R.

Sean R.

    Gold

  • Active Members
  • PipPipPipPip
  • 289 posts
  • Gender:Male
  • Location:Russellville, TN
  • Accordance Version:10.x

Posted 28 February 2012 - 02:11 PM

I've been encountering a problem when I select a portion of a verse that excludes the beginning or end of the verse and, from the contextual menu, select Copy As: Citation. When pasted into a document, often a portion (generally the last few letters or word) of the selected text is not copied over. Sometimes, a word or so from the beginning of the verse (a word not selected) will be included in the pasted text.

For example, I selected "the beginning was the Word, and the Word was with God, and the" from John 1:1. When pasted, I got "In the beginning was the Word, and the Word was with God, a".

When I copy as citation utilizing the key command (ctrl+command+c) I don't encounter this problem.

While I've installed the latest beta (9.5.5), I've been countering this problem for the past several versions; it's not new.

Edited by Sean R., 28 February 2012 - 02:30 PM.

Sean Reed

#2 Joel Brown

Joel Brown

    Administrator

  • Admin
  • 2,812 posts
  • Gender:Male
  • Location:Houston, TX
  • Accordance Version:10.x

Posted 28 February 2012 - 03:38 PM

Sean, I'm having trouble reproducing this. I open ESVS, made the selection you discussed, and every method of Copy as Citation worked for me, via key combo, menu bar, or right click. Perhaps you have different text or citation settings that are the root of the problem? I recall addressing a similar bug a few months ago, perhaps during 9.4, and I was not aware it was still occurring. If you could post screenshots of your Set Text Display and Preferences -> Citation windows, that'd be very helpful.
Joel Brown

By day: Consultant for Oaktree
By night: Freelance Trombonist and Private Instructor

#3 Alistair

Alistair

    Platinum

  • Active Members
  • PipPipPipPipPip
  • 525 posts
  • Gender:Male
  • Accordance Version:10.x

Posted 28 February 2012 - 03:49 PM

I'm finding it erratic also.

When I select "Was in the beginning with"

I get

“He was in the beginning w”
(John 1:2 ESV)

#4 Sean R.

Sean R.

    Gold

  • Active Members
  • PipPipPipPip
  • 289 posts
  • Gender:Male
  • Location:Russellville, TN
  • Accordance Version:10.x

Posted 28 February 2012 - 03:56 PM

I first noticed this behavior with NAS95S. I've since tested ESVS, NKJVS, and NET with the same result—erratic copying when selecting Copy As: Citation from the contextual menu (but no problem when using the key command).

Attached are the requested screenshots.

Attached Files


Sean Reed

#5 Alistair

Alistair

    Platinum

  • Active Members
  • PipPipPipPipPip
  • 525 posts
  • Gender:Male
  • Accordance Version:10.x

Posted 28 February 2012 - 04:32 PM

I was using the key command with the ESVS text.

#6 Sean R.

Sean R.

    Gold

  • Active Members
  • PipPipPipPip
  • 289 posts
  • Gender:Male
  • Location:Russellville, TN
  • Accordance Version:10.x

Posted 01 March 2012 - 11:13 AM

I restarted Accordance, and my Mac, and the problem disappeared.
Sean Reed

#7 Alistair

Alistair

    Platinum

  • Active Members
  • PipPipPipPipPip
  • 525 posts
  • Gender:Male
  • Accordance Version:10.x

Posted 03 March 2012 - 08:23 PM

I restarted Accordance, and my Mac, and the problem disappeared.


Me too, but the problem remains:


"Was in the beginning with" becomes “He was in the beginning w” (John 1:2 ESV)

#8 Helen Brown

Helen Brown

    Mithril

  • Admin
  • 8,269 posts
  • Gender:Female
  • Location:heart in Israel
  • Accordance Version:10.x

Posted 03 March 2012 - 09:01 PM

Alistair: are you perchance hiding the superscripts in this text?
Helen Brown
OakTree Software

#9 Alistair

Alistair

    Platinum

  • Active Members
  • PipPipPipPipPip
  • 525 posts
  • Gender:Male
  • Accordance Version:10.x

Posted 04 March 2012 - 07:59 PM

Hi Helen,

No, I'm only hiding red letter text.

NB there are no superscripts in John 1:2.

#10 Alistair

Alistair

    Platinum

  • Active Members
  • PipPipPipPipPip
  • 525 posts
  • Gender:Male
  • Accordance Version:10.x

Posted 12 March 2012 - 03:58 PM

"Was in the beginning with" becomes “He was in the beginning w” (John 1:2 ESV)


Still the same in 9.5.7, with keyboard shortcut and with selecting menu item.





Also tagged with one or more of these keywords: copy, citation

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users