Jump to content


Photo

Making Hebrew Flashcards for FCE and Mental Case


  • Please log in to reply
11 replies to this topic

#1 timothylfox

timothylfox

    Member

  • Active Members
  • Pip
  • 16 posts
  • Accordance Version:9.x

Posted 06 May 2012 - 04:24 PM


I've tried creating flashcards for Flashcard Exchange/Mental Case according to the blog post here - analyzing hit words, setting their display correctly, exporting as RTF, etc.

Everything works fine for me until I try to import my modified RTF text into Flashcard Exchange. When I do that, the Hebrew gets really wacky - it looks like the vowels are becoming their own "characters" instead of being above or below the consonants. Any ideas of what's causing this? It is still wacky when I display and study the set in Flashcard Exchange, and not just when I am pasting it on FE. I have Accordance set to paste Greek/Hebrew in Unicode and I'm on OSX 10.6.8.

Assuming it shows up the same on your screen, it looks like this:

‎מִקְדָּשׁ


Thanks!


Tim



#2 Rick Bennett

Rick Bennett

    Platinum

  • Accordance
  • 1,636 posts
  • Gender:Male
  • Location:Tampa Bay, FL
  • Interests: gadgets, coffee, running and cycling, Rays baseball
  • Accordance Version:10.x

Posted 07 May 2012 - 08:30 AM

I've tried creating flashcards for Flashcard Exchange/Mental Case according to the blog post here - analyzing hit words, setting their display correctly, exporting as RTF, etc.
Everything works fine for me until I try to import my modified RTF text into Flashcard Exchange. When I do that, the Hebrew gets really wacky - it looks like the vowels are becoming their own "characters" instead of being above or below the consonants. Any ideas of what's causing this? It is still wacky when I display and study the set in Flashcard Exchange, and not just when I am pasting it on FE. I have Accordance set to paste Greek/Hebrew in Unicode and I'm on OSX 10.6.8.
Assuming it shows up the same on your screen, it looks like this:

‎מִקְדָּשׁ


Thanks!


Tim



That word appears correctly on my end (verified with Safari and Firefox). Try checking your encoding settings in your web browser, and make sure they are set to Unicode.

Rick Bennett
Director of Content Development
iOS Working Group


#3 timothylfox

timothylfox

    Member

  • Active Members
  • Pip
  • 16 posts
  • Accordance Version:9.x

Posted 07 May 2012 - 11:41 AM

Hi Rick,

I did set my browsers (Firefox, Safari, Chrome) from Western to UTF-8 Unicode, and then restarted my computer, but I'm still having the same problem. Any other ideas?

Possible ideas:

-My "keyboard" is currently set to U.S. Extended (so I can type macros: ō)...could this be causing a problem?
-I am on an old-ish Macbook Pro (2006, first generation of Intel processors), running OSX 10.6.8.
-....?

I'd really appreciate any help!

Tim

#4 Rick Bennett

Rick Bennett

    Platinum

  • Accordance
  • 1,636 posts
  • Gender:Male
  • Location:Tampa Bay, FL
  • Interests: gadgets, coffee, running and cycling, Rays baseball
  • Accordance Version:10.x

Posted 07 May 2012 - 01:50 PM

Hi Rick,

I did set my browsers (Firefox, Safari, Chrome) from Western to UTF-8 Unicode, and then restarted my computer, but I'm still having the same problem. Any other ideas?

Possible ideas:

-My "keyboard" is currently set to U.S. Extended (so I can type macros: ō)...could this be causing a problem?
-I am on an old-ish Macbook Pro (2006, first generation of Intel processors), running OSX 10.6.8.
-....?

I'd really appreciate any help!

Tim


I'm not sure about the keyboard; you could try turning it off (i.e. using non-extended version). The MacBook Pro shouldn't be the issue either.

Edited by Rick Bennett, 07 May 2012 - 02:01 PM.

Rick Bennett
Director of Content Development
iOS Working Group


#5 Rick Bennett

Rick Bennett

    Platinum

  • Accordance
  • 1,636 posts
  • Gender:Male
  • Location:Tampa Bay, FL
  • Interests: gadgets, coffee, running and cycling, Rays baseball
  • Accordance Version:10.x

Posted 07 May 2012 - 02:01 PM

Hi Rick,

I did set my browsers (Firefox, Safari, Chrome) from Western to UTF-8 Unicode, and then restarted my computer, but I'm still having the same problem. Any other ideas?

Possible ideas:

-My "keyboard" is currently set to U.S. Extended (so I can type macros: ō)...could this be causing a problem?
-I am on an old-ish Macbook Pro (2006, first generation of Intel processors), running OSX 10.6.8.
-....?

I'd really appreciate any help!

Tim


Can you also send/post a link to the specific set you created on FCE?

Rick Bennett
Director of Content Development
iOS Working Group


#6 timothylfox

timothylfox

    Member

  • Active Members
  • Pip
  • 16 posts
  • Accordance Version:9.x

Posted 07 May 2012 - 02:31 PM

Hi Rick,

Thanks again for all your help. I tried turning my keyboard back to the "normal" US keyboard, but I'm still having the same problem.

Here is the original FCE set: http://www.flashcard...w-70-75-2183295

I created a new set (with the "normal" keyboard), but it looks like it is not showing up yet in FCE's searchable database.

Thanks!
Tim

#7 James Tucker

James Tucker

    Platinum

  • Active Members
  • PipPipPipPipPip
  • 609 posts
  • Gender:Not Telling
  • Accordance Version:10.x

Posted 07 May 2012 - 02:40 PM

Here is the original FCE set: http://www.flashcard...w-70-75-2183295


They appear to be fine.

It might help to post a screen shot of what you are seeing?

#8 timothylfox

timothylfox

    Member

  • Active Members
  • Pip
  • 16 posts
  • Accordance Version:9.x

Posted 07 May 2012 - 03:46 PM

Here's a screenshot of the FCE interface.

Thanks!

Attached File  Screen shot 2012-05-07 at 1.32.51 PM.png   27.28KB   22 downloads

#9 James Tucker

James Tucker

    Platinum

  • Active Members
  • PipPipPipPipPip
  • 609 posts
  • Gender:Not Telling
  • Accordance Version:10.x

Posted 07 May 2012 - 03:50 PM

How did you 'import' this set into Flashcard Exchange?


Have you tried to download them to your iPhone/iPod for viewing?

Edited by James Tucker, 07 May 2012 - 03:51 PM.


#10 Rick Bennett

Rick Bennett

    Platinum

  • Accordance
  • 1,636 posts
  • Gender:Male
  • Location:Tampa Bay, FL
  • Interests: gadgets, coffee, running and cycling, Rays baseball
  • Accordance Version:10.x

Posted 07 May 2012 - 03:52 PM

How did you 'import' this set into Flashcard Exchange?


Copy / paste from Accordance as in the blog. But, that can't be the issue since it renders fine on our browsers.

Tim, I suspect it is still related to the default font (make sure it supports the vowels) or something else encoding related.

Edited by Rick Bennett, 07 May 2012 - 03:53 PM.

Rick Bennett
Director of Content Development
iOS Working Group


#11 timothylfox

timothylfox

    Member

  • Active Members
  • Pip
  • 16 posts
  • Accordance Version:9.x

Posted 07 May 2012 - 06:54 PM

Bad News: I changed my default font (in Chrome) from "Times" to "Times New Roman," restarted, and then still the same weird vowel display.

Good News: Once I import from FCE into my iPhone (and then back to Mental Case on my Mac), the vowels display fine.

Weird...

...while we're at it, can someone also solve the mystery of predestination for me? 100 words or less. Thanks. =)

#12 timothylfox

timothylfox

    Member

  • Active Members
  • Pip
  • 16 posts
  • Accordance Version:9.x

Posted 08 May 2012 - 12:49 PM

Update:

I checked the cardset on FCE on my work computer, which is also running OSX 10.6.8. The vowels display fine! The weird thing is that this browser (Chrome) is set for Western (not Unicode) encoding, and it still worked.

I wonder if there's something wrong with my home computer's registry or something...?

Thanks for all your help!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users