Jump to content


Photo

More User Tool problems


  • Please log in to reply
16 replies to this topic

#1 Alistair

Alistair

    Platinum

  • Active Members
  • PipPipPipPipPip
  • 513 posts
  • Gender:Male
  • Accordance Version:10.x

Posted 05 July 2006 - 06:42 AM

I'm struggling with the User Tool.

I have imported a large section of html text, which has worked fine.

I'm now working through the tool marking up scripture references and adding titles and subtitles.

The problem is when I start adding titles, the subsequent non-titled text disappears.

It appears in the tool itself in the normal Accordance window, but when I go into edit mode to add more titles I can only see the text for the titled section. I am therefore unable to add more titles or markup more scripture references.

My frustrations with the limitations of the User Tool creation and editing facilities are well documented elsewhere on this forum, as indeed are those of others. I would like to strongly urge the Accordance programmers to give serious thought to expanding these facilites.

User Tool creation that is difficult and time-consuming is one thing.
User Tool creation that simply doesn't work is another.

#2 David Lang

David Lang

    Platinum

  • Accordance
  • 763 posts
  • Gender:Male
  • Location:Mount Dora, FL
  • Interests:Accordance development, writing, spending time with my wife and five kids
  • Accordance Version:9.x

Posted 05 July 2006 - 09:06 AM

Alistair,

It sounds like you're just running into the fact that the Edit window only shows a certain portion of the text of the tool at one time. You can move to the next section of text by clicking the down arrow buttons at the bottom left corner of the window.

You can also expand the amount of text which is displayed in the Edit window at one time. Just go to Preferences, select Edit Windows, and choose Medium or Large in the pop-up labeled User Tool Edit.

Hope this helps.
Sincerely,
David Lang
Accordance Developer
http://www.accordancebible.com

Author:
Feet to Follow, Eyes to See
http://feettofollow.wordpress.com

Macs in the Ministry
http://www.macsinministrybook.com

Leader of the "Lang Gang"
http://www.langgangland.com
http://twitter.com/DavidAllenLang

#3 Alistair

Alistair

    Platinum

  • Active Members
  • PipPipPipPipPip
  • 513 posts
  • Gender:Male
  • Accordance Version:10.x

Posted 05 July 2006 - 12:23 PM

Hi David,

Thanks, that's helpful albeit to my mind a little non-intuitive!

Now my problem is that Accordance has automatically put T-marks in where I don't want them, and I cannot remove them.

Any tips?



Hi David,

Then I get an error message because the paragraph where Accordance has put the T-mark is over 128 characters in length, therefore I cannot save the updates I just made.

Then Accordance crashes.

Not good.

~A

#4 Helen Brown

Helen Brown

    Mithril

  • Admin
  • 8,225 posts
  • Gender:Female
  • Location:heart in Israel
  • Accordance Version:10.x

Posted 05 July 2006 - 03:29 PM

We have already admitted that the Ts are offset because of the new margin around the text. Just click below one to remove it, and accept that new ones are created above the line of the text you intend them for. We will correct this in the next release.
Helen Brown
OakTree Software

#5 Harry Hoffner

Harry Hoffner

    Bronze

  • Active Members
  • PipPip
  • 52 posts
  • Location:Chicago-area, Illinois
  • Interests:Emeritus Professor, University of Chicago. Interests Ancient Near Eastern languages and history; biblical studies.

Posted 05 July 2006 - 04:51 PM

We have already admitted that the Ts are offset because of the new margin around the text. Just click below one to remove it, and accept that new ones are created above the line of the text you intend them for. We will correct this in the next release.


Helen, you didn't answer the second part of his question. He now cannot remove the T's, even if he clicks the line under them. I had the same problem, and only managed to finally delete them in unpredictable and therefore unrepeatable ways. Any time a "T" was at the top of a User Tool Edit window, it refused to be dleted in the usual way.

Something does seem out of whack. Maybe once the alignment problem is fixed this will also fix the other.
Harry Hoffner. Emeritus Professor, The Oriental Institute of the University of Chicago. Founder & Editor of The Hittite Dictionary of the Oriental Institute of the University of Chicago.


#6 Alistair

Alistair

    Platinum

  • Active Members
  • PipPipPipPipPip
  • 513 posts
  • Gender:Male
  • Accordance Version:10.x

Posted 06 July 2006 - 04:52 AM

Thank you Harry, you hit the nail on the head, and very eloquently too.

Accordance has put T-marks in places where I did not want them, namely at the beginning of sections I can only navigate to by clicking on the up and down arrows in the edit window.

These I cannot remove either by by clicking on, under, around or over.

(Banging the keyboard against my head, or my head against the keyboard, doesn't help either.)

My User Tool is a 112 page document. Automatic T insertion is a great feature, when it works, but not when it gets it wrong and refuses to allow me to correct it.

<Rant>

I know OakTree must be constantly bombarded with requests for this module or that module, this feature or that feature... my two-pence worth is for a User Tool creation and editing experience that is a thing of beauty and a joy forever. There is tiny number of User Tools publicly available over the Internet (thank you Accordance Exchange), but that could change dramatically. If, as I have been infomed, User Tool creation is unique to Accordance in comparison to other Bible software, or at no extra cost, then why not go out and really make a feature out of it.

We need proper editing and formatting tools within Accordance, or better importing functions from documents from html or xml or rtf.

And please don't tell me that the User Tool wasn't designed for 112 page documents. If a document was small enough to be imported into Accordance without any problems then I wouldn't NEED to import it into Accordance. It is EXACTLY BECAUSE it is such a large document that I want it available within Accordance.
(Capitals for emphasis, not volume!)

</Rant>

Thanks.

Postscript:
OK, I have a work around for the immovable Ts.
1 Use the arrows to navigate to the section with the immovable T.
2 Copy and delete this text.
3 Use the arrows to navigate to the previous section.
4 Paste the text at the end of the preceeding text.
5 Tidy up and format text.
6 Check with User Tool browser sidebar that everthing is OK.
7 Hope for the best!

~A

Edited by Alistair, 06 July 2006 - 04:53 AM.


#7 Alistair

Alistair

    Platinum

  • Active Members
  • PipPipPipPipPip
  • 513 posts
  • Gender:Male
  • Accordance Version:10.x

Posted 07 July 2006 - 11:50 AM

I'm looking forward to see the improvements in the next update.

David, I was just re-reading the second part of your entry and I discovered that I do not have a setting for "Edit Windows" in the preferences window. (7.0.1)

Am I looking in the wrong place?

Thanks!

#8 Alistair

Alistair

    Platinum

  • Active Members
  • PipPipPipPipPip
  • 513 posts
  • Gender:Male
  • Accordance Version:10.x

Posted 11 July 2006 - 06:56 AM

Something is still seriously wrong with User Tools.

Trying to launch Accordance gives an error message:
"An attempt to read or save data beyond the end of the file "User Tools" has failed."
The program then quits with an error message.

This is solved by removing the file "User Tools" at
~user/Library/Preferences/Accordance Preferences/User Tools
However, I then have to import all my User Tools from scratch (about thirty), which you can imagine, is tedious.

I have had to do this twice now. I suspect that the User Tools are somehow being corrupted by the program, possibly related to the inflexible Ts and their automatic placement.

David, I still cannot find the "Edit Windows" option among the preferences. I must be missing somthing fundamentally obvious, please help!

#9 Helen Brown

Helen Brown

    Mithril

  • Admin
  • 8,225 posts
  • Gender:Female
  • Location:heart in Israel
  • Accordance Version:10.x

Posted 11 July 2006 - 01:43 PM

The User Tools themselves are not being corrupted, maybe the Preference is, we can look at that. If you try again, be sure to delete that preference file from both Accordance Preferences folders.

Maybe you need to add at least on User Note in order to see the Edit Window item in the list of Preferences, as most of the options apply to User Notes rather than User Tools.

Yes, this is a bug and is fixed for the upcoming 7.0.2 which we will release shortly.
Helen Brown
OakTree Software

#10 Alistair

Alistair

    Platinum

  • Active Members
  • PipPipPipPipPip
  • 513 posts
  • Gender:Male
  • Accordance Version:10.x

Posted 12 July 2006 - 04:22 AM

Thanks Helen,

Your tip on user notes solved that problem.

I didn't have any user notes but after creating an empty note file and saving it the Edit Window feature appeared under preferences.

Yay! This is real progress. Please give yourself a hug from me :) I can see a way out, light at the end of the tunnel!

~A

Both Accordance Preferences folders? I seem to have missed one of them, I assume you mean the one in the same folder as the Accordance application. I haven't touched that folder but it seems to be working fine. I haven't imported/loaded my user tools yet, however. I think I'll leave it as it is unless I get the same problem again, in which case I'll delete both and start over from scratch.

~A

PS It's not a bug, it's an "undocumented feature"!

Edited by Alistair, 12 July 2006 - 04:32 AM.


#11 Alistair

Alistair

    Platinum

  • Active Members
  • PipPipPipPipPip
  • 513 posts
  • Gender:Male
  • Accordance Version:10.x

Posted 12 July 2006 - 05:28 AM

On the subject of undocumented features, with the Edit Window preferences set to "Large (fewer updates)" I was unable to mark as Scripture Link any references that included a range of verses.

IE, Highlighting "Revelation 20:11-15" and clicking on Scripture Link had no effect. Linking single verse references eg "Matthew 27:51" worked fine.

I changed the Edit Window preferences set to "Small (faster editing)" and I was able to markup the ranged references normally.

Anybody else experienced such behaviour?

~A

#12 Ken Han

Ken Han

    Platinum

  • Active Members
  • PipPipPipPipPip
  • 603 posts
  • Gender:Male
  • Location:San Diego, CA
  • Accordance Version:10.x

Posted 12 July 2006 - 08:41 AM

Yes, the scripture link is often finicky. I often run into situations like yours where the scripture link randomly does not work, even though links before and after it will work perfectly fine.

#13 Alistair

Alistair

    Platinum

  • Active Members
  • PipPipPipPipPip
  • 513 posts
  • Gender:Male
  • Accordance Version:10.x

Posted 12 July 2006 - 08:43 AM

Yes, the scripture link is often finicky. I often run into situations like yours where the scripture link randomly does not work, even though links before and after it will work perfectly fine.


Ken,

Was this on single verse references or on multiple verse ranges?

For me the problem seems to be with multiple verse ranges.

~A!

#14 Alistair

Alistair

    Platinum

  • Active Members
  • PipPipPipPipPip
  • 513 posts
  • Gender:Male
  • Accordance Version:10.x

Posted 19 July 2006 - 12:04 PM

Here's a new glitch (7.0.2):

Editing a UT does not reveal all bold text styles, or at least it isn't discernable with Geneva 12pt or 18pt black text.

The text is bold in the Accordance application UT window, but in the editing window it shows up as roman/plain.

Clicking BOLD on and off makes the tiniest difference to the tracking of the word selected, but not the usual obvious emboldening effect with the increase in the weight of the characters.

~A!

Edited by Alistair, 19 July 2006 - 12:05 PM.


#15 Helen Brown

Helen Brown

    Mithril

  • Admin
  • 8,225 posts
  • Gender:Female
  • Location:heart in Israel
  • Accordance Version:10.x

Posted 22 July 2006 - 07:52 AM

This is working fine for me, I wonder which version of Accordance you have.

Quartz requires that each font have its own style, it no longer interlopates the styles from the plain font as the Mac Classic systems did. Geneva font only comes in Regular so Accordance is now using Helvetica in the Edit Window (though it is still labeled Geneva), and I suspect is doing the same in other places.
Helen Brown
OakTree Software

#16 Alistair

Alistair

    Platinum

  • Active Members
  • PipPipPipPipPip
  • 513 posts
  • Gender:Male
  • Accordance Version:10.x

Posted 26 July 2006 - 11:25 AM

That could explain it. I had disabled the Helvetica font, but when re-enabled the problem goes away.

Requests:

1) Rename Geneva in the palette to Helvetica, so it is accurate and not misleading.
2) Enable multiple different user-defined fonts to be used within UserTools.

Having said that, I can see that limiting uniformity in font usage is an advantage when it comes to sharing UTs that would otherwise be tied to particular typefaces.

Edited by Alistair, 26 July 2006 - 11:26 AM.


#17 Helen Brown

Helen Brown

    Mithril

  • Admin
  • 8,225 posts
  • Gender:Female
  • Location:heart in Israel
  • Accordance Version:10.x

Posted 26 July 2006 - 12:53 PM

We can do the first idea, but all tools use a uniform font for English text, and you select the display font in the Set tool Display, so this is not an option for User Tools, sorry.
Helen Brown
OakTree Software




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users