Jump to content


Photo

Formatting in user Bible texts


  • Please log in to reply
9 replies to this topic

#1 Andrew Perriman

Andrew Perriman

    Member

  • Active Members
  • Pip
  • 19 posts
  • Accordance Version:8.x

Posted 05 December 2012 - 10:34 AM

I have been trying to add html formatting to a user bible text but keep getting a message saying "Expecting one or more HTML tags at the end of the text... to terminate earlier HTML tags in the verse."

I have one verse with html for test purposes:

Heb 1:14 Are they not all <i>ministering spirits</i> sent for service for the sake of those about to inherit salvation?

I can't see anything wrong with that. If I delete the <i>...</i>, the file is imported normally.

I am using Accordance 10.1.

#2 Andrew Perriman

Andrew Perriman

    Member

  • Active Members
  • Pip
  • 19 posts
  • Accordance Version:8.x

Posted 06 December 2012 - 04:58 AM

Further to this, I have found that the user Bible will import correctly if I place the closing tag at the end of the verse, as it says in the warning message:

Heb 1:14 Are they not all <i>ministering spirits sent for service for the sake of those about to inherit salvation?</i>

The text file is saved as UTF-8 as it has the character ē in it.

#3 arcanemuse

arcanemuse

    Bronze

  • Active Members
  • PipPip
  • 72 posts
  • Gender:Male
  • Accordance Version:10.x

Posted 06 December 2012 - 07:52 AM

I am not sure how it works in this application but maybe it wants to see <html> and </html> at the beginning of your passage and at the end? Just a thought of something to try. Perhaps someone with more knowledge about this particular application of it might be able to shed light on this better than I. I suppose it won't hurt to try that idea, though. Worst case scenario is that it still won't work. :-)
God Bless,
Rick

#4 Andrew Perriman

Andrew Perriman

    Member

  • Active Members
  • Pip
  • 19 posts
  • Accordance Version:8.x

Posted 06 December 2012 - 11:00 AM

I am not sure how it works in this application but maybe it wants to see <html> and </html> at the beginning of your passage and at the end? Just a thought of something to try. Perhaps someone with more knowledge about this particular application of it might be able to shed light on this better than I. I suppose it won't hurt to try that idea, though. Worst case scenario is that it still won't work. :-)

Thanks for the suggestion, but sadly it didn't help.

#5 Sean R.

Sean R.

    Gold

  • Active Members
  • PipPipPipPip
  • 289 posts
  • Gender:Male
  • Location:Russellville, TN
  • Accordance Version:10.x

Posted 06 December 2012 - 11:14 AM

I copied from your original post the Heb 1:14 text

Heb 1:14 Are they not all <i>ministering spirits</i> sent for service for the sake of those about to inherit salvation?


pasted it into a Text Edit document, converted it to plain text, and saved it in UTF-8 encoding. Then, I imported it into Accordance as a User Bible with no problems. I don't have any idea why you're experiencing the trouble you are, but perhaps quitting Accordance and re-opening the program may help. If that doesn't work, perhaps restarting your computer (just stabbing in the dark here).

Posted Image

Edited by Sean R., 06 December 2012 - 11:16 AM.

Sean Reed

#6 Andrew Perriman

Andrew Perriman

    Member

  • Active Members
  • Pip
  • 19 posts
  • Accordance Version:8.x

Posted 06 December 2012 - 01:12 PM

Thanks for trying! Shutting down Accordance and rebooting made no difference.

What version of Accordance did you try it in? I am using 10.1.

I have uploaded a text file with Hebrews 1 if you or anyone else wants to try it out. Two verses have italics formatting in them. If I remove the formatting the file imports without a hitch.

Attached Files



#7 Sean R.

Sean R.

    Gold

  • Active Members
  • PipPipPipPip
  • 289 posts
  • Gender:Male
  • Location:Russellville, TN
  • Accordance Version:10.x

Posted 06 December 2012 - 01:18 PM

The file you uploaded doesn't have any formatting markers in it. What verse, other than v. 14, has italics in it? I'll try importing it.
Sean Reed

#8 Sean R.

Sean R.

    Gold

  • Active Members
  • PipPipPipPip
  • 289 posts
  • Gender:Male
  • Location:Russellville, TN
  • Accordance Version:10.x

Posted 06 December 2012 - 01:26 PM

I imported the file you uploaded, italicizing oikoumenē in v. 6 and ministering spirits in v. 14. Accordance threw the file back at me twice. Once I made two changes, it worked alright.

1. It didn't like the closing marker (</i>) in v. 6. Once I moved it to after the comma (,) it worked fine. Thus I changed it from
But again whenever he brings the firstborn into the <i>oikoumenē</i>, he says, "And let all angels of God worship him."
to
But again whenever he brings the firstborn into the <i>oikoumenē,</i> he says, "And let all angels of God worship him."

2. It didn't like the closing marker (</i> in v. 14. So I put a space between it and the preceding word, removed the space following the marker so as to make sure didn't have two spaces, and Accordance took it just fine.

I'll mess with it a bit more to see if I can figure out why it is snagging on these closing markers.
Sean Reed

#9 Sean R.

Sean R.

    Gold

  • Active Members
  • PipPipPipPip
  • 289 posts
  • Gender:Male
  • Location:Russellville, TN
  • Accordance Version:10.x

Posted 06 December 2012 - 01:50 PM

The problem seems to center around the ē. If this character is removed, there are no issues related to the character formatting markers. With ē, I cannot import without the added spaces discussed above.

One other issue I just noticed is that Accordance is not displaying the chapter number, just the book and verse. This doesn't seem to impact verse searching at all, but I wonder why there is this display issue (and it's not related to the text display preferences).

Edited by Sean R., 06 December 2012 - 01:52 PM.

Sean Reed

#10 Andrew Perriman

Andrew Perriman

    Member

  • Active Members
  • Pip
  • 19 posts
  • Accordance Version:8.x

Posted 06 December 2012 - 04:43 PM

Sean, many thanks for your help. Your solution worked—there is a problem if the </i> immediately follows ē.

When I load the full document, which is not a complete translation, chapter numbers show as expected.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users