Jump to content


Photo

Unicode export should not disable "Save as plain text"


  • Please log in to reply
3 replies to this topic

#1 Joe Weaks

Joe Weaks

    Platinum

  • Active Members
  • PipPipPipPipPip
  • 1,082 posts
  • Gender:Male
  • Location:Odessa, TX
  • Interests:I like things that are Orange, and possibly Blue.
  • Accordance Version:11.x

Posted 06 December 2012 - 01:36 PM

This has bugged me for a long time.
When Export as Unicode is selected, the "File/Save text selection as Plain text" is disabled. This makes no sense. Unicode is plain text. In fact, Unicode Greek and Hebrew is even more conducive to saving in plain text format than legacy font encodings, because Unicode Greek/Hebrew actually displays at Greek/Hebrew even in plain text format. Accordance may have internal limitations that make this limitation so, but it is a bug.

This bug is even worse, now, since moving "Export as Unicode" outside of the Greek/Hebrew tab, because now if I have even an English-only text selection, and trying to save it as plain text, and it won't allow the Plain text option if the "Unicode export" option is selected.

#2 Joel Brown

Joel Brown

    Administrator

  • Admin
  • 3,047 posts
  • Gender:Male
  • Location:Houston, TX
  • Accordance Version:11.x
  • Platforms:Mac OS X, Windows

Posted 06 December 2012 - 04:00 PM

As you notice when you select the "File/Save text selection as Plain text' that it specifies it is saving the file as ASCII, which as you know is explicitly not Unicode. What it sounds like you are looking for is that this export, when Unicode is on, uses non-styled Unicode, rather than non-styled ASCII. That is a feature request we'll have to consider!

For the record, no functionality changed when the preferences moved around. Export as Unicode has always affected English, and that disabling has always been in place, even for English.
Joel Brown

By day: Consultant for Oaktree
By night: Freelance Trombonist and Private Instructor

#3 Joe Weaks

Joe Weaks

    Platinum

  • Active Members
  • PipPipPipPipPip
  • 1,082 posts
  • Gender:Male
  • Location:Odessa, TX
  • Interests:I like things that are Orange, and possibly Blue.
  • Accordance Version:11.x

Posted 06 December 2012 - 04:26 PM

Yep, Joel, you understand the problem, of course.
Yes, I understand the legacy reasons why the problem is there, of course.

And, disabling save as Plain Text is a bug from the user perspective. UTF-8 is plain text, too.
Joe Weaks
The Macintosh Biblioblog

Sometimes I'm so helpful even I can't stand it.

#4 Scott Knapp

Scott Knapp

    Platinum

  • Accordance
  • 1,142 posts
  • Gender:Male
  • Location:Orlando, FL
  • Accordance Version:10.x

Posted 06 December 2012 - 05:47 PM

I agree with Joe here. "Plain" is more of a text style (or lack thereof) rather than a text encoding.

Scott.

Edited by Scott Knapp, 06 December 2012 - 05:47 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users