Jump to content


Photo

Verse scoped searches failing


  • Please log in to reply
4 replies to this topic

#1 Daniel Semler

Daniel Semler

    Platinum

  • Active Members
  • PipPipPipPipPip
  • 1,180 posts
  • Gender:Male
  • Accordance Version:10.x

Posted 28 December 2012 - 12:10 AM

Hi All,

I must be missing something on this one. I am new to Acc. but I've read search doc on this and watched a number of Dr. J's podcasts. I'm still not getting this one. Here's my problem : I search for a word in the whole text of a bible in English. I search for the word Adam and I scope the search to Verse. Its a single word; every occurrence is by definition within a verse. I get this dialog in response to my search "There are no verses in the current range of the "BBE" text, which fit the current search entry. I've attached a before and after screenshot. These shots were done with Exact search but Flex does the same thing. If I search with scope of Chapter I get the results.

Any guesses as to what I might not be doing or what I should not be doing ?

Thx
D

Attached Files


Accordance Configurations :

 

Mac : 2009 27" iMac                 Windows : HP 4540s laptop

      Intel Core Duo                          Intel i5 Ivy Bridge

      12GB RAM                                8GB RAM

      Accordance 10.4.3.2                     Accordance 10.4.3.2 and Aleph 10.4.3.2

      OSX 10.9 (Mavericks)                    Win 7 Professional x64 SP1


#2 Ken Simpson

Ken Simpson

    Platinum

  • Accordance
  • 1,335 posts
  • Gender:Male
  • Location:Sydney, Australia
  • Interests:Astronomy
    Archaeology
    Physics
    Hebrew and Greek
    Papyrology
    Surgeon
  • Accordance Version:10.x

Posted 28 December 2012 - 02:08 AM

Hi Daniel,
Accordance is in verse mode. Try changing to word mode in the search entry bar drop down.

I am away from my Mac, but that's something I can see that's inconsistent...

Regards
Ken
Australian Accordance Demonstrator

Administrator, Accordance Exchange

Assistant Minister, Summer Hill Church


#3 Daniel Semler

Daniel Semler

    Platinum

  • Active Members
  • PipPipPipPipPip
  • 1,180 posts
  • Gender:Male
  • Accordance Version:10.x

Posted 28 December 2012 - 02:19 AM

Hi Ken,

Thanx for that and I'm surprised I snapped the images that way but in fact it makes no difference. I've tried it again just now in Words mode and I get the same result.

As an aside, I thought Acc 10 was capable of running the search in the appropriate mode if the search was otherwise clear. Am I mistaken in thinking this ?

Tx
D

Accordance Configurations :

 

Mac : 2009 27" iMac                 Windows : HP 4540s laptop

      Intel Core Duo                          Intel i5 Ivy Bridge

      12GB RAM                                8GB RAM

      Accordance 10.4.3.2                     Accordance 10.4.3.2 and Aleph 10.4.3.2

      OSX 10.9 (Mavericks)                    Win 7 Professional x64 SP1


#4 Joel Brown

Joel Brown

    Administrator

  • Admin
  • 2,524 posts
  • Gender:Male
  • Location:Houston, TX
  • Accordance Version:10.x

Posted 28 December 2012 - 04:33 AM

Hi, Daniel, and welcome to Accordance!

 

First, yes one of the features in 10 is that you don't need to worry about Verses vs. Words in your searches, it should switch for you if necessary.

 

Now then, regarding your specific error, I believe I know what is going on.  If you look to the right of your Scope is Verse menus, there are the two arrows to the right. These indicate that you have an additional search condition set that isn't visible due to limited screen space.  I wonder if this condition is set to Brackets, that they are Exclusive.  This would prevent the BBE from finding Adam, as it is searching only within [bracketed words].  Just remove the condition or change it to Inclusive or Ignored.

 

Some quick explanation of all of the things I just talked about:

• The search conditions that you've added are very useful at times, but usually not needed except for certain types of searches.  

 

• Accordance will always search [All Text] if there is no Range condition applied, so unless you want to specify a specific range to search, you don't need that condition up.

 

• The Scope condition generally only applies with compound searches.  For example, if I want to find Adam and Eve within the same Verse, I use 'Adam <AND> Eve', with Scope set to verse. If I want to find those two words within the same Chapter, I then change my scope to Chapter.  But, for a single word search, it doesn't really affect anything.

 

• The Bracketed Words condition applies when dealing with words between square brackets  [  ]  .  Inclusive is the default, which means that searches search words both inside and outside the brackets.  Ignored means that Accordance doesn't search the words inside the brackets, only the ones outside them.  Exclusive is probably what was causing the error and means that it will only find words inside brackets.  I imagine BBE doesn't even use brackets, so thats why Adam wasn't found inside of them.

 

 

Generally, I keep my search conditions all closed to maximize the space my text can appear, then I only add them as needed.  Some users like to keep all three visible for easy access each time, which is fine of course.  In your case, that hidden one was set to Exclusive and thus preventing your search.  Note, in your case where its overflowing, the arrows are also a menu that lets you access the bracket options without having to make your window bigger.

 

Hope this all helps!

 

tl;dr:  You appear to have a Bracketed Words condition set to Exclusive, which means it won't find Adam.  Change that to Inclusive, or just remove the condition to fix your search.


Joel Brown

By day: Consultant for Oaktree
By night: Freelance Trombonist and Private Instructor

#5 Daniel Semler

Daniel Semler

    Platinum

  • Active Members
  • PipPipPipPipPip
  • 1,180 posts
  • Gender:Male
  • Accordance Version:10.x

Posted 28 December 2012 - 09:29 AM

Hi Joel,  Many thanx. Spot on. I had not paid much attention to the Bracketed Words condition and though I'd noticed the slightly unexpected Exclusive rather than Excluded as opposite of Included I had not investigated that. I was playing with more complex searches but simplified to a single term trying to find the source of the issue I was seeing. Indeed setting to included or ignored works as does removing the condition.

 

Many thanx

D


Accordance Configurations :

 

Mac : 2009 27" iMac                 Windows : HP 4540s laptop

      Intel Core Duo                          Intel i5 Ivy Bridge

      12GB RAM                                8GB RAM

      Accordance 10.4.3.2                     Accordance 10.4.3.2 and Aleph 10.4.3.2

      OSX 10.9 (Mavericks)                    Win 7 Professional x64 SP1





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users