Jump to content


Photo

Display, Copy and Paste


  • Please log in to reply
8 replies to this topic

#1 jarcher

jarcher

    Silver

  • Active Members
  • PipPipPip
  • 150 posts
  • Gender:Male
  • Location:Minnesota
  • Accordance Version:8.x

Posted 25 May 2005 - 11:58 PM

Greetings,

I'm a long time BibleWorks user and have recently purchased a Mac and Accordance. One of the features that I'm used to in BibleWorks and would like to know how to implement in Accordance, if possible, is related to the display, copy, and pasting of text from Accordance into Word.

In my text window, I like to have a slightly larger font than I use in Word. However, in my word processor where I'm actually working or creating a document, I like to use a 12pt. font. However, it seems that I can't set any type of "copy text" options that would allow me to set the text style that would be moved to the clipboard when I hit 'copy'. Therefore, if my text display is at 14pt. in Accordance and I paste into Word the text will display as 14pt. Obviously, this is how it should seem to work. However, it would be great if we could set copy options. For example, if I could set an option to strip the hit highlighting from the text when I copy it I wouldn't have to reformat the text when I dropped it into Word. Or, if I could set the default copy font to Times New Roman, but display it in Accordance as something else, then I wouldn't have to burn time reformatting the text for my actual document. Does this make sense? If so, is there a way to do this or would this be a feature request?

Thanks!

Jeremy

#2 David Leighton

David Leighton

    Member

  • Active Members
  • Pip
  • 11 posts
  • Location:keswick, United Kingdom

Posted 26 May 2005 - 05:46 AM

The easiest way to deal with this is to use the paste special feature in word.

Select your test in accordance and copy it. Then go to work and select paste special from the edit menu, and then when you have the options select unformatted text. The text pasted in then takes on the formatting that is current in the word document.
David Leighton

12" PowerBook, OS X 10.5.8, Accordance 8.2.3

#3 jarcher

jarcher

    Silver

  • Active Members
  • PipPipPip
  • 150 posts
  • Gender:Male
  • Location:Minnesota
  • Accordance Version:8.x

Posted 26 May 2005 - 07:32 AM

Excellent! It worked. You made my day.

Shalom,

Jeremy

#4 Joe Weaks

Joe Weaks

    Platinum

  • Active Members
  • PipPipPipPipPip
  • 1,037 posts
  • Gender:Male
  • Location:Raytown, MO (outside KC)
  • Interests:I like things that are Orange, and possibly Blue.
  • Accordance Version:8.x

Posted 26 May 2005 - 11:27 AM

The easiest way to deal with this is to use the paste special feature in word.

Select your test in accordance and copy it.† Then go to work and select paste special from the edit menu, and then when you have the options select unformatted text.† The text pasted in then takes on the formatting that is current in the word document.


If you do this with any frequency, it is worth it to create a macro in Word and assign is a key combo, so that you can do this quicker.

Have some text ready to paste, and then under Tools/Macros in the Word menu, select "Record Macro". Give the macro a name like "PasteUnformatted" and then click the keyboard button to assign a key combination (something like Command+Control+v), or the Tools button to put a button on a toolbar.
Then you can paste special unformatted text and stop the recording.


FYI, this recording will create a macro that you can see in the VB editor, something like:
Sub PastUnformatted()
'
' PastUnformatted Macro
' Macro recorded 5/26/05
'
 † †Selection.PasteAndFormat (wdPasteDefault)
End Sub

Aha! A bug in the Word Macro Record... see followup below for the simple fix:

Edited by Joe Weaks, 26 May 2005 - 12:49 PM.

Joe Weaks
The Macintosh Biblioblog

Sometimes I'm so helpful even I can't stand it.

#5 jarcher

jarcher

    Silver

  • Active Members
  • PipPipPip
  • 150 posts
  • Gender:Male
  • Location:Minnesota
  • Accordance Version:8.x

Posted 26 May 2005 - 12:25 PM

Thanks, I can't get it to work though. Must be a problem with my Macro. It seems to record fine, it just records it as a regular 'Paste' not a 'Paste Unformatted.'

Edited by jarcher, 26 May 2005 - 01:28 PM.


#6 Joe Weaks

Joe Weaks

    Platinum

  • Active Members
  • PipPipPipPipPip
  • 1,037 posts
  • Gender:Male
  • Location:Raytown, MO (outside KC)
  • Interests:I like things that are Orange, and possibly Blue.
  • Accordance Version:8.x

Posted 26 May 2005 - 12:53 PM

Oops, I should have actually read the macro text. Notice how the macro text says wordpasteDefault... this is not what we want. So, once you have created the macro, go to Tools/Macros/Visual Basic Editor.
Now, this new view might be foreign to you, but suffice it to say that this is where the documents containing the Visual Basic code is found. All you should have to do is scroll down to the bottom of the document and find the macro as I showed it to you above. Then, repleace the line:

Selection.PasteAndFormat (wdPasteDefault)

with

Selection.PasteSpecial DataType:=wdPasteText

then just Save, and Quit and Return to Word. All should be working correclty now. Let us know if it doesn't.
Joe Weaks
The Macintosh Biblioblog

Sometimes I'm so helpful even I can't stand it.

#7 DavidDoyle

DavidDoyle

    Silver

  • Active Members
  • PipPipPip
  • 116 posts
  • Gender:Male
  • Accordance Version:10.x

Posted 26 May 2005 - 01:27 PM

Jeremy,

If you are using Word 2004 (I'm not sure about previous versions) you get a little clipboard icon when you paste text. If you click that you can choose Source or Destination formatting or plain text.
I use that because I forget to set stuff before I put the text in my Word doc.

Another option from the macros, if you should so choose.

Blessings,

<>< Dave

#8 jarcher

jarcher

    Silver

  • Active Members
  • PipPipPip
  • 150 posts
  • Gender:Male
  • Location:Minnesota
  • Accordance Version:8.x

Posted 26 May 2005 - 01:27 PM

Great. I thought I may need to do something like that. I am thankful for the help. I hope this was useful for others as well.

Peace,

Jeremy

#9 Joe Weaks

Joe Weaks

    Platinum

  • Active Members
  • PipPipPipPipPip
  • 1,037 posts
  • Gender:Male
  • Location:Raytown, MO (outside KC)
  • Interests:I like things that are Orange, and possibly Blue.
  • Accordance Version:8.x

Posted 26 May 2005 - 01:31 PM

A new posting should go into the Tips forum by Helen. It has been a common question over the years, Jeremy.
I don't know why Accordance doesn't have a "Copy As... Unformatted" option.
Joe Weaks
The Macintosh Biblioblog

Sometimes I'm so helpful even I can't stand it.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users