Jump to content


Photo

Typing Hebrew into a notes file


  • Please log in to reply
6 replies to this topic

#1 luoar

luoar

    Silver

  • Active Members
  • PipPipPip
  • 133 posts
  • Gender:Not Telling
  • Accordance Version:10.x

Posted 21 February 2013 - 12:45 AM

I want to use my notes file for both English and Hebrew. It is easy enough to switch to Hebrew using cmd-alt 4. But then getting back to English is the chore of having to scroll the fonts menu. Oddly the size of my English font (when I at last manage to find it) is changed from the default 16 to 24 which was the size of the Hebrew font. This is no problem if one uses Hebrew infrequently but it is problematic when one is typing a lot of Hebrew.

 

Is there an easier way?  See attachments.

 

rari



#2 Ken Han

Ken Han

    Platinum

  • Active Members
  • PipPipPipPipPip
  • 518 posts
  • Gender:Male
  • Location:San Diego, CA
  • Accordance Version:10.x

Posted 21 February 2013 - 02:35 AM

You may be better off switching the keyboard input source instead of using the popup character palette. You can do this from System Preferences > Language & Text and then choose the Input Sources tab and enable an appropriate Hebrew keyboard input source. 

 

As to the font size, this is the behavior for all (I think) apps that the font size is inherited from the previous character. So if you were typing in Hebrew in size 24, when you switch to English the size will stay the same as your Hebrew font. One way I get around is first typing out the English text first, leaving at least two spaces where the Hebrew needs to go. Then I type inside the 2 spaces I left before in Hebrew / Greek, and then I can change the size of that portion only while leaving the rest of the sentence at the right size.



#3 luoar

luoar

    Silver

  • Active Members
  • PipPipPip
  • 133 posts
  • Gender:Not Telling
  • Accordance Version:10.x

Posted 21 February 2013 - 05:40 AM

Ken,

Thank you. Unfortunately using a Hebrew keyboard does not help because once one has changed form English to Hebrew the only way to get back to English in Accordance is to manually change the font.

Raoul



#4 Julie Falling

Julie Falling

    Platinum

  • Active Members
  • PipPipPipPipPip
  • 1,134 posts
  • Gender:Female
  • Location:Tennessee
  • Interests:Numerous!
  • Accordance Version:10.x

Posted 21 February 2013 - 08:24 AM

I run into this same issue with Helena, which also has to be larger.  I type my English font on both sides of where I want to insert the Greek, then insert the Greek into the middle of the English text.  I think this is what Ken was describing.  That way you already have your English font in the preferred size on the other side of the Greek or Hebrew.

 

Another thing that makes switching fonts easier is in the Accordance Preferences.  Check the box shown.

 

Attached File  Fonts.png   65.53KB   8 downloads

 

This will put the fonts you use most at the top of the list so that you don't have to wade through them all.  The font size issue is not just in Accordance.  It's in Mail, Pages, etc.  For all I know it's the same in Word (really don't like MS).


  • luoar likes this

Julia Falling

 

Accordance 10

MacBook Air Mavericks

Mac mini Mavericks

iPad Air iOS 7

 

 


#5 James Tucker

James Tucker

    Platinum

  • Active Members
  • PipPipPipPipPip
  • 644 posts
  • Gender:Not Telling
  • Accordance Version:10.x

Posted 21 February 2013 - 10:00 AM

The quickest way I have found to overcome this issue is to use a third party tool, Keyboard Maestro. Nisus Writer Pro, a Mac word processor, allows one, when switching to a keyboard, to associate a font with a Keyboard. Thus, Estrangelo = Syriac Input; SBL Hebrew = Hebrew Input. It's a very quick and efficient way to switch between languages and have the font change as well.

 

Meanwhile, what I have done is to write a macro with Keyboard Maestro. Upon calling the Macro, I get a option window with a numbered list. I can then switch back and forth for my fonts. Here is what it looks like:

 

 

I then just type 1 - 5 to get the font, size, and Keyboard Input.


  • luoar likes this

#6 Joel Brown

Joel Brown

    Administrator

  • Admin
  • 2,512 posts
  • Gender:Male
  • Location:Houston, TX
  • Accordance Version:10.x

Posted 22 February 2013 - 04:10 PM

Sorry about the issues, rari.  The input of the user notes based on system keyboard used to be working properly, but seems to have been broken.  Not sure yet why, but we'll take a look and fix it as soon as possible.

 

Once its working, you should be able to very easily switch fonts, size, color, etc. by simply changing the system keyboard.


  • luoar likes this
Joel Brown

By day: Consultant for Oaktree
By night: Freelance Trombonist and Private Instructor

#7 luoar

luoar

    Silver

  • Active Members
  • PipPipPip
  • 133 posts
  • Gender:Not Telling
  • Accordance Version:10.x

Posted 22 February 2013 - 11:12 PM

Thank you so much Joel.

Edited by luoar, 22 February 2013 - 11:13 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users