Jump to content


Photo

Apostrophes are not maintained from Edit Window to User Tool Window

user tool apostrophe formatting copy-paste

  • Please log in to reply
3 replies to this topic

#1 TheMinibishop

TheMinibishop

    Member

  • Members
  • Pip
  • 8 posts
  • Accordance Version:10.x

Posted 02 March 2013 - 04:37 PM

Greetings. 

 

I have a collection of New Testament Briefs that I submitted for a class in seminary.  The purpose of the assignment was to create a one page overview of New Testament texts for our future reference.  I wanted to use them in Accordance and thought a User Tool would be the best way to go.

 

I opened the document in Pages, copied, and then pasted them in the Edit Window in Accordance. I added links, adjusted fonts, and everything looked well.  After updating, I found that word's with apostrophes did not look right.  What's even more odd, is that a title and subtitle just above was inserted the same way with no problems.  I'm including a screenshot to illustrate what I mean.

 

I'm grateful for the assistance.

Attached Files



#2 Joel Brown

Joel Brown

    Administrator

  • Admin
  • 2,748 posts
  • Gender:Male
  • Location:Houston, TX
  • Accordance Version:10.x

Posted 02 March 2013 - 05:43 PM

I believe those quotes are unicode characters, which aren't supported in our User Tools (at least, for now!).  You can probably do a find and replace, to replace the unicode smart quotes with either dumb quotes (") or ascii smart quotes (option-[ and shift-option-[).  Or, you can ensure your source document is in mac roman before copying and pasting to Accordance, but I'm not sure if thats possible in Pages.


Joel Brown

By day: Consultant for Oaktree
By night: Freelance Trombonist and Private Instructor

#3 TheMinibishop

TheMinibishop

    Member

  • Members
  • Pip
  • 8 posts
  • Accordance Version:10.x

Posted 02 March 2013 - 09:28 PM

Thanks.  That was helpful, if not painstaking to accomplish.  Perhaps there's a workaround coming soon...



#4 Joel Brown

Joel Brown

    Administrator

  • Admin
  • 2,748 posts
  • Gender:Male
  • Location:Houston, TX
  • Accordance Version:10.x

Posted 03 March 2013 - 12:12 AM

Well, don't forget that we have a Find and Replace when editing user content - Command-F, or under the Search menu.  Then put in the gibberish characters on the left 'Find' section and the appropriate smart or dumb quote on the right Replace section, and it can update it all automatically.

 

We hope to support full Unicode in User Tools, but until then, using Find/Replace shouldn't be too painstaking of a workaround.


Joel Brown

By day: Consultant for Oaktree
By night: Freelance Trombonist and Private Instructor





Also tagged with one or more of these keywords: user tool, apostrophe, formatting, copy-paste

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users