Jump to content


Photo

Unable to minimize zone


  • Please log in to reply
14 replies to this topic

#1 Daniel Saunders

Daniel Saunders

    Member

  • Active Members
  • Pip
  • 34 posts
  • Gender:Male
  • Location:Brisbane
  • Accordance Version:10.x

Posted 26 March 2013 - 06:51 PM

This is a little bug that I seem to run into lots.

 

If I maximise* a zone (often for me it's a zone that I have lexicons in) and then I click on a reference in the lexicon, Accordance then opens up my default bible in a maximised zone. When I try and close/minimise the zone, I get an error message 'You cannot minimize this zone because one or more of Text (XXX) panes are two small).

 

The only way I can get back to my lexicons and texts is to close the window (click red button in top left) and then reopen the workspace.

 

Is this a bug, or is there something that I'm doing wrong?

 

Thanks,

Daniel

 

 

 

*Sorry, for spelling correctly  ;)

Attached Files



#2 Ken Simpson

Ken Simpson

    Platinum

  • Accordance
  • 1,581 posts
  • Gender:Male
  • Location:Sydney, Australia
  • Interests:Astronomy
    Archaeology
    Physics
    Hebrew and Greek
    Papyrology
    Orthopædic Surgery
  • Accordance Version:10.x

Posted 26 March 2013 - 07:05 PM

Hi Daniel, it doesn't happen for me the way you describe. Minimising works fine. Have you tried closing the tab instead though?

 

Like this

 

Attached File  Accordance.png   101.14KB   14 downloads

 

(this is my bible pane amplified from a maximised lexicon entry)


Regards
Ken
Lead Australian Accordance Demonstrator

Administrator, Accordance Exchange

Assistant Minister, Summer Hill Church


#3 Daniel Saunders

Daniel Saunders

    Member

  • Active Members
  • Pip
  • 34 posts
  • Gender:Male
  • Location:Brisbane
  • Accordance Version:10.x

Posted 26 March 2013 - 07:13 PM

Hi Ken,

 

Thanks for the response.

 

For some reason I don't have a tab to close. I've just reproduced the bug again.

 

Steps:

  1. Maximize a zone with just lexicons (see attachment).
  2. Click on a bible reference (with the magnifying glass cursor). This opens my default text (ESVS) maximized with the verse in it.
  3. Attempt to get back to the Lexicon by clicking the minimize button. This gives me the error that I posted above.

I'm using version 10.1.4.

Attached Files



#4 Ken Simpson

Ken Simpson

    Platinum

  • Accordance
  • 1,581 posts
  • Gender:Male
  • Location:Sydney, Australia
  • Interests:Astronomy
    Archaeology
    Physics
    Hebrew and Greek
    Papyrology
    Orthopædic Surgery
  • Accordance Version:10.x

Posted 26 March 2013 - 07:21 PM

Hi Daniel,

 

Hmmm - it's hard when I can't reproduce it. I think I'll have to call in the help of the clever people.

 

Joel, are you there?


Regards
Ken
Lead Australian Accordance Demonstrator

Administrator, Accordance Exchange

Assistant Minister, Summer Hill Church


#5 Ken Simpson

Ken Simpson

    Platinum

  • Accordance
  • 1,581 posts
  • Gender:Male
  • Location:Sydney, Australia
  • Interests:Astronomy
    Archaeology
    Physics
    Hebrew and Greek
    Papyrology
    Orthopædic Surgery
  • Accordance Version:10.x

Posted 26 March 2013 - 07:47 PM

Just so you can see, using 10.1.3 (in Lion on my MBP) this is what happens when I do your steps

 

Attached File  Workspace-2.png   993.85KB   8 downloads Attached File  Workspace-3.png   287.76KB   9 downloads Attached File  Maximised.png   105.05KB   10 downloads

 

Wait - Eureka! I can do it. I turned on the option to Hide tab area if only a single tab

 

Attached File  Preferences.png   75.86KB   10 downloads

 

I couldn't reproduce the error, but at least could reproduce the appearance. If you can, turn off this option and see if that alleviates the issue. It's still probably an issue that we should look at though.

 


Edited by Ken Simpson, 26 March 2013 - 07:55 PM.

Regards
Ken
Lead Australian Accordance Demonstrator

Administrator, Accordance Exchange

Assistant Minister, Summer Hill Church


#6 Timothy Jenney

Timothy Jenney

    Platinum

  • Accordance
  • 1,567 posts
  • Gender:Male
  • Location:sunny Winter Haven, FL
  • Interests:a good cup of coffee, sci-fi, playing bass, listing to jazz and the blues, camping, fishing and the great outdoors
  • Accordance Version:10.x

Posted 26 March 2013 - 07:48 PM

I have seen this happen when there are too many zones for the size of the monitor. It does happen sometimes, especially when the workspace has been saved on a larger monitor, then opened on a smaller one. Try eliminating a zone, preferably the smallest one with the ESVS text in it. If you don't want to eliminate the text entirely, turn it into a tab and place it behind another text.

 

See if that works.


Edited by Timothy Jenney, 26 March 2013 - 07:49 PM.

Blessings,
"Dr. J"

Timothy P. Jenney, Ph. D.
"Lighting the Lamp" Host and Producer

 

Early 2011 17" MBP (8,3), 2.3 GHz Quad core, 16 GB RAM, Mercury 6G 480 SSD + 1.5 TB HD, OSX 10.10, Yosemite

iPhone 6 plus 64 GB iOS 8.1


#7 Daniel Saunders

Daniel Saunders

    Member

  • Active Members
  • Pip
  • 34 posts
  • Gender:Male
  • Location:Brisbane
  • Accordance Version:10.x

Posted 26 March 2013 - 07:54 PM

Hi Ken,

 

Yep, that switch has sort of fixed the issue.

 

Now when I have the ESV text maximised (due to amplifying a reference in BDAG) I can see the tab. If I click the minimize zone button, I get the same error. But if I click the 'close tab' button I get the error message, and when I close the error dialog, I go back to viewing the zone with the lexicons.

 

That's better than what I had (I don't have to close the workspace and start all my searches from scratch), but still something to be investigated.

 

Daniel



#8 Ken Simpson

Ken Simpson

    Platinum

  • Accordance
  • 1,581 posts
  • Gender:Male
  • Location:Sydney, Australia
  • Interests:Astronomy
    Archaeology
    Physics
    Hebrew and Greek
    Papyrology
    Orthopædic Surgery
  • Accordance Version:10.x

Posted 26 March 2013 - 07:57 PM

would you like to share your workspace with us and we'll have a look? (ie save it and post the saved file)


Regards
Ken
Lead Australian Accordance Demonstrator

Administrator, Accordance Exchange

Assistant Minister, Summer Hill Church


#9 Daniel Saunders

Daniel Saunders

    Member

  • Active Members
  • Pip
  • 34 posts
  • Gender:Male
  • Location:Brisbane
  • Accordance Version:10.x

Posted 26 March 2013 - 08:00 PM

Here it is.

Attached Files



#10 Ken Simpson

Ken Simpson

    Platinum

  • Accordance
  • 1,581 posts
  • Gender:Male
  • Location:Sydney, Australia
  • Interests:Astronomy
    Archaeology
    Physics
    Hebrew and Greek
    Papyrology
    Orthopædic Surgery
  • Accordance Version:10.x

Posted 26 March 2013 - 09:22 PM

Thanks - I can reproduce it with this.

 

If you re-enable the tabs preference above, you can still get out if ti by pressing CMD-W - albeit with the warning.

 

I think Joel will need to look at the logic.


Edited by Ken Simpson, 26 March 2013 - 09:24 PM.

Regards
Ken
Lead Australian Accordance Demonstrator

Administrator, Accordance Exchange

Assistant Minister, Summer Hill Church


#11 Joel Brown

Joel Brown

    Administrator

  • Admin
  • 2,760 posts
  • Gender:Male
  • Location:Houston, TX
  • Accordance Version:10.x

Posted 26 March 2013 - 10:28 PM

Apparently I have a reputation of fixing things now!

 

Thanks for posting your workspace, Daniel.  I can also confirm the issue.  Basically what's happening is that when you click the bible reference, Accordance opens a new zone to display the chosen verses in.  The bug/tweak needed is that due to Instant Details being on the bottom, Accordance tries to open it in a less-ideal location, so there isn't enough room to re-minimize everything.  There are a couple of solutions here:

 

1) [Most ideal] Click on a verse reference when it isn't magnified, to have Accordance open your text window.  Then, drag it somewhere nice and stable, perhaps as a tab somewhere in another zone, or in a small zone in a corner, or something.  Now, when you click references, this tab will recycle, so everything should be good when re-minimizing it all.

2) Make your lexicon zone just a little wider.  This will also help Accordance put the context zone in a little nicer place.

 

A couple of interesting things, though.  FIrst, we'll take a look to see why the context is appearing in a less ideal location for minimizing.  Second, the logic that occurs when closing the ESVS tab via Command-W is a bit funny with its error messages.  Finally, we are also doing a bit funny logic for the closing of a zone/tab in magnify.  So, we'll take a look at all this, thanks!  It should be better for 10.1.5.  In the meantime, I hope those workarounds help!


Joel Brown

By day: Consultant for Oaktree
By night: Freelance Trombonist and Private Instructor

#12 Ken Simpson

Ken Simpson

    Platinum

  • Accordance
  • 1,581 posts
  • Gender:Male
  • Location:Sydney, Australia
  • Interests:Astronomy
    Archaeology
    Physics
    Hebrew and Greek
    Papyrology
    Orthopædic Surgery
  • Accordance Version:10.x

Posted 27 March 2013 - 01:27 PM

Thanks Joel. A well-deserved reputation it seems...

#13 Daniel Saunders

Daniel Saunders

    Member

  • Active Members
  • Pip
  • 34 posts
  • Gender:Male
  • Location:Brisbane
  • Accordance Version:10.x

Posted 27 March 2013 - 04:46 PM

thanks for all those workaround options.

 

For now, I'm happy enough with just closing the tab and getting the error message. Thanks each of you for taking the time to look into this bug report - hope it's not too painful to squash.



#14 Ken Simpson

Ken Simpson

    Platinum

  • Accordance
  • 1,581 posts
  • Gender:Male
  • Location:Sydney, Australia
  • Interests:Astronomy
    Archaeology
    Physics
    Hebrew and Greek
    Papyrology
    Orthopædic Surgery
  • Accordance Version:10.x

Posted 27 March 2013 - 05:03 PM

Hi Daniel,

were you at the seminar I did at QTC last year? Your name doesn't ring a bell...


Regards
Ken
Lead Australian Accordance Demonstrator

Administrator, Accordance Exchange

Assistant Minister, Summer Hill Church


#15 Daniel Saunders

Daniel Saunders

    Member

  • Active Members
  • Pip
  • 34 posts
  • Gender:Male
  • Location:Brisbane
  • Accordance Version:10.x

Posted 27 March 2013 - 05:12 PM

No, I wasn't there. I'm only part-time at QTC. I've previously studied at Moore, and did a training seminar there a few years back (but I don't think that you were there).






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users