Jump to content


Photo

maximizable Accordance windows


  • Please log in to reply
8 replies to this topic

#1 Harry Hoffner

Harry Hoffner

    Bronze

  • Active Members
  • PipPip
  • 52 posts
  • Location:Chicago-area, Illinois
  • Interests:Emeritus Professor, University of Chicago. Interests Ancient Near Eastern languages and history; biblical studies.

Posted 04 August 2006 - 08:27 PM

Most windows in Accordance have the standard Macintosh configuration, including the invaluable three colored buttons in the upper lefthand corner (dismiss, minimize and maximize). I don't know how many times the maximize button has gotten be out of a jam when I have somehow moved the window to a position where I could not access the resize corner (lower righthand). Unfortunately not all Accordance windows have this configuration. One that I wish did have it is the Instant Details window. It happens that now my Instant Details window has become extended beyong the righthand edge of my laptop screen, so that I cannot resize it. the particular handicap of not being able to do so, is that the last 2 or 3 letters of any text displayed in it are now off-screen and therefore invisible. The little window has one "button" -- for dismiss. But when reactivated, it reappears in the same partially obscured position. Is there any way to make it return to what must have been the "default" position? And has any thought been given to equipping that window with a maximize button to return it to a default position when it has gotten misaligned?
Harry Hoffner. Emeritus Professor, The Oriental Institute of the University of Chicago. Founder & Editor of The Hittite Dictionary of the Oriental Institute of the University of Chicago.


#2 David Lang

David Lang

    Platinum

  • Accordance
  • 754 posts
  • Gender:Male
  • Location:Mount Dora, FL
  • Interests:Accordance development, writing, spending time with my wife and five kids
  • Accordance Version:9.x

Posted 04 August 2006 - 08:39 PM

Professor Hoffner,

Try reducing the resolution of your screen (to say, 800 X 600), and then changing it back to the standard resolution. That will bring the Instant Details box back well within the margins of the screen.

Hope this helps.
Sincerely,
David Lang
Accordance Developer
http://www.accordancebible.com

Author:
Feet to Follow, Eyes to See
http://feettofollow.wordpress.com

Macs in the Ministry
http://www.macsinministrybook.com

Leader of the "Lang Gang"
http://www.langgangland.com
http://twitter.com/DavidAllenLang

#3 jpkang

jpkang

    Platinum

  • Active Members
  • PipPipPipPipPip
  • 577 posts
  • Gender:Male
  • Location:Seattle, WA
  • Interests:Comparative Semitics; ancient Hebrew semantics; Hebrew syntax; history and religion of ancient Israel; history of interpretation.
  • Accordance Version:10.x

Posted 05 August 2006 - 05:41 AM

Try reducing the resolution of your screen (to say, 800 X 600), and then changing it back to the standard resolution. That will bring the Instant Details box back well within the margins of the screen.

In Apple menu > System Preferences > Displays, just in case there is a question about how to do this!
J. P. Kang, Ph.D. (Bible)

#4 Harry Hoffner

Harry Hoffner

    Bronze

  • Active Members
  • PipPip
  • 52 posts
  • Location:Chicago-area, Illinois
  • Interests:Emeritus Professor, University of Chicago. Interests Ancient Near Eastern languages and history; biblical studies.

Posted 05 August 2006 - 07:33 AM

Professor Hoffner,

Try reducing the resolution of your screen (to say, 800 X 600), and then changing it back to the standard resolution. That will bring the Instant Details box back well within the margins of the screen.

Hope this helps.


I'm afraid it didn't. :(


By the way, what is the "standard resolution"? 1440x960 (the highest) was -- I think -- what it was before I tried your switch. How does one discover what is "standard" on a Powerbook 15"?

More ideas???
Harry Hoffner. Emeritus Professor, The Oriental Institute of the University of Chicago. Founder & Editor of The Hittite Dictionary of the Oriental Institute of the University of Chicago.


#5 jarcher

jarcher

    Silver

  • Active Members
  • PipPipPip
  • 150 posts
  • Gender:Male
  • Location:Minnesota
  • Accordance Version:8.x

Posted 05 August 2006 - 07:47 AM

Professor Hoffner,

If you can see the dismiss button on the instant details box you may be able to move the entire box back into the rest of the screen by clicking and dragging just below the dismiss button on the grey sidebar.

Hope this works!

Jeremy

#6 Harry Hoffner

Harry Hoffner

    Bronze

  • Active Members
  • PipPip
  • 52 posts
  • Location:Chicago-area, Illinois
  • Interests:Emeritus Professor, University of Chicago. Interests Ancient Near Eastern languages and history; biblical studies.

Posted 05 August 2006 - 07:35 PM

Professor Hoffner,

If you can see the dismiss button on the instant details box you may be able to move the entire box back into the rest of the screen by clicking and dragging just below the dismiss button on the grey sidebar.

Hope this works!

Jeremy

That was the first thing I tried. But the dismiss button is already on the left edge of the scree. The problem is that the total width of the Instant Details window is greater by about a few cm than the screen width.
Harry Hoffner. Emeritus Professor, The Oriental Institute of the University of Chicago. Founder & Editor of The Hittite Dictionary of the Oriental Institute of the University of Chicago.


#7 jpkang

jpkang

    Platinum

  • Active Members
  • PipPipPipPipPip
  • 577 posts
  • Gender:Male
  • Location:Seattle, WA
  • Interests:Comparative Semitics; ancient Hebrew semantics; Hebrew syntax; history and religion of ancient Israel; history of interpretation.
  • Accordance Version:10.x

Posted 05 August 2006 - 10:39 PM

Quitting Accordance, deleting your General preference file in ~/Library/Preferences/Accordance Preferences/ and restarting will cause the default search window and palettes to return to their default locations, but you will probably have to respecify various preferences (i.e., splash screens on text open, etc.). If you have a lot of windows open that you would like to keep, you can try File > Save Session... and then reopen that session after you do the above.

By any chance, did you use Accordance with your laptop hooked up to an external display or projector that extended your desktop, and which allowed you to resize the ID window wider than your built-in display?

On your other question, the maximum resolution in the Displays prefpane is usually the default for LCDs, because that will mean a 1:1 mapping of pixels and maximum sharpness; lower resolutions will either result in 1:1 with a black border or else some stretching or extrapolation will occur to fill up the screen, usually with some visible artifacts.
J. P. Kang, Ph.D. (Bible)

#8 Rosemary Brown

Rosemary Brown

    Member

  • Members
  • Pip
  • 4 posts

Posted 22 February 2007 - 09:55 AM

Deleting the General Preference file was the only solution that worked for me. But I added some steps to make it easier to reconstruct all my preferences. Here's how I did it:

(1) I saved the session with my window positions, as advised.

(2) Then I opened the Accordance Preferences from the "Accordance" menu.

(3) I opened each preference pane one-by-one and took a screen snapshot of my settings (Command-Shift-4). I numbered the ".png" files in the same order that the panes appeared in the Accordance Preference window (General, Appearance, Text Display, etc.). My screen snapshots were called "Picture 01.png," "Picture 02.png," etc.

(4) I created a folder on my desktop to move all these pictures into, and dragged them in.

(5) I quit Accordance and then deleted the General Preference file, as advised.

(6) Then I reopened Accordance and went through the initial setup, which you are prompted to do. I selected all the default options, since I had saved my own preferences and knew I would restore them later.

(7) Then I quit and re-launched Accordance. I went back to the Accordance menu and selected Preferences…. One-by-one, I opened my screen snapshots, positioned them side-by-side with the actual Preference panes, and used them as a guide to restore the preferences I had originally created for each preference category.

Now I'm back and running. The pesky Instant Details Box is finally the size I like, and it doesn't extend off the right side of my screen.

#9 Andy Crim

Andy Crim

    Bronze

  • Active Members
  • PipPip
  • 66 posts
  • Gender:Male
  • Location:Iowa
  • Accordance Version:9.x

Posted 22 February 2007 - 10:24 AM

I had the same problem and finally realized that I had extended the instant details box while using an external monitor. The only solution apart from trashing the general preferences was to reconnect to an external monitor and resize the instant details box to a shorter length.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users