Jump to content


Photo

Font menu glitch


  • Please log in to reply
7 replies to this topic

#1 Alistair

Alistair

    Gold

  • Active Members
  • PipPipPipPip
  • 478 posts
  • Gender:Male
  • Accordance Version:10.x

Posted 10 August 2006 - 04:26 AM

In the Set Text Pane display window (command-T) the font menu lists fonts that have not been activated under Font Book. Selecting these fonts makes no difference to the displayed text.

Using 7.0.3 on 10.4.7.

#2 jpkang

jpkang

    Platinum

  • Active Members
  • PipPipPipPipPip
  • 577 posts
  • Gender:Male
  • Location:Seattle, WA
  • Interests:Comparative Semitics; ancient Hebrew semantics; Hebrew syntax; history and religion of ancient Israel; history of interpretation.
  • Accordance Version:10.x

Posted 10 August 2006 - 10:45 AM

Changes you make through Font Book during an Accordance session will not register until you quit and restart Accordance (I think it caches all the active fonts on launch, but doesn't update their status "live"). I just tried disabling "Hoefler Text" with Accordance running, confirmed it was still in the font list, then quit and restarted Accordance, and it was no longer there in the Set Text Pane Display sheet.
J. P. Kang, Ph.D. (Bible)

#3 Alistair

Alistair

    Gold

  • Active Members
  • PipPipPipPip
  • 478 posts
  • Gender:Male
  • Accordance Version:10.x

Posted 10 August 2006 - 11:53 AM

Changes you make through Font Book during an Accordance session will not register until you quit and restart Accordance (I think it caches all the active fonts on launch, but doesn't update their status "live"). I just tried disabling "Hoefler Text" with Accordance running, confirmed it was still in the font list, then quit and restarted Accordance, and it was no longer there in the Set Text Pane Display sheet.


That's smart thinking but the fonts were deactivated to begin with.

I opened Font Book to double check.

#4 jpkang

jpkang

    Platinum

  • Active Members
  • PipPipPipPipPip
  • 577 posts
  • Gender:Male
  • Location:Seattle, WA
  • Interests:Comparative Semitics; ancient Hebrew semantics; Hebrew syntax; history and religion of ancient Israel; history of interpretation.
  • Accordance Version:10.x

Posted 10 August 2006 - 12:15 PM

Can you name a specific font or fonts with which you're seeing this behavior? Some fonts are less optional than others for OS X, and I wonder if it has anything to do with that list...
J. P. Kang, Ph.D. (Bible)

#5 Alistair

Alistair

    Gold

  • Active Members
  • PipPipPipPip
  • 478 posts
  • Gender:Male
  • Accordance Version:10.x

Posted 11 August 2006 - 04:07 AM

Can you name a specific font or fonts with which you're seeing this behavior? Some fonts are less optional than others for OS X, and I wonder if it has anything to do with that list...


Thanks JP, but I've decided that this is an OS X font problem and not an Accordance problem. My font book settings are not being saved and when I restart the computer (as I did this morning) ALL my fonts (c.300 families!) are activated.

I have a base set of fonts for everyday use, but somehow some fonts that are not in this base set are being activated. In Font Book, however, these fonts are identified as being NOT activated, even though in reality, they ARE.

How annoying is that?! I might just go back to using Linotype FontExplorer for font management, except Pages' font palette is tied to the Apple Font Book for font families, categories, favourites, and recently used fonts.

*sigh*

Edited by Alistair, 11 August 2006 - 04:09 AM.


#6 jpkang

jpkang

    Platinum

  • Active Members
  • PipPipPipPipPip
  • 577 posts
  • Gender:Male
  • Location:Seattle, WA
  • Interests:Comparative Semitics; ancient Hebrew semantics; Hebrew syntax; history and religion of ancient Israel; history of interpretation.
  • Accordance Version:10.x

Posted 11 August 2006 - 10:19 AM

Thanks JP, but I've decided that this is an OS X font problem and not an Accordance problem. My font book settings are not being saved and when I restart the computer (as I did this morning) ALL my fonts (c.300 families!) are activated.

300!? (are you a graphic designer?)

I honestly wish I could run my system with a dozen fonts, but it seems near impossible these days... It makes me wonder how many seconds/minutes/hours/days people have wasted in the last decade scrolling through font menus.

Hope you find a good workaround for your particular set of issues!
J. P. Kang, Ph.D. (Bible)

#7 Alistair

Alistair

    Gold

  • Active Members
  • PipPipPipPip
  • 478 posts
  • Gender:Male
  • Accordance Version:10.x

Posted 14 August 2006 - 05:51 AM

:)

Edited by Alistair, 03 May 2008 - 11:52 AM.


#8 Mick Matousek

Mick Matousek

    Silver

  • Active Members
  • PipPipPip
  • 170 posts
  • Gender:Male
  • Accordance Version:10.x

Posted 14 August 2006 - 09:02 AM

Thanks JP, but I've decided that this is an OS X font problem and not an Accordance problem. My font book

One MacOSX utility that has solved some obtuse font issues is Font Finagler It deletes font caches which can get corrupted or not properly updated. The shareware cost is $10. With 3000 fonts, this utility should be handy more than once. When I had thousands of fonts installed, I noticed a slowdown opening new texts in Accordance search windows. Also, you might consider a separate user account with the entire thousands of fonts, and another user account with simply hundreds.

Edited by Mick Matousek, 14 August 2006 - 09:03 AM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users