Jump to content


Photo

User bible text format


  • Please log in to reply
13 replies to this topic

#1 Daniel Semler

Daniel Semler

    Mithril

  • Active Members
  • PipPipPipPipPipPip
  • 2,011 posts
  • Gender:Male
  • Accordance Version:11.x

Posted 27 January 2013 - 02:18 AM

Hi ya,

 

  I'm doing translation exercises from the gospels and putting them in user bible format so I can import the "bible" into Acc where I would then be able to do comparisons with other texts. So far so good and I got it off the ground. But inevitably a question or two. I noticed that the chapter number is not appearing next to my translation. Would this work if I was using paragraphing ? Should I be able to see what one normally sees for a regular bible - ie. that the Book name, the chapter number and the verse number appear at the beginning of each para. and thereafter just the verse numbers ? I tried adding paragraph markers to the text - currently only John 1:6 and 1:7 for testing.

 

I also tried adding John 1:1 with bogus text and a paragraph marker because of one reading I made of this doc :

 

You can use any text editor software to convert styled text to plain text with these codes.

  • Paragraph marks are denoted by use of the paragraph marker (¶) with a single space on each side. If paragraphs are used, a paragraph marker must appear after the reference of the first verse of the first book, otherwise Accordance assumes there are no paragraphs in the text. The marker should also appear at reasonable intervals throughout the text.

But to no avail. I appear to get no chapter numbers. I've attached a screen grab - on the left is the UBS 4 with Book Ch:verse at each para and verses within para's and then on the right my fragment with only the Book initially with either chapter or verse, I cannot tell which, some missing verses - because I haven't translated those, and the 6 and 7. And both of those have paragraph markers in them as per the doc, ie. after the chapter:verse marker with a space on either side, as below :

 

John 1:1 ¶ The first verse for testing.
6 ¶ A man came, having been sent from God, his name is John.
7 ¶ He came ....

 

Thanx

D

Attached Files


Sola lingua bona est lingua mortua

ἡ μόνη ἀγαθὴ γλῶσσα γλῶσσα νεκρὰ ἐστιν

lišanu ēdēnitu damqitu lišanu mītu

 

Accordance Configurations :
 
Mac : 2009 27" iMac                 Windows : HP 4540s laptop
      Intel Core Duo                          Intel i5 Ivy Bridge
      12GB RAM                                8GB RAM
      Accordance 11.0.4                       Accordance 11.0.4
      OSX 10.10.2 (Yosemite)                  Win 7 Professional x64 SP1


#2 Joel Brown

Joel Brown

    Administrator

  • Admin
  • 3,256 posts
  • Gender:Male
  • Location:Houston, TX
  • Accordance Version:11.x
  • Platforms:Mac OS X, Windows

Posted 27 January 2013 - 08:58 PM

Can you include part of your source file as an attachment?  My guess is that you aren't doing the chapter/verse numbers right, so Accordance doesn't know that those are individual verses.

 

If you import it correctly, every chapter number will show up if you set the Text Display to Separate Verses.  If they are still missing at that point, something is wrong with your input file.  If they are only missing when displayed as Paragraphs, then it may have to do with paragraph markers.


Joel Brown

By day: Consultant for Oaktree
By night: Freelance Trombonist and Private Instructor

#3 Daniel Semler

Daniel Semler

    Mithril

  • Active Members
  • PipPipPipPipPipPip
  • 2,011 posts
  • Gender:Male
  • Accordance Version:11.x

Posted 27 January 2013 - 10:10 PM

Hi Joel,

 

  Here's the latest version including John 1:6-1:14. I changed from merely using the book and verse initially and then using just verse numbers to fully specifying Book Ch:verse, but the result was the same. Attached in a copy of the source file and the imported result.

 

Thx

D

Attached Files


Sola lingua bona est lingua mortua

ἡ μόνη ἀγαθὴ γλῶσσα γλῶσσα νεκρὰ ἐστιν

lišanu ēdēnitu damqitu lišanu mītu

 

Accordance Configurations :
 
Mac : 2009 27" iMac                 Windows : HP 4540s laptop
      Intel Core Duo                          Intel i5 Ivy Bridge
      12GB RAM                                8GB RAM
      Accordance 11.0.4                       Accordance 11.0.4
      OSX 10.10.2 (Yosemite)                  Win 7 Professional x64 SP1


#4 Daniel Semler

Daniel Semler

    Mithril

  • Active Members
  • PipPipPipPipPipPip
  • 2,011 posts
  • Gender:Male
  • Accordance Version:11.x

Posted 27 January 2013 - 10:21 PM

One more data point. If I change the file encoding from UTF8 to Mac Roman the paragraphing starts working but the numbering is still not right.

 

Thx

D


Sola lingua bona est lingua mortua

ἡ μόνη ἀγαθὴ γλῶσσα γλῶσσα νεκρὰ ἐστιν

lišanu ēdēnitu damqitu lišanu mītu

 

Accordance Configurations :
 
Mac : 2009 27" iMac                 Windows : HP 4540s laptop
      Intel Core Duo                          Intel i5 Ivy Bridge
      12GB RAM                                8GB RAM
      Accordance 11.0.4                       Accordance 11.0.4
      OSX 10.10.2 (Yosemite)                  Win 7 Professional x64 SP1


#5 Joel Brown

Joel Brown

    Administrator

  • Admin
  • 3,256 posts
  • Gender:Male
  • Location:Houston, TX
  • Accordance Version:11.x
  • Platforms:Mac OS X, Windows

Posted 27 January 2013 - 10:28 PM

Hi, Daniel.

 

I can confirm your result when importing the text, on both the paragraph issues and the versification.

 

The paragraphs not splitting up when UTF8 as opposed to MacRoman definitely seems to be a bug - we'll fix it right away!

 

The versification is not a bug, as far as I can tell.  If a book has only one chapter, Accordance doesn't show the chapter number as it is redundant.  E.g. Jude 7, Obad 8, etc.  In your test file, I added some content to John 2:1, and when imported the chapter numbers were showing.  So, if its important to see the chapter numbers, even if you only have been doing translation in one chapter of a book, consider adding a blank verse in the next chapter of the book, so that Accordance understands this is a multichapter book.


Joel Brown

By day: Consultant for Oaktree
By night: Freelance Trombonist and Private Instructor

#6 Daniel Semler

Daniel Semler

    Mithril

  • Active Members
  • PipPipPipPipPipPip
  • 2,011 posts
  • Gender:Male
  • Accordance Version:11.x

Posted 27 January 2013 - 10:33 PM

Hi Joel,

 

  Thank you for this. OK, for now I'll use Mac Roman. I would argue the toss on the chapter numbering personally but its not a big deal now I know what's going on. Incidentally I could not find that in the documentation so perhaps a note needs adding on that account. Or I missed it.

 

  Anyhow many thanx for checking it out.

 

thx

D


Sola lingua bona est lingua mortua

ἡ μόνη ἀγαθὴ γλῶσσα γλῶσσα νεκρὰ ἐστιν

lišanu ēdēnitu damqitu lišanu mītu

 

Accordance Configurations :
 
Mac : 2009 27" iMac                 Windows : HP 4540s laptop
      Intel Core Duo                          Intel i5 Ivy Bridge
      12GB RAM                                8GB RAM
      Accordance 11.0.4                       Accordance 11.0.4
      OSX 10.10.2 (Yosemite)                  Win 7 Professional x64 SP1


#7 Christopher Smith

Christopher Smith

    Member

  • Members
  • Pip
  • 6 posts
  • Gender:Male
  • Accordance Version:10.x

Posted 18 February 2013 - 01:04 AM

I am also attempting to create a user text. I've done the book of Galatians, but the file will not import. The error message is here ( http://encarnado.net...AccordError.png ).

 

Here's the code for the first verse, where the problem occurs:

 

Gal 1:1 ¶ The Apostle Paul wrote a letter to the Christians in Galatia province. We call this letter <b>Galatians</b>. <i>I</i>, Paul, <i>write this letter to you. I remind you that I am</i> an apostle. That is not because a group of people <i>appointed me</i>, nor because a human being <i>sent me to be an apostle</i>. Instead, Jesus Christ and God <i>our heavenly</i> Father, who caused Jesus to become alive again after he died, have <i>appointed and</i> sent <i>me to be an apostle</i>.

 

The error message seems to imply that, although I've closed the italics tag before "Paul," I'm not permitted to open another italics tag??  I'm guessing that the meaning of "without removing it" is "without closing it".

 

Perhaps I've discovered a bug, but I don't see an open italics tag which hasn't been closed before that point ("write this letter...").

 

Thanks for any help you can offer.

Chris


Edited by Christopher Smith, 18 February 2013 - 01:05 AM.


#8 Daniel Semler

Daniel Semler

    Mithril

  • Active Members
  • PipPipPipPipPipPip
  • 2,011 posts
  • Gender:Male
  • Accordance Version:11.x

Posted 18 February 2013 - 11:45 AM

Hi Christopher,

 

  I have not had time to do a test on this so I'll just ask if you've tried this with both Mac Roman and UTF encoding schemes. This is a wild guess based only on my own previous experience in this post. It might be worth a quick try.

 

thx

D


Sola lingua bona est lingua mortua

ἡ μόνη ἀγαθὴ γλῶσσα γλῶσσα νεκρὰ ἐστιν

lišanu ēdēnitu damqitu lišanu mītu

 

Accordance Configurations :
 
Mac : 2009 27" iMac                 Windows : HP 4540s laptop
      Intel Core Duo                          Intel i5 Ivy Bridge
      12GB RAM                                8GB RAM
      Accordance 11.0.4                       Accordance 11.0.4
      OSX 10.10.2 (Yosemite)                  Win 7 Professional x64 SP1


#9 Joel Brown

Joel Brown

    Administrator

  • Admin
  • 3,256 posts
  • Gender:Male
  • Location:Houston, TX
  • Accordance Version:11.x
  • Platforms:Mac OS X, Windows

Posted 18 February 2013 - 12:47 PM

I can confirm that this is a bug in importing the unicode, try setting your text to MacRoman until we fix it in 10.1.4.


Joel Brown

By day: Consultant for Oaktree
By night: Freelance Trombonist and Private Instructor

#10 Christopher Smith

Christopher Smith

    Member

  • Members
  • Pip
  • 6 posts
  • Gender:Male
  • Accordance Version:10.x

Posted 18 February 2013 - 09:50 PM

Thanks, Daniel & Joel. My text is formatted as UTF8, so that is the issue (until the fix).



#11 Fabian

Fabian

    Gold

  • Active Members
  • PipPipPipPip
  • 464 posts
  • Gender:Male
  • Interests:www.internetkirche.com
    www.iglesia-del-internet.com
  • Accordance Version:11.x
  • Platforms:Mac OS X, iOS

Posted 13 February 2015 - 07:06 AM

How many ¶ are too much?

 

By 15053 ¶ comes the pop-up

 

Greetings

 

Fabian

Attached Files


Mac Air (13-inch, Mid 2013)

1,3 GHz Intel Core i5

4GB Ram

Next time: I'll buy only one with Retina, and hopefully without a glossy screen. A faster CPU and more RAM.

 

Yosemite 10.10.3

Accordance 11.0.4 and waiting on 11.1

 

iPhone 4S

iOS 8.3

iAccord 2.0


#12 Arnold

Arnold

    Member

  • Members
  • Pip
  • 8 posts
  • Gender:Male
  • Accordance Version:8.x

Posted 13 March 2015 - 09:54 AM

I've successfully imported two user Bibles and use them daily. But in the psalms the syncing isn't accurate. If I have Psalm 23:1 open in English I'm looking at Psalm 25:4 in my imported Bible. And yet if I search for Psalm 23 in the imported Bible it takes me there accurately but shows me Psa. 22:14 in the English. Looking at the import file there isn't anything funny going on that I can find with the references. Ideas?



#13 Daniel Semler

Daniel Semler

    Mithril

  • Active Members
  • PipPipPipPipPipPip
  • 2,011 posts
  • Gender:Male
  • Accordance Version:11.x

Posted 13 March 2015 - 01:47 PM

Hey Arnold, I'm wondering if this is a Psalms Old Greek versification versus Masoretic Text versification issue. What is the text the user bible is from ?

 

thx

D


Sola lingua bona est lingua mortua

ἡ μόνη ἀγαθὴ γλῶσσα γλῶσσα νεκρὰ ἐστιν

lišanu ēdēnitu damqitu lišanu mītu

 

Accordance Configurations :
 
Mac : 2009 27" iMac                 Windows : HP 4540s laptop
      Intel Core Duo                          Intel i5 Ivy Bridge
      12GB RAM                                8GB RAM
      Accordance 11.0.4                       Accordance 11.0.4
      OSX 10.10.2 (Yosemite)                  Win 7 Professional x64 SP1


#14 Fabian

Fabian

    Gold

  • Active Members
  • PipPipPipPip
  • 464 posts
  • Gender:Male
  • Interests:www.internetkirche.com
    www.iglesia-del-internet.com
  • Accordance Version:11.x
  • Platforms:Mac OS X, iOS

Posted 13 March 2015 - 02:07 PM

I've successfully imported two user Bibles and use them daily. But in the psalms the syncing isn't accurate. If I have Psalm 23:1 open in English I'm looking at Psalm 25:4 in my imported Bible. And yet if I search for Psalm 23 in the imported Bible it takes me there accurately but shows me Psa. 22:14 in the English. Looking at the import file there isn't anything funny going on that I can find with the references. Ideas?

 

Some chapter has to much verse in it . 

 

There is some few changes to the KJV verse order possible, but the best ist to give them the KJV verse order. 

 

http://www.accordanc...n +false +place

 

Greetings

 

Fabian


Mac Air (13-inch, Mid 2013)

1,3 GHz Intel Core i5

4GB Ram

Next time: I'll buy only one with Retina, and hopefully without a glossy screen. A faster CPU and more RAM.

 

Yosemite 10.10.3

Accordance 11.0.4 and waiting on 11.1

 

iPhone 4S

iOS 8.3

iAccord 2.0





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users