Jump to content


SBL Hebrew font problems

Mac Hebrew font

  • Please log in to reply
1 reply to this topic

#1 Robert Holmstedt

Robert Holmstedt


  • Accordance
  • 897 posts
  • Gender:Male
  • Accordance Version:12.x
  • Platforms:Mac OS X, iOS

Posted 03 November 2013 - 02:23 PM

I'm having a vexing font problem. A short history will provide the context for my headache.


- on the advice of a colleague, 3 weeks ago I did a clean install of Mountain Lion. As my colleague hinted, after this and upon reinstalling LibreOffice and Pages I found that the SBL Hebrew font displayed vowels and accents perfectly (previous to this, the vowels and especially accents were off and only displayed correctly in Mellel). This was true for Ezra SIL and other Biblical Hebrew fonts. 


- for some reason, in the past 3 days, the font problem returned, but with a twist. SBL Hebrew (and SBL Biblit, Ezra SIL, etc.) had really weird spacing problems in LibreOffice, OpenOffice, and NeoOffice (tried them all), but look beautiful in Pages and TextEdit (and, of course, Mellel). 


- I did some house-cleaning (emptied font caches, re-installed fonts, etc.; used Onyx, Yasu, and others), but nothing works to fix the problem. As it stands, the fonts works only in Apple programs and Mellel and displays offset vowels and accents in all other Office suites.


Does anyone have any idea what the source of my problem might be? I'd prefer not to do another clean install with Mavericks over the Christmas break (I found out last time that using a Time Machine backup to restore after the clean install of Mountain Lion brought didn't work to fix the font problem; only a clean install of OS and all programs and fonts worked the magic.)


Thanks for any help.


Edit: here's a pic of what the font looks like in NeoOffice

Attached File  Screen Shot 2013-11-03 at 2.19.54 PM.png   25.23KB   1 downloads

Edited by Robert Holmstedt, 03 November 2013 - 02:25 PM.

Professor, Hebrew and Northwest Semitic Languages
Dept. of Near and Middle Eastern Civilizations
The University of Toronto
blog: ancienthebrewgrammar.wordpress.com

#2 Bob Kuo

Bob Kuo


  • Active Members
  • PipPipPip
  • 116 posts
  • Gender:Male
  • Location:Champaign-Urbana, IL
  • Accordance Version:11.x
  • Platforms:Mac OS X, Windows, iOS

Posted 03 November 2013 - 05:12 PM

Robert - that's really bizarre.  I've seen a similar problem - the vowel points are not aligned properly - but only with the built in Unicode fonts.  If re-installing the font + emptying the font caches didn't do the trick, I'm not sure what else to try.

Also tagged with one or more of these keywords: Mac, Hebrew, font

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users