Jump to content


Photo

Interlinear formatting

interlinear

  • Please log in to reply
5 replies to this topic

#1 jrethorn

jrethorn

    Member

  • Members
  • Pip
  • 3 posts
  • Accordance Version:11.x
  • Platforms:Mac OS X, Windows, iOS

Posted 26 May 2015 - 08:44 AM

I've attached a few different screenshots of issues when using the interlinear feature. I see three different things that are causing problems. 

 

1. When I have an English translation added, words sometimes get cutoff (screenshot 1 with the end of v18 & beginning of v19).

2. It seems like the dynamic resizing of the zones does not translate well. I have to keep fidgeting with the zone size to get the text to display properly (screenshot 2 showing PrtSpeech and tag being cut off).

3. The interlinear does not always line up the different elements very well (screenshot 3 shows the text does not line up with the other parts of the interlinear).

 

I'm using 11.0.6 on a MacBook Pro Retina (10.10.3)

Attached Files



#2 Timothy Jenney

Timothy Jenney

    Mithril

  • Accordance
  • 3,285 posts
  • Gender:Male
  • Location:sunny Winter Haven, FL
  • Interests:a great cup of coffee, sci-fi, jazz and the blues, kayaking, camping, fishing and the great outdoors
  • Accordance Version:12.x
  • Platforms:Mac OS X, iOS

Posted 26 May 2015 - 09:15 AM

What you are describing is common—and common to printed interlinears as well. When single words in one language must be translated into phrases in another, the resulting differences in size force some real compromises. Changing the size of the column to accommodate a phrase makes spreads the single words (in the other language) so far apart it makes it difficult to read that text easily. Changing the size of just a single cell means the columns no longer line up neatly.

 

I think Accordance handles these issues as well as any interlinear I have seen. The column highlighting also makes it easy to see offset material, which is something no printed edition has.

 

I imagine we'll keep trying to tweak things to make them better, but you might try increasing the size of your font (or your zone) when using an interlinear. Magnifying the interlinear zone, another option,  will allow it to occupy the maximum space on your display.

 

Thanks for the feedback!


Blessings,
"Dr. J"

Timothy P. Jenney, Ph. D.
"Lighting the Lamp" Host and Producer
Academic Licensing Assistant

iMac: Late 2014 27" 5k display, 4.0 GHz quad core i7, 24 GB RAM, 500 GB SSD, AMD Radeon R9 M295X 4096 MB, macOS Sierra 10.13
MBP: Early 2011 17" MBP (8,3), 2.3 GHz quad core i7, 16 GB RAM, 480 SSD + 1 TB SSD, AMD Radeon HD 6750M, macOS Sierra 10.13
iPhone 7 plus: 128 GB, iOS 11.x

#3 Joel Brown

Joel Brown

    Administrator

  • Admin
  • 6,228 posts
  • Gender:Male
  • Location:Houston, TX
  • Accordance Version:13.x
  • Platforms:Mac OS X, Windows, iOS

Posted 27 May 2015 - 05:04 AM

The other recommendation, especially when displaying long interlinear elements, is to display as Separate Verses rather than paragraph mode, as this will alleviate most of your issues.
  • rpavich likes this

Joel Brown

By day: Lead Software Engineer at Accordance
By night: Freelance Trombonist


#4 jrethorn

jrethorn

    Member

  • Members
  • Pip
  • 3 posts
  • Accordance Version:11.x
  • Platforms:Mac OS X, Windows, iOS

Posted 27 May 2015 - 08:38 AM

Thanks for the recommendations. Switching from paragraph mode really helped. I tried magnifying the zone as well, but it seems to leave the line wrapping in place. Is there a way to change the wrapping so it takes advantage of the extra space available? I attached a screen shot of the view.

Attached Files



#5 Timothy Jenney

Timothy Jenney

    Mithril

  • Accordance
  • 3,285 posts
  • Gender:Male
  • Location:sunny Winter Haven, FL
  • Interests:a great cup of coffee, sci-fi, jazz and the blues, kayaking, camping, fishing and the great outdoors
  • Accordance Version:12.x
  • Platforms:Mac OS X, iOS

Posted 27 May 2015 - 08:42 AM

It looks to me as if you have set your preferences to Preferences>Appearance>Text Appearance>Limit Text Width.

 

Try turning it off and see if it eliminates those wide margins.


  • jeremyduncan likes this
Blessings,
"Dr. J"

Timothy P. Jenney, Ph. D.
"Lighting the Lamp" Host and Producer
Academic Licensing Assistant

iMac: Late 2014 27" 5k display, 4.0 GHz quad core i7, 24 GB RAM, 500 GB SSD, AMD Radeon R9 M295X 4096 MB, macOS Sierra 10.13
MBP: Early 2011 17" MBP (8,3), 2.3 GHz quad core i7, 16 GB RAM, 480 SSD + 1 TB SSD, AMD Radeon HD 6750M, macOS Sierra 10.13
iPhone 7 plus: 128 GB, iOS 11.x

#6 jrethorn

jrethorn

    Member

  • Members
  • Pip
  • 3 posts
  • Accordance Version:11.x
  • Platforms:Mac OS X, Windows, iOS

Posted 27 May 2015 - 11:45 AM

Thanks. That fixed it. Everything looks/works much better now.


Edited by jrethorn, 27 May 2015 - 11:45 AM.

  • Timothy Jenney likes this





Also tagged with one or more of these keywords: interlinear

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users