Jump to content


Photo

Installing on Debian/Linux with Internet Connection Problem

LInux Debian Accordance Wine Internet Connection

  • Please log in to reply
6 replies to this topic

#1 jelee

jelee

    Member

  • Members
  • Pip
  • 2 posts
  • Accordance Version:11.x
  • Platforms:Windows, None

Posted 09 February 2016 - 08:05 AM

Hi,

 

I purchased Accordance 11 through school.  I am using Debian GNU/Linux and have a problem at installing Accordance.  I patched the WINE (which I downloaded from Accordance support web page).  Follow is the information of my computer:

$ uname -a
Linux desktop-je 3.16.0-4-686-pae #1 SMP Debian 3.16.7-ckt20-1+deb8u3 (2016-01-17) i686 GNU/Linux

$ wine --version
wine-1.7.44

The installing itself was OK but when I try to set it up, it always says "Active Internet Connection not found."  Please see the attached screetshot for the error message.

 

I checked with my WINE and it has internet connection.  To make sure, I installed wine version of firefox which works very well.

$ wine ipconfig /all
fixme:ole:RemUnknown_QueryInterface No interface for iid {00000019-0000-0000-c000-000000000046}
    Hostname. . . . . . . . . . . . . : desktop-je
    Node type . . . . . . . . . . . . : Hybrid
    IP routing enabled. . . . . . . . : No

Ethernet adaptor lo

    Connection-specific DNS suffix. . : 
    Description . . . . . . . . . . . : lo
    Physical address. . . . . . . . . : 
    DHCP enabled. . . . . . . . . . . : No
    IPv4 address. . . . . . . . . . . : 127.0.0.1
    IPv6 address. . . . . . . . . . . : ::1
    Default gateway . . . . . . . . . : 

Ethernet adaptor eth0

    Connection-specific DNS suffix. . : hsd1.il.comcast.net
    Description . . . . . . . . . . . : eth0
    Physical address. . . . . . . . . : 50-E5-49-EC-9D-06
    DHCP enabled. . . . . . . . . . . : No
    IPv4 address. . . . . . . . . . . : 192.168.1.129
    IPv6 address. . . . . . . . . . . : fe80::52e5:49ff:feec:9d06%2
    Default gateway . . . . . . . . . : 192.168.1.1

Any help on this?  I am not in a hurry because I have BibleWorks as well, but I do want to use what I paid for.

 

Thank you, and the grace of our Lord and Saviour Jesus Christ be with you all.

 

Je

Attached Files


Edited by jelee, 09 February 2016 - 08:05 AM.


#2 Michel Gilbert

Michel Gilbert

    Platinum

  • Active Members
  • PipPipPipPipPip
  • 1,230 posts
  • Gender:Male
  • Accordance Version:12.x
  • Platforms:Mac OS X, iOS, Android

Posted 10 February 2016 - 10:15 AM

Hi Je,

 

Accordance doesn't support Linux, so you might not get a response to your question.

 

If you want to cast your vote for developing a Linux version, you can revive one of the many old posts on the subject, or start a new one under Feature Requests.

 

Only a few of us have gotten Acc to run under Wine. I got it to run under the latest Wine (1.9x now) and Wine Staging, but there are a few problems; see at http://www.accordanc...= wine staging . But I didn't have any problems with my Internet connection - it activated, and downloaded and installed my Modules.

 

Regards,

 

Michel


  • Fabian likes this

#3 eflange

eflange

    Member

  • Members
  • Pip
  • 2 posts
  • Accordance Version:11.x
  • Platforms:Mac OS X

Posted 13 April 2016 - 09:46 PM

Hi Je,

 

I had some trouble getting Accordance to work, but I've got it working like the others have..  Here's the step-by-step process I used.  This probably isn't the cleanest install process, but I wanted to document what worked for me.

 

Accordance Version: 11.0.6 - you can't browse to it from the Accordance website, but a link to this version is here.  (the newest version - 11.1.6 as of 4/13/16 - may work, but I wanted to stick with the version that everyone else got working for now.)

Computer: Dell Chromebook 13, dual-booting ChromeOS and GalliumOS 1.0 (www.galliumos.org), based off of Ubuntu 15.04 vivid

 

First, I downloaded wine1.8 - not sure if it was needed, but I wanted to be consistent.  I'll use this for other apps using wine.

$ sudo dpkg --add-architecture i386
$ sudo add-apt-repository ppa:ubuntu-wine/ppa
$ sudo apt-get update
$ sudo apt-get install wine1.8

Then I downloaded wine-staging:

$ sudo add-apt-repository ppa:wine/wine-builds
$ sudo apt-get update
$ sudo apt-get install --install-recommends wine-staging

Next, I downloaded 11.0.6 from Accordance's website.

Then I set wine-staging be the version to install it.

$ cd ~/Downloads
$ /opt/wine-staging/bin/wine Accordance11.0.6.exe

That started the install process.  A few times popups appeared that asked me to install Gecko and something else - I said "Cancel" on each of these when they popped up.

 

I then followed the prompts.  When I got to the internet verification part, it worked right away and began downloading modules and fired right up.

 

Hope that helps.  I'm no expert, but I've followed a few of the threads around here and wanted to share what worked for me.  I'm thrilled to use Accordance on a Chromebook!


Edited by eflange, 13 April 2016 - 09:47 PM.


#4 Michel Gilbert

Michel Gilbert

    Platinum

  • Active Members
  • PipPipPipPipPip
  • 1,230 posts
  • Gender:Male
  • Accordance Version:12.x
  • Platforms:Mac OS X, iOS, Android

Posted 14 April 2016 - 10:42 PM

Hi eflange,

 

I tried what you said exactly, except I used the Accordance Demo instead of 11.0.6 (to avoid using another activation). I get the same results as before, lots of flickering, etc., when I used:

 

sudo dpkg --add-architecture i386

sudo add-apt-repository ppa:wine/wine-builds
sudo apt-get update
sudo apt-get install --install-recommends winehq-staging

(from https://wiki.winehq.org/Ubuntu ).

Does your Acc install flicker at all when you hover your mouse over texts?

If not, I wonder if my problem is my AMD Radeon graphics driver.

Thanks, and regards,

Michel



#5 eflange

eflange

    Member

  • Members
  • Pip
  • 2 posts
  • Accordance Version:11.x
  • Platforms:Mac OS X

Posted 05 July 2016 - 09:42 PM

Michael,

 

Sorry for the delay.  Didn't realize you replied.

 

I get a little bit of flickering if I scroll through a lot of text, but it's not enough for it to bother me too much.  No flickering when the mouse hovers over texts on my install.  All told, Accordance is definitely usable. 

 

It's possible it could be the Radeon Graphics driver, certainly.  I wouldn't know. It may also be your version of Ubuntu?  I've got it working in WIne-staging for Ubuntu 15.04 and now 16.04.  Maybe that extra jump in versions was enough...?

 

Sorry to say I'm still a Linux novice.  



#6 jelee

jelee

    Member

  • Members
  • Pip
  • 2 posts
  • Accordance Version:11.x
  • Platforms:Windows, None

Posted 07 September 2016 - 09:43 PM

Hi,

as of today (Sept 7, 2016), installation works fine.  I tried on my new laptop with Ubuntu 16.04 LTS.  Maybe both wine and accordance has new version and the problem solved.

 

But it is not stable.  I am thankful that at least this problem is solved.

Thank you all for your help.



#7 nmax

nmax

    Member

  • Members
  • Pip
  • 2 posts
  • Accordance Version:12.x
  • Platforms:Windows, None

Posted 12 November 2018 - 02:45 PM

For some reason Accordance has no internet access running under wine:

 

https://www.accordan...ing-wine/page-2

 

If you have any suggestions for wine-config, installed Windows DLL/components, etc. I'd be most grateful.

 

Is your Accordance-via-Wine instance still working?







Also tagged with one or more of these keywords: LInux, Debian, Accordance, Wine, Internet Connection

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users